Ethernet is disabled. How to enable it?

Asked by Mrinal Saurabh on 2010-10-29

Though I have configured Iv4 settings of eth0 in wired connetions, I can't access Internet and LAN. Earlier it worked well, and it is working with Windows. When I checked in Hardware in System Administration, it shows Ethernet disabled. What needs to be done??

I use Ubuntu 10.10.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-31
Last reply:
2010-10-29
Knuth Gurkasch (sinn3r) said : #1

Checked you have enabled the interface in the gui config?

Output of ifconfig -a?

Mrinal Saurabh (msaurabh92) said : #2

eth0 Link encap:Ethernet HWaddr 00:1e:68:ff:1f:20
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:43 Base address:0x2000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1744 (1.7 KB) TX bytes:1744 (1.7 KB)

wlan0 Link encap:Ethernet HWaddr 00:17:c4:3e:fe:c9
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Can you give the output of:

sudo lshw -C network

Thanks

Mrinal Saurabh (msaurabh92) said : #4

yeah.. sure

q@q-laptop:~$ sudo lshw -C network
[sudo] password for q:
  *-network DISABLED
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 02
       serial: 00:1e:68:ff:1f:20
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:43 ioport:1000(size=256) memory:52410000-52410fff memory:52400000-5240ffff memory:52420000-5242ffff
  *-network
       description: Wireless interface
       physical id: 2
       bus info: usb@2:7
       logical name: wlan0
       serial: 00:17:c4:3e:fe:c9
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8187 driverversion=2.6.35-22-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg

thnx

ok are the lights flashing where the Ethernet cable connects?

http://ubuntu-virginia.ubuntuforums.org/showthread.php?p=9878333

looks like you may need to compile the driver.

Mrinal Saurabh (msaurabh92) said : #6

yeah... the lights are flashing

Mrinal Saurabh (msaurabh92) said : #7

and what i've got to do with the above link?? can u plz give me more details??

Mrinal Saurabh (msaurabh92) said : #8

the message that shows during installation of above driver:

Check old driver and unload it.
rmmod r8169
ERROR: Removing 'r8169': Operation not permitted
Build the module and install

My device configuration:

Ethernet interface
/0/100/1c.5/0

product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10EC:8136]
vendor: Realtek Semiconductor Co., Ltd. [10EC]
bus info: pci@0000:04:00.0
logical name: eth0
version: 02
serial: 00:1e:68:ff:1f:20
width: 64 bits
clock: 33MHz
capabilities:
 bus mastering,
 PCI capabilities listing,
 extension ROM,
 ethernet,
 Physical interface
configuration:
 broadcast: yes
 driver: r8169
 driverversion: 2.3LK-NAPI
 latency: 0
 multicast: yes
resources:
 irq: 43
 ioport: 1000(size=256)
 memory: 52410000-52410fff
 memory: 52400000-5240ffff
 memory: 52420000-5242ffff
this device has been disabled

plz help.

You need to compile the source. There are links in the text to source code which you can then make.

Mrinal Saurabh (msaurabh92) said : #10

It says I've got to remove the previous hardware driver before reinstalling. how to do that??

Just download the tar.gz and run the autorun.sh file (you may need to mark it as executable, use: chmod +x filename to do this)

Book 'em Dano (heymrdjd) said : #12

Try sudo ./autorun.sh or sudo sh autorun.sh

Mrinal Saurabh (msaurabh92) said : #13

Check old driver and unload it.
rmmod r8169
ERROR: Removing 'r8169': Operation not permitted
Build the module and install

this message shows up when i run the autorun.sh file in terminal.

plz help

Can you help with this problem?

Provide an answer of your own, or ask Mrinal Saurabh for more information if necessary.

To post a message you must log in.