ubuntu 10.10: can't connect wireless (nb asus, chipset 3945abg)

Asked by camillo cecere on 2010-10-22

Can't get working Wireless connection, driver seems to be ok.

Following the output of some comands:

root@charlie-F6E:~# rfkill list
0: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

root@charlie-F6E:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1f:c6:32:d5:55
          indirizzo inet:192.168.1.2 Bcast:192.168.1.255 Maschera:255.255.255.0
          indirizzo inet6: fe80::21f:c6ff:fe32:d555/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:108 errors:0 dropped:0 overruns:0 frame:0
          TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:37214 (37.2 KB) Byte TX:23550 (23.5 KB)
          Interrupt:45 Indirizzo base:0x2000

lo Link encap:Loopback locale
          indirizzo inet:127.0.0.1 Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:28 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:1680 (1.6 KB) Byte TX:1680 (1.6 KB)

wlan0 Link encap:Ethernet HWaddr 00:1c:bf:a2:03:4f
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:0 (0.0 B) Byte TX:0 (0.0 B)

root@charlie-F6E:~# lshw -c Network
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 01
       serial: 00:1f:c6:32:d5:55
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.2 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:45 ioport:a800(size=256) memory:fdcff000-fdcfffff memory:fdcc0000-fdcdffff
  *-network DISABLED
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 02
       serial: 00:1c:bf:a2:03:4f
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=2.6.35-22-generic-pae firmware=15.32.2.9 latency=0 link=yes multicast=yes wireless=IEEE 802.11abg
       resources: irq:47 memory:fddff000-fddfffff

root@charlie-F6E:~# dmesg -c
.
.
.
.
[ 24.160051] eth0: no IPv6 routers present
[ 24.363935] Bluetooth: L2CAP ver 2.14
[ 24.363939] Bluetooth: L2CAP socket layer initialized
[ 24.370739] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 24.370743] Bluetooth: BNEP filters: protocol multicast
[ 24.379171] Bluetooth: SCO (Voice Link) ver 0.6
[ 24.379174] Bluetooth: SCO socket layer initialized
[ 24.643909] Bluetooth: RFCOMM TTY layer initialized
[ 24.643915] Bluetooth: RFCOMM socket layer initialized
[ 24.643918] Bluetooth: RFCOMM ver 1.11
[ 35.860134] Skipping EDID probe due to cached edid
[ 36.284101] Skipping EDID probe due to cached edid
[ 36.700060] Skipping EDID probe due to cached edid
[ 37.132064] Skipping EDID probe due to cached edid
[ 38.404045] Skipping EDID probe due to cached edid
[ 42.952130] Skipping EDID probe due to cached edid
[ 236.752465] iwl3945 0000:02:00.0: Radio disabled by HW RF Kill switch

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-22
Last reply:
2010-10-22

What is the output of:

sudo iwlist scan | head -n 25

Thanks

root@charlie-F6E:~# iwlist scan | head -n 25
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

sudo rmmod -f iwl3945
sudo modprobe iwl3945 disable_hw_scan=1

may work

Done, still doesn't work.

Messages from /var/log/messages:

Oct 22 19:53:29 charlie-F6E kernel: [ 5381.920704] iwl3945 0000:02:00.0: PCI INT A disabled
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.296812] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.296816] iwl3945: Copyright(c) 2003-2010 Intel Corporation
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.296891] iwl3945 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.335584] iwl3945 0000:02:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.335588] iwl3945 0000:02:00.0: Detected Intel Wireless WiFi Link 3945ABG
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.353451] iwl3945 0000:02:00.0: loaded firmware version 15.32.2.9
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.354479] iwl3945 0000:02:00.0: Radio disabled by HW RF Kill switch
Oct 22 19:53:37 charlie-F6E kernel: [ 5389.355960] iwl3945 0000:02:00.0: Radio disabled by HW RF Kill switch

Ok:

Radio disabled by HW RF Kill switch

Is a huge give away, do you have a little switch on the system to turn the wifi off and on? Make sure the wireless is enabled then reboot

Yes, there is an f-key to turn it on/off.

You can see it from the following:

root@charlie-F6E:~# rfkill list
0: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
3: phy2: Wireless LAN
 Soft blocked: yes ---> (it's off)
 Hard blocked: no

root@charlie-F6E:~# rfkill list
0: hci0: Bluetooth
 Soft blocked: yes
 Hard blocked: no
3: phy2: Wireless LAN
 Soft blocked: no ---> (it's on)
 Hard blocked: no

Can you help with this problem?

Provide an answer of your own, or ask camillo cecere for more information if necessary.

To post a message you must log in.