Ubuntu 10.10 Lose Wireless Network Connectivity when on battery power.

Asked by Joe on 2010-10-11

I just did a clean install of 10.10 on an ACER Aspire 5515. It had 10.04 up to that point, with no issues at all. Now, when I unplug the AC, I lose wireless network connectivity. The Network Connection status shows that it tries to connect, and it eventually asks for password. I re-enter p/w but it won't connect. If I plug the power cord back in, it still won't connect until I restart the system. If I start up in battery mode, it won't connect at all. I have the broadcom driver installed, same as with 10.04.
I'm really just at user level, but have installed every version since 9.04 on the same machine with no issues. Any suggestions on how to correct this, as the laptop goes with me a lot, and I have to be able to use it on battery and still have wireless connection.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-23
Last reply:
2010-10-12

Please install wicd then remove network-manager package, i found wicd work better than network-manager

Joe (joesbunker) said : #2

I tried this, and it made matters MUCH worse. Now, the broadcomm drivers won't activate, WICD won't recognize any wireless networks, and after I tried and failed, the system now won't boot. I am so disappointed in this release... I have never had this much trouble with installing an upgrade for ubuntu, and I've been a user since 9.04 with really no problems. This one has me stumped. The original problem was that I would lose wireless internet as soon as I went to DC power (Battery). The only way to restore this was to plug into AC and reboot.

Now, it's a mess and I'm not sure how to get it back except just wipe it out and go back to Lucid, which works absolutely fine for me.

Can you help with this problem?

Provide an answer of your own, or ask Joe for more information if necessary.

To post a message you must log in.