3 mobile dongle ZTE MF112 does not register in network connections

Asked by Manjuvajra on 2010-10-03

I have been using a vodafone mobile connection dongle that has been working OK but only at slow speeds. I have changed to a 3 mobile dongle ZTE MF112 and although it works very well on a windows computer and on my net book with Ubuntu for netbooks it does not work on my Fujitsu Amilo Pi 2515 with Ubuntu 10.04. I have followed the suggested procedure of ejecting the disk that first appears and entered the details with the wizard but still no listing in the Network manager.

Also my vodafone mobile connect listing has also vanished so I can use neither dongle.

Can anyone help?

With thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-03
Last reply:
2010-10-04

What windows does or doesn't do is of no value, it is a different OS with different support

Boot and login to the OS without the device attatched, let the OS settle. launch a terminal and run:

lsusb

Then plug in the device, wait 10 seconds then run:

echo; lsusb; echo; dmesg | tail

Copy the whole output and paste it here as an update

Thanks

Thomas Kr├╝ger (thkrueger) said : #2

You should install the package "usb-modeswitch" via Synaptic of the Software Center and reconnect the stick.
If that does not help please run "dmesg" in the terminal and post the lines that have been added when you plug in the stick.

Manjuvajra (thehut) said : #3

Hi actionparsnip.
Thanks for you help
The output is:
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 05b8:3112 Agiler, Inc.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 19d2:0103 ONDA Communication S.p.A.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

[ 153.378103] usb-storage: device found at 2
[ 153.378108] usb-storage: waiting for device to settle before scanning
[ 158.376583] usb-storage: device scan complete
[ 179.916056] usb 1-1: reset high speed USB device using ehci_hcd and address 2
[ 180.051587] scsi 5:0:0:0: CD-ROM HSPA USB SCSI CD-ROM 2.31 PQ: 0 ANSI: 2
[ 180.054908] sr1: scsi-1 drive
[ 180.055124] sr 5:0:0:0: Attached scsi CD-ROM sr1
[ 180.055251] sr 5:0:0:0: Attached scsi generic sg2 type 5
[ 180.289278] ISO 9660 Extensions: Microsoft Joliet Level 1
[ 180.331781] ISOFS: changing to secondary root

Manjuvajra (thehut) said : #4

Hi Thomas,

I have already installed usb-modeswitch.

The complete output from dmesg is:

[ 0.212861] PCI: Using ACPI for IRQ routing
[ 0.213140] NetLabel: Initializing
[ 0.213143] NetLabel: domain hash size = 128
[ 0.213145] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.213163] NetLabel: unlabeled traffic allowed by default
[ 0.213205] hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
[ 0.213212] hpet0: 3 comparators, 64-bit 14.318180 MHz counter
[ 0.216058] Switching to clocksource tsc
[ 0.218838] AppArmor: AppArmor Filesystem Enabled
[ 0.218855] pnp: PnP ACPI init
[ 0.218870] ACPI: bus type pnp registered
[ 0.219899] pnp 00:01: mem resource (0xf0401000-0xf0401fff) overlaps 0000:00:1c.0 BAR 15 (0xf0000000-0xf1ffffff), disabling
[ 0.221594] pnp: PnP ACPI: found 10 devices
[ 0.221598] ACPI: ACPI bus type pnp unregistered
[ 0.221604] PnPBIOS: Disabled by ACPI PNP
[ 0.221618] system 00:01: iomem range 0xfed1c000-0xfed1ffff has been reserved
[ 0.221623] system 00:01: iomem range 0xfed14000-0xfed17fff has been reserved
[ 0.221627] system 00:01: iomem range 0xfed18000-0xfed18fff has been reserved
[ 0.221631] system 00:01: iomem range 0xfed19000-0xfed19fff has been reserved
[ 0.221635] system 00:01: iomem range 0xe0000000-0xefffffff has been reserved
[ 0.221639] system 00:01: iomem range 0xfed20000-0xfed3ffff has been reserved
[ 0.221643] system 00:01: iomem range 0xfed40000-0xfed44fff has been reserved
[ 0.221647] system 00:01: iomem range 0xfed45000-0xfed8ffff has been reserved
[ 0.221657] system 00:04: iomem range 0xfed00000-0xfed003ff has been reserved
[ 0.221667] system 00:06: ioport range 0x200-0x20f has been reserved
[ 0.221670] system 00:06: ioport range 0x260-0x26f has been reserved
[ 0.221674] system 00:06: ioport range 0x300-0x30f has been reserved
[ 0.221678] system 00:06: ioport range 0x378-0x387 has been reserved
[ 0.221682] system 00:06: ioport range 0x3f0-0x3ff could not be reserved
[ 0.221686] system 00:06: ioport range 0x680-0x69f has been reserved
[ 0.221690] system 00:06: ioport range 0x800-0x80f has been reserved
[ 0.221694] system 00:06: ioport range 0x1000-0x107f has been reserved
[ 0.221698] system 00:06: ioport range 0x1180-0x11bf has been reserved
[ 0.221702] system 00:06: ioport range 0x1640-0x164f has been reserved
[ 0.221706] system 00:06: ioport range 0xfe00-0xfe00 has been reserved
[ 0.256644] pci 0000:00:1c.0: PCI bridge, secondary bus 0000:02
[ 0.256651] pci 0000:00:1c.0: IO window: 0x2000-0x2fff
[ 0.256660] pci 0000:00:1c.0: MEM window: 0xf6000000-0xf7ffffff
[ 0.256666] pci 0000:00:1c.0: PREFETCH window: 0x000000f0000000-0x000000f1ffffff
[ 0.256677] pci 0000:00:1c.2: PCI bridge, secondary bus 0000:04
[ 0.256681] pci 0000:00:1c.2: IO window: 0x3000-0x3fff
[ 0.256689] pci 0000:00:1c.2: MEM window: 0xf8000000-0xf9ffffff
[ 0.256696] pci 0000:00:1c.2: PREFETCH window: 0x000000f2000000-0x000000f3ffffff
[ 0.256707] pci 0000:00:1c.3: PCI bridge, secondary bus 0000:06
[ 0.256712] pci 0000:00:1c.3: IO window: 0x4000-0x4fff
[ 0.256720] pci 0000:00:1c.3: MEM window: 0xfa000000-0xfbffffff
[ 0.256727] pci 0000:00:1c.3: PREFETCH window: 0x000000f4000000-0x000000f5ffffff
[ 0.256737] pci 0000:00:1e.0: PCI bridge, secondary bus 0000:08
[ 0.256740] pci 0000:00:1e.0: IO window: disabled
[ 0.256748] pci 0000:00:1e.0: MEM window: disabled
[ 0.256753] pci 0000:00:1e.0: PREFETCH window: disabled
[ 0.256779] alloc irq_desc for 17 on node -1
[ 0.256782] alloc kstat_irqs on node -1
[ 0.256792] pci 0000:00:1c.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 0.256800] pci 0000:00:1c.0: setting latency timer to 64
[ 0.256813] alloc irq_desc for 18 on node -1
[ 0.256816] alloc kstat_irqs on node -1
[ 0.256821] pci 0000:00:1c.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
[ 0.256828] pci 0000:00:1c.2: setting latency timer to 64
[ 0.256840] alloc irq_desc for 19 on node -1
[ 0.256842] alloc kstat_irqs on node -1
[ 0.256848] pci 0000:00:1c.3: PCI INT D -> GSI 19 (level, low) -> IRQ 19
[ 0.256854] pci 0000:00:1c.3: setting latency timer to 64
[ 0.256864] pci 0000:00:1e.0: setting latency timer to 64
[ 0.256870] pci_bus 0000:00: resource 0 io: [0x00-0xffff]
[ 0.256874] pci_bus 0000:00: resource 1 mem: [0x000000-0xffffffff]
[ 0.256878] pci_bus 0000:02: resource 0 io: [0x2000-0x2fff]
[ 0.256882] pci_bus 0000:02: resource 1 mem: [0xf6000000-0xf7ffffff]
[ 0.256885] pci_bus 0000:02: resource 2 pref mem [0xf0000000-0xf1ffffff]
[ 0.256889] pci_bus 0000:04: resource 0 io: [0x3000-0x3fff]
[ 0.256893] pci_bus 0000:04: resource 1 mem: [0xf8000000-0xf9ffffff]
[ 0.256896] pci_bus 0000:04: resource 2 pref mem [0xf2000000-0xf3ffffff]
[ 0.256900] pci_bus 0000:06: resource 0 io: [0x4000-0x4fff]
[ 0.256904] pci_bus 0000:06: resource 1 mem: [0xfa000000-0xfbffffff]
[ 0.256907] pci_bus 0000:06: resource 2 pref mem [0xf4000000-0xf5ffffff]
[ 0.256911] pci_bus 0000:08: resource 3 io: [0x00-0xffff]
[ 0.256914] pci_bus 0000:08: resource 4 mem: [0x000000-0xffffffff]
[ 0.256968] NET: Registered protocol family 2
[ 0.257105] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.257551] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
[ 0.258078] TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
[ 0.258335] TCP: Hash tables configured (established 131072 bind 65536)
[ 0.258339] TCP reno registered
[ 0.258463] NET: Registered protocol family 1
[ 0.258490] pci 0000:00:02.0: Boot video device
[ 0.258894] cpufreq-nforce2: No nForce2 chipset.
[ 0.258934] Scanning for low memory corruption every 60 seconds
[ 0.259072] audit: initializing netlink socket (disabled)
[ 0.259086] type=2000 audit(1286133872.255:1): initialized
[ 0.272513] highmem bounce pool size: 64 pages
[ 0.272521] HugeTLB registered 4 MB page size, pre-allocated 0 pages
[ 0.274640] VFS: Disk quotas dquot_6.5.2
[ 0.274722] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.275523] fuse init (API version 7.13)
[ 0.275637] msgmni has been set to 1680
[ 0.275927] alg: No test for stdrng (krng)
[ 0.275997] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ 0.276001] io scheduler noop registered
[ 0.276003] io scheduler anticipatory registered
[ 0.276006] io scheduler deadline registered
[ 0.276063] io scheduler cfq registered (default)
[ 0.276282] alloc irq_desc for 24 on node -1
[ 0.276285] alloc kstat_irqs on node -1
[ 0.276301] pcieport 0000:00:1c.0: irq 24 for MSI/MSI-X
[ 0.276315] pcieport 0000:00:1c.0: setting latency timer to 64
[ 0.276509] alloc irq_desc for 25 on node -1
[ 0.276512] alloc kstat_irqs on node -1
[ 0.276523] pcieport 0000:00:1c.2: irq 25 for MSI/MSI-X
[ 0.276537] pcieport 0000:00:1c.2: setting latency timer to 64
[ 0.276728] alloc irq_desc for 26 on node -1
[ 0.276730] alloc kstat_irqs on node -1
[ 0.276741] pcieport 0000:00:1c.3: irq 26 for MSI/MSI-X
[ 0.276755] pcieport 0000:00:1c.3: setting latency timer to 64
[ 0.276885] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 0.276961] ACPI Error (psargs-0359): [CDW1] Namespace lookup failure, AE_NOT_FOUND
[ 0.276969] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._OSC] (Node f70130f0), AE_NOT_FOUND
[ 0.277060] ACPI Error (psargs-0359): [CDW1] Namespace lookup failure, AE_NOT_FOUND
[ 0.277068] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._OSC] (Node f70130f0), AE_NOT_FOUND
[ 0.277147] ACPI Error (psargs-0359): [CDW1] Namespace lookup failure, AE_NOT_FOUND
[ 0.277154] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._OSC] (Node f70130f0), AE_NOT_FOUND
[ 0.277255] ACPI Error (psargs-0359): [CDW1] Namespace lookup failure, AE_NOT_FOUND
[ 0.277262] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._OSC] (Node f70130f0), AE_NOT_FOUND
[ 0.277340] ACPI Error (psargs-0359): [CDW1] Namespace lookup failure, AE_NOT_FOUND
[ 0.277347] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._OSC] (Node f70130f0), AE_NOT_FOUND
[ 0.277425] ACPI Error (psargs-0359): [CDW1] Namespace lookup failure, AE_NOT_FOUND
[ 0.277431] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._OSC] (Node f70130f0), AE_NOT_FOUND
[ 0.277485] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[ 0.277864] ACPI: AC Adapter [AC0] (on-line)
[ 0.277965] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
[ 0.277969] ACPI: Power Button [PWRB]
[ 0.278026] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
[ 0.278072] ACPI: Lid Switch [LID]
[ 0.278134] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
[ 0.278138] ACPI: Sleep Button [SLPB]
[ 0.278195] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[ 0.278198] ACPI: Power Button [PWRF]
[ 0.279026] ACPI: SSDT 7f6d5b8a 001B4 (v01 PmRef Cpu0Ist 00003000 INTL 20050624)
[ 0.281544] ACPI: SSDT 7f6d5632 004D3 (v01 PmRef Cpu0Cst 00003001 INTL 20050624)
[ 0.284407] Monitor-Mwait will be used to enter C-1 state
[ 0.284449] Monitor-Mwait will be used to enter C-2 state
[ 0.284458] Marking TSC unstable due to TSC halts in idle
[ 0.284524] processor LNXCPU:00: registered as cooling_device0
[ 0.284982] ACPI: SSDT 7f6d5d3e 000C8 (v01 PmRef Cpu1Ist 00003000 INTL 20050624)
[ 0.285426] ACPI: SSDT 7f6d5b05 00085 (v01 PmRef Cpu1Cst 00003000 INTL 20050624)
[ 0.286311] Switching to clocksource hpet
[ 0.287628] processor LNXCPU:01: registered as cooling_device1
[ 0.291269] thermal LNXTHERM:01: registered as thermal_zone0
[ 0.291281] ACPI: Thermal Zone [THRM] (59 C)
[ 0.293355] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 0.295175] brd: module loaded
[ 0.295808] loop: module loaded
[ 0.295919] input: Macintosh mouse button emulation as /devices/virtual/input/input4
[ 0.296056] ata_piix 0000:00:1f.1: version 2.13
[ 0.296073] ata_piix 0000:00:1f.1: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 0.296126] ata_piix 0000:00:1f.1: setting latency timer to 64
[ 0.296227] scsi0 : ata_piix
[ 0.296321] scsi1 : ata_piix
[ 0.297098] ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x1810 irq 14
[ 0.297102] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x1818 irq 15
[ 0.297618] Fixed MDIO Bus: probed
[ 0.297668] PPP generic driver version 2.4.2
[ 0.297723] tun: Universal TUN/TAP device driver, 1.6
[ 0.297726] tun: (C) 1999-2004 Max Krasnyansky <email address hidden>
[ 0.297837] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 0.297862] ehci_hcd 0000:00:1a.7: PCI INT C -> GSI 18 (level, low) -> IRQ 18
[ 0.297880] ehci_hcd 0000:00:1a.7: setting latency timer to 64
[ 0.297885] ehci_hcd 0000:00:1a.7: EHCI Host Controller
[ 0.297925] ehci_hcd 0000:00:1a.7: new USB bus registered, assigned bus number 1
[ 0.297961] ehci_hcd 0000:00:1a.7: debug port 1
[ 0.301843] ehci_hcd 0000:00:1a.7: cache line size of 32 is not supported
[ 0.301887] ehci_hcd 0000:00:1a.7: irq 18, io mem 0xfc404800
[ 0.305320] isapnp: Scanning for PnP cards...
[ 0.320018] ehci_hcd 0000:00:1a.7: USB 2.0 started, EHCI 1.00
[ 0.320136] usb usb1: configuration #1 chosen from 1 choice
[ 0.320178] hub 1-0:1.0: USB hub found
[ 0.320188] hub 1-0:1.0: 4 ports detected
[ 0.320266] alloc irq_desc for 23 on node -1
[ 0.320269] alloc kstat_irqs on node -1
[ 0.320277] ehci_hcd 0000:00:1d.7: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 0.320296] ehci_hcd 0000:00:1d.7: setting latency timer to 64
[ 0.320301] ehci_hcd 0000:00:1d.7: EHCI Host Controller
[ 0.320351] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 2
[ 0.320384] ehci_hcd 0000:00:1d.7: debug port 1
[ 0.324275] ehci_hcd 0000:00:1d.7: cache line size of 32 is not supported
[ 0.324292] ehci_hcd 0000:00:1d.7: irq 23, io mem 0xfc404c00
[ 0.344293] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
[ 0.344459] usb usb2: configuration #1 chosen from 1 choice
[ 0.344546] hub 2-0:1.0: USB hub found
[ 0.344557] hub 2-0:1.0: 6 ports detected
[ 0.344644] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 0.344668] uhci_hcd: USB Universal Host Controller Interface driver
[ 0.344717] alloc irq_desc for 16 on node -1
[ 0.344720] alloc kstat_irqs on node -1
[ 0.344728] uhci_hcd 0000:00:1a.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 0.344766] uhci_hcd 0000:00:1a.0: setting latency timer to 64
[ 0.344773] uhci_hcd 0000:00:1a.0: UHCI Host Controller
[ 0.344938] uhci_hcd 0000:00:1a.0: new USB bus registered, assigned bus number 3
[ 0.344984] uhci_hcd 0000:00:1a.0: irq 16, io base 0x00001820
[ 0.345105] usb usb3: configuration #1 chosen from 1 choice
[ 0.345139] hub 3-0:1.0: USB hub found
[ 0.345147] hub 3-0:1.0: 2 ports detected
[ 0.345207] alloc irq_desc for 21 on node -1
[ 0.345210] alloc kstat_irqs on node -1
[ 0.345215] uhci_hcd 0000:00:1a.1: PCI INT B -> GSI 21 (level, low) -> IRQ 21
[ 0.345226] uhci_hcd 0000:00:1a.1: setting latency timer to 64
[ 0.345230] uhci_hcd 0000:00:1a.1: UHCI Host Controller
[ 0.345276] uhci_hcd 0000:00:1a.1: new USB bus registered, assigned bus number 4
[ 0.345373] uhci_hcd 0000:00:1a.1: irq 21, io base 0x00001840
[ 0.345598] usb usb4: configuration #1 chosen from 1 choice
[ 0.345681] hub 4-0:1.0: USB hub found
[ 0.345689] hub 4-0:1.0: 2 ports detected
[ 0.345838] uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 0.345847] uhci_hcd 0000:00:1d.0: setting latency timer to 64
[ 0.345852] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[ 0.345898] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 5
[ 0.345931] uhci_hcd 0000:00:1d.0: irq 23, io base 0x00001860
[ 0.346655] usb usb5: configuration #1 chosen from 1 choice
[ 0.346746] hub 5-0:1.0: USB hub found
[ 0.346756] hub 5-0:1.0: 2 ports detected
[ 0.346980] uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[ 0.346989] uhci_hcd 0000:00:1d.1: setting latency timer to 64
[ 0.346994] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[ 0.347037] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 6
[ 0.347079] uhci_hcd 0000:00:1d.1: irq 19, io base 0x00001880
[ 0.347203] usb usb6: configuration #1 chosen from 1 choice
[ 0.347238] hub 6-0:1.0: USB hub found
[ 0.347246] hub 6-0:1.0: 2 ports detected
[ 0.348226] uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
[ 0.348235] uhci_hcd 0000:00:1d.2: setting latency timer to 64
[ 0.348240] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[ 0.348284] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 7
[ 0.348316] uhci_hcd 0000:00:1d.2: irq 18, io base 0x000018a0
[ 0.348434] usb usb7: configuration #1 chosen from 1 choice
[ 0.348469] hub 7-0:1.0: USB hub found
[ 0.348478] hub 7-0:1.0: 2 ports detected
[ 0.348606] PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[ 0.355499] i8042.c: Detected active multiplexing controller, rev 1.1.
[ 0.366728] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 0.366737] serio: i8042 AUX0 port at 0x60,0x64 irq 12
[ 0.372145] serio: i8042 AUX1 port at 0x60,0x64 irq 12
[ 0.372182] serio: i8042 AUX2 port at 0x60,0x64 irq 12
[ 0.372216] serio: i8042 AUX3 port at 0x60,0x64 irq 12
[ 0.372383] mice: PS/2 mouse device common for all mice
[ 0.372649] rtc_cmos 00:07: rtc core: registered rtc_cmos as rtc0
[ 0.372686] rtc0: alarms up to one month, y3k, 242 bytes nvram, hpet irqs
[ 0.372831] device-mapper: uevent: version 1.0.3
[ 0.401294] device-mapper: ioctl: 4.15.0-ioctl (2009-04-01) initialised: <email address hidden>
[ 0.412302] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
[ 0.412538] device-mapper: multipath: version 1.1.0 loaded
[ 0.412542] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.420489] EISA: Probing bus 0 at eisa.0
[ 0.420498] Cannot allocate resource for EISA slot 1
[ 0.420503] Cannot allocate resource for EISA slot 2
[ 0.420506] Cannot allocate resource for EISA slot 3
[ 0.420509] Cannot allocate resource for EISA slot 4
[ 0.420531] EISA: Detected 0 cards.
[ 0.428232] cpuidle: using governor ladder
[ 0.428354] cpuidle: using governor menu
[ 0.428969] TCP cubic registered
[ 0.429175] NET: Registered protocol family 10
[ 0.429819] lo: Disabled Privacy Extensions
[ 0.430297] NET: Registered protocol family 17
[ 0.430995] Using IPI No-Shortcut mode
[ 0.431109] PM: Resume from disk failed.
[ 0.431126] registered taskstats version 1
[ 0.431756] Magic number: 14:638:444
[ 0.431858] rtc_cmos 00:07: setting system clock to 2010-10-03 19:24:33 UTC (1286133873)
[ 0.431862] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.431865] EDD information not available.
[ 0.476030] ata1.00: ATAPI: Optiarc DVD RW AD-7540A, 1.42, max UDMA/33
[ 0.492425] ata1.00: configured for UDMA/33
[ 0.662469] Freeing initrd memory: 13067k freed
[ 0.663089] isapnp: No Plug & Play device found
[ 0.664064] ACPI: Battery Slot [BAT0] (battery present)
[ 0.672242] scsi 0:0:0:0: CD-ROM Optiarc DVD RW AD-7540A 1.42 PQ: 0 ANSI: 5
[ 0.675482] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[ 0.675488] Uniform CD-ROM driver Revision: 3.20
[ 0.675690] sr 0:0:0:0: Attached scsi CD-ROM sr0
[ 0.675768] sr 0:0:0:0: Attached scsi generic sg0 type 5
[ 0.675851] Freeing unused kernel memory: 656k freed
[ 0.676487] Write protecting the kernel text: 4684k
[ 0.676551] Write protecting the kernel read-only data: 1840k
[ 0.701056] udev: starting version 151
[ 0.799524] ahci 0000:00:1f.2: version 3.0
[ 0.799553] ahci 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[ 0.799614] alloc irq_desc for 27 on node -1
[ 0.799617] alloc kstat_irqs on node -1
[ 0.799632] ahci 0000:00:1f.2: irq 27 for MSI/MSI-X
[ 0.799725] ahci 0000:00:1f.2: AHCI 0001.0100 32 slots 3 ports 3 Gbps 0x7 impl SATA mode
[ 0.799730] ahci 0000:00:1f.2: flags: 64bit ncq sntf pm led clo pio slum part ccc
[ 0.799738] ahci 0000:00:1f.2: setting latency timer to 64
[ 0.804662] Linux agpgart interface v0.103
[ 0.810106] scsi2 : ahci
[ 0.813885] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[ 0.813915] r8169 0000:06:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 0.813976] r8169 0000:06:00.0: setting latency timer to 64
[ 0.814064] alloc irq_desc for 28 on node -1
[ 0.814067] alloc kstat_irqs on node -1
[ 0.814087] r8169 0000:06:00.0: irq 28 for MSI/MSI-X
[ 0.815035] eth0: RTL8101e at 0xf80d4000, 00:03:0d:7b:a3:97, XID 14000000 IRQ 28
[ 0.834546] scsi3 : ahci
[ 0.845040] usb 5-1: new low speed USB device using uhci_hcd and address 2
[ 0.873790] scsi4 : ahci
[ 0.874014] ata3: SATA max UDMA/133 abar m2048@0xfc404000 port 0xfc404100 irq 27
[ 0.874020] ata4: SATA max UDMA/133 abar m2048@0xfc404000 port 0xfc404180 irq 27
[ 0.874025] ata5: SATA max UDMA/133 abar m2048@0xfc404000 port 0xfc404200 irq 27
[ 0.874317] agpgart-intel 0000:00:00.0: Intel 965GM Chipset
[ 0.875067] agpgart-intel 0000:00:00.0: detected 7676K stolen memory
[ 0.882898] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
[ 0.884640] [drm] Initialized drm 1.1.0 20060810
[ 1.021136] usb 5-1: configuration #1 chosen from 1 choice
[ 1.037921] usbcore: registered new interface driver hiddev
[ 1.052375] input: SYSGRATION 2.4G Mouse as /devices/pci0000:00/0000:00:1d.0/usb5/5-1/5-1:1.0/input/input6
[ 1.052471] generic-usb 0003:05B8:3112.0001: input,hidraw0: USB HID v1.00 Keyboard [SYSGRATION 2.4G Mouse] on usb-0000:00:1d.0-1/input0
[ 1.079644] input: SYSGRATION 2.4G Mouse as /devices/pci0000:00/0000:00:1d.0/usb5/5-1/5-1:1.1/input/input7
[ 1.079755] generic-usb 0003:05B8:3112.0002: input,hidraw1: USB HID v1.00 Mouse [SYSGRATION 2.4G Mouse] on usb-0000:00:1d.0-1/input1
[ 1.079782] usbcore: registered new interface driver usbhid
[ 1.079786] usbhid: v2.6:USB HID core driver
[ 1.192063] ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 1.192097] ata4: SATA link down (SStatus 0 SControl 300)
[ 1.192779] ACPI Warning for \_SB_.PCI0.SATA.PRT0._GTF: Return type mismatch - found Integer, expected Buffer (20090903/nspredef-1006)
[ 1.192789] ata3.00: _GTF unexpected object type 0x1
[ 1.200081] ata5: SATA link down (SStatus 0 SControl 300)
[ 1.244941] ata3.00: ATA-8: WDC WD2500BEVS-22UST0, 01.01A01, max UDMA/133
[ 1.244948] ata3.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[ 1.245939] ata3.00: _GTF unexpected object type 0x1
[ 1.246265] ata3.00: configured for UDMA/133
[ 1.260260] scsi 2:0:0:0: Direct-Access ATA WDC WD2500BEVS-2 01.0 PQ: 0 ANSI: 5
[ 1.260439] sd 2:0:0:0: [sda] 488397168 512-byte logical blocks: (250 GB/232 GiB)
[ 1.260442] sd 2:0:0:0: Attached scsi generic sg1 type 0
[ 1.260517] sd 2:0:0:0: [sda] Write Protect is off
[ 1.260521] sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 1.260561] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 1.260742] sda: sda1 sda2 < sda5 >
[ 1.292815] sd 2:0:0:0: [sda] Attached SCSI disk
[ 1.323436] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 1.323444] i915 0000:00:02.0: setting latency timer to 64
[ 1.327961] alloc irq_desc for 29 on node -1
[ 1.327965] alloc kstat_irqs on node -1
[ 1.327977] i915 0000:00:02.0: irq 29 for MSI/MSI-X
[ 1.327985] [drm] set up 7M of stolen space
[ 1.454081] [drm] initialized overlay support
[ 1.887868] fb0: inteldrmfb frame buffer device
[ 1.887872] registered panic notifier
[ 1.889079] ACPI Warning for \_SB_.PCI0.GFX0.DD02._BQC: Return type mismatch - found Reference, expected Integer (20090903/nspredef-1006)
[ 1.891827] acpi device:03: registered as cooling_device2
[ 1.892488] Monitor-Mwait will be used to enter C-2 state
[ 1.992250] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input8
[ 1.992300] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 1.992338] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[ 1.994524] vga16fb: initializing
[ 1.994528] vga16fb: mapped to 0xc00a0000
[ 1.994532] vga16fb: not registering due to another framebuffer present
[ 2.229345] Console: switching to colour frame buffer device 160x50
[ 2.802713] xor: automatically using best checksumming function: pIII_sse
[ 2.820004] pIII_sse : 5494.000 MB/sec
[ 2.820006] xor: using function: pIII_sse (5494.000 MB/sec)
[ 2.823477] device-mapper: dm-raid45: initialized v0.2594b
[ 3.028247] EXT4-fs (sda1): mounted filesystem with ordered data mode
[ 14.796324] Adding 6010872k swap on /dev/sda5. Priority:-1 extents:1 across:6010872k
[ 14.817185] udev: starting version 151
[ 14.844142] lp: driver loaded but no devices found
[ 15.137459] cfg80211: Calling CRDA to update world regulatory domain
[ 15.223607] cfg80211: World regulatory domain updated:
[ 15.223612] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 15.223616] (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.223620] (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 15.223624] (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 15.223627] (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.223631] (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.223937] psmouse serio4: ID: 10 00 64
[ 15.285970] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
[ 15.285975] iwl3945: Copyright(c) 2003-2009 Intel Corporation
[ 15.286100] iwl3945 0000:04:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 15.286117] iwl3945 0000:04:00.0: setting latency timer to 64
[ 15.357789] iwl3945 0000:04:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 15.357794] iwl3945 0000:04:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 15.357918] alloc irq_desc for 30 on node -1
[ 15.357921] alloc kstat_irqs on node -1
[ 15.357957] iwl3945 0000:04:00.0: irq 30 for MSI/MSI-X
[ 15.372779] phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 15.384578] type=1505 audit(1286130288.449:2): operation="profile_load" pid=663 name="/sbin/dhclient3"
[ 15.385498] type=1505 audit(1286130288.453:3): operation="profile_load" pid=663 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 15.385989] type=1505 audit(1286130288.453:4): operation="profile_load" pid=663 name="/usr/lib/connman/scripts/dhclient-script"
[ 15.421701] alloc irq_desc for 22 on node -1
[ 15.421705] alloc kstat_irqs on node -1
[ 15.421715] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 15.421766] HDA Intel 0000:00:1b.0: setting latency timer to 64
[ 15.537836] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input9
[ 15.644452] type=1505 audit(1286130288.712:5): operation="profile_load" pid=832 name="/usr/share/gdm/guest-session/Xsession"
[ 15.646762] type=1505 audit(1286130288.712:6): operation="profile_replace" pid=833 name="/sbin/dhclient3"
[ 15.647692] type=1505 audit(1286130288.712:7): operation="profile_replace" pid=833 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 15.648321] type=1505 audit(1286130288.716:8): operation="profile_replace" pid=833 name="/usr/lib/connman/scripts/dhclient-script"
[ 15.654326] type=1505 audit(1286130288.720:9): operation="profile_load" pid=834 name="/usr/bin/evince"
[ 15.666252] type=1505 audit(1286130288.732:10): operation="profile_load" pid=834 name="/usr/bin/evince-previewer"
[ 15.673729] type=1505 audit(1286130288.740:11): operation="profile_load" pid=834 name="/usr/bin/evince-thumbnailer"
[ 15.844301] iwl3945 0000:04:00.0: firmware: requesting iwlwifi-3945-2.ucode
[ 15.935218] input: PS/2 Logitech Wheel Mouse as /devices/platform/i8042/serio4/input/input10
[ 15.982710] iwl3945 0000:04:00.0: loaded firmware version 15.32.2.9
[ 16.055260] Registered led device: iwl-phy0::radio
[ 16.055287] Registered led device: iwl-phy0::assoc
[ 16.055308] Registered led device: iwl-phy0::RX
[ 16.055332] Registered led device: iwl-phy0::TX
[ 16.163196] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 16.165119] r8169: eth0: link down
[ 16.165376] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 16.512790] ppdev: user-space parallel port driver
[ 19.175650] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[ 35.718268] wlan0: deauthenticating from 00:17:3f:8a:09:05 by local choice (reason=3)
[ 35.720123] wlan0: direct probe to AP 00:17:3f:8a:09:05 (try 1)
[ 35.759801] wlan0: direct probe responded
[ 35.759808] wlan0: authenticate with AP 00:17:3f:8a:09:05 (try 1)
[ 35.774680] wlan0: authenticated
[ 35.774704] wlan0: associate with AP 00:17:3f:8a:09:05 (try 1)
[ 35.826150] wlan0: RX AssocResp from 00:17:3f:8a:09:05 (capab=0x431 status=0 aid=2)
[ 35.826155] wlan0: associated
[ 35.828823] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 46.312017] wlan0: no IPv6 routers present
[ 152.169059] usb 1-1: new high speed USB device using ehci_hcd and address 2
[ 152.302209] usb 1-1: configuration #1 chosen from 1 choice
[ 153.374627] Initializing USB Mass Storage driver...
[ 153.374839] scsi5 : SCSI emulation for USB Mass Storage devices
[ 153.375179] usbcore: registered new interface driver usb-storage
[ 153.375185] USB Mass Storage support registered.
[ 153.378103] usb-storage: device found at 2
[ 153.378108] usb-storage: waiting for device to settle before scanning
[ 158.376583] usb-storage: device scan complete
[ 179.916056] usb 1-1: reset high speed USB device using ehci_hcd and address 2
[ 180.051587] scsi 5:0:0:0: CD-ROM HSPA USB SCSI CD-ROM 2.31 PQ: 0 ANSI: 2
[ 180.054908] sr1: scsi-1 drive
[ 180.055124] sr 5:0:0:0: Attached scsi CD-ROM sr1
[ 180.055251] sr 5:0:0:0: Attached scsi generic sg2 type 5
[ 180.289278] ISO 9660 Extensions: Microsoft Joliet Level 1
[ 180.331781] ISOFS: changing to secondary root

Manjuvajra (thehut) said : #5

Sorry about that last post - it was a bit excessive.

Yes the device is detected as a USB storage so you will need usb-modeswitch

Manjuvajra (thehut) said : #7

I do have usb-modeswitch installed!! I don't know why it doesn't do what it should.

If I eject the 'CD drive' manually and then run lsusb again I get the modem detected properly:

Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 05b8:3112 Agiler, Inc.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 19d2:0031 ONDA Communication S.p.A. ZTE MF636
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

but it still does not appear in the network manager!!.

I have rooted around and discovered that if I log on as root user and I run wvdial (after fiddling with the configuration file) I can get the modem to work properly. This means that I have to log on as root, plug in the dongle, eject the 'CD' drive, open a terminal and run wvdial - and then change to my normal user name. I also means have to manually set Evolution and Firefox online. Not very neat but it works.

I would prefer to use the network manager if I could find out what is going wrong. As I say my netbook is working fine exactly as it should.

Any thoughts?

peter b (b1pete) said : #8

how about

usb-modeswitch-data

? is it installed ?

Manjuvajra (thehut) said : #9

Sorry for delay - I have been asleep.

Yes usb-modeswitch-data is installed.

Could it be something to do with the network manager program?

Its really very simple why it "doesn't do what it should". In windows the device is seen as a storage device and automagically installs the driver. It then gets switched over by the software to being a modem. He company has been short sighted and not accommodated your OS so you have to do the legwork yourself and switch the device manually. There is software available to you (which you are being advised on but I have zero use of it so am sitting to the side) to get the device thinking its a modem and not a storage device.

peter b (b1pete) said : #11

it appears that for this chip set

ID 19d2:0103 ONDA Communication S.p.A.

the usb-modeswitch-data is not up to par yet. other users apparently sorted out this by by modifying/adding new rules for ejecting the cd. so, give it a try and see how it goes. the url is below - #18

http://ubuntuforums.org/showthread.php?t=1528185&page=2

Manjuvajra (thehut) said : #12

Thanks for your help - I will try modifying the usb-modeswitch-data rules. But for the next two weeks I will have no internet connection (off into Spanish mountains) will try again when I get back.

Can you help with this problem?

Provide an answer of your own, or ask Manjuvajra for more information if necessary.

To post a message you must log in.