Wireless card (Broadcom) not working Ubuntu 10.04.1

Asked by Felicity on 2010-09-19

I just installed Ubuntu 10.04.1 on a HP dv8100 Laptop. The wireless card light is not on, and the button will not turn it on. There is a Broadcom 802.11 Linux STA driver installed, appears in the package manager as installed. I've entered all the info (user and pw) for my network connection.

My wireless card is:
Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) Realtek Semiconductor
Co., Ltd. RTL-8139/8139C+ (rev 10)

I'm thinking I just can't figure out how to turn the card on.

I appreciate any help~!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Felicity
Solved:
2010-09-19
Last query:
2010-09-19
Last reply:
2010-09-19
peter b (b1pete) said : #1

pls enter and carry out into a terminal commands as follows - one at the time

sudo ifconfig

sudo iwconfig

please copy/paste above commands output here, same question but new post so we'll see whether there are any interfaces configured. more instructions after.

Hi,

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word restart. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|ndiswrapper|NPE|ound|prism|rtl|rt2|rt3|usb|witch|wl'; iwconfig; grep b43 /etc/modprobe.d/*; grep wl /etc/modprobe.d/*; sudo hwinfo --netcard ; sudo lsmod; sudo /etc/init.d/networking restart

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Regards,

Mark

Felicity (stark-05) said : #3

Hi Mark,

I ran the code as you instructed, but forgot to copy the code. It did say that two new packages will be installed: hwinfo and libhd16. Anyways, I ran the code again, and below is what I got. I did notice an install drivers icon appear top right. So clicked that and installed the broadcom B43 wireless driver - but still not working. when I mouse over the wifi icon, it says wireless device not ready.

felicity@felicity-laptop:~$ sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C
[sudo] password for felicity:
Hit http://security.ubuntu.com lucid-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_CA
Hit http://ca.archive.ubuntu.com lucid Release.gpg
Hit http://ca.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_CA
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_CA
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_CA
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_CA
Hit http://security.ubuntu.com lucid-security Release
Hit http://ca.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_CA
Hit http://ca.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_CA
Ign http://ca.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_CA
Hit http://ca.archive.ubuntu.com lucid-updates Release.gpg
Ign http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_CA
Ign http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_CA
Ign http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_CA
Ign http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_CA
Hit http://ca.archive.ubuntu.com lucid Release
Hit http://ca.archive.ubuntu.com lucid-updates Release
Hit http://security.ubuntu.com lucid-security/main Packages
Hit http://ca.archive.ubuntu.com lucid/main Packages
Hit http://ca.archive.ubuntu.com lucid/restricted Packages
Hit http://ca.archive.ubuntu.com lucid/main Sources
Hit http://ca.archive.ubuntu.com lucid/restricted Sources
Hit http://ca.archive.ubuntu.com lucid/universe Packages
Hit http://security.ubuntu.com lucid-security/restricted Packages
Hit http://security.ubuntu.com lucid-security/main Sources
Hit http://security.ubuntu.com lucid-security/restricted Sources
Hit http://security.ubuntu.com lucid-security/universe Packages
Hit http://ca.archive.ubuntu.com lucid/universe Sources
Hit http://ca.archive.ubuntu.com lucid/multiverse Packages
Hit http://ca.archive.ubuntu.com lucid/multiverse Sources
Hit http://ca.archive.ubuntu.com lucid-updates/main Packages
Hit http://ca.archive.ubuntu.com lucid-updates/restricted Packages
Hit http://ca.archive.ubuntu.com lucid-updates/main Sources
Hit http://ca.archive.ubuntu.com lucid-updates/restricted Sources
Hit http://security.ubuntu.com lucid-security/universe Sources
Hit http://security.ubuntu.com lucid-security/multiverse Packages
Hit http://security.ubuntu.com lucid-security/multiverse Sources
Hit http://ca.archive.ubuntu.com lucid-updates/universe Packages
Hit http://ca.archive.ubuntu.com lucid-updates/universe Sources
Hit http://ca.archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://ca.archive.ubuntu.com lucid-updates/multiverse Sources
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
hwinfo is already the newest version.
grep is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 55 not upgraded.
Hardware Lister (lshw) - B.02.14
usage: lshw [-format] [-options ...]
       lshw -version

 -version print program version (B.02.14)

format can be
 -html output hardware tree as HTML
 -xml output hardware tree as XML
 -short output hardware paths
 -businfo output bus information

options can be
 -class CLASS only show a certain class of hardware
 -C CLASS same as '-class CLASS'
 -c CLASS same as '-class CLASS'
 -disable TEST disable a test (like pci, isapnp, cpuid, etc. )
 -enable TEST enable a test (like pci, isapnp, cpuid, etc. )
 -quiet don't display status
 -sanitize sanitize output (remove sensitive information like serial numbers, etc.)
 -numeric output numeric IDs (for PCI, USB, etc.)

felicity@felicity-laptop:~$

Felicity (stark-05) said : #4

Aha~!

It worked, there was another driver to install under that icon. Thank you very much for your help!