Need help connecting an external hard drive via ethernet cable.

Asked by cwrann on 2007-08-26

I have a Western Digital My Book World Edition that connects to the PC via ethernet cable. I have two ethernet ports that are directly connected to the motherboard. Ubuntu recognizes both ethernet ports. I would like to know how to access the files on this drive in ubuntu. In windows I am able to access this hard drive when connected into this ethernet port. This is the last thing I need to figure out to be completly free of windows.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Jim Hutchinson
Solved:
2007-08-28
Last query:
2007-08-28
Last reply:
2007-08-27
Jim Hutchinson (jphutch) said : #1

Normally this type of device would be connected to a router rather than the PC itself. Interesting that it works in windows that way. I wouldn't have thought it would. Although this type of connection will probably not allow it to be easily visible to the rest of the network as it would be if connected to a router. The router would give the device an IP address via DHCP. I wonder if the OS itself can dish out an IP address or if there is a way to assign one manually. Typing

ifconfig

in a terminal should show you all your network connections. It may show the second ethernet port as eth1 or something. If it does, it may also show the IP address for the device. If so, you should then be able to use the "connect to server" option under Places (on the menubar) and fill in the info. It's also possible it will find it automatically. I'm pretty sure it will be considered a windows share. You could click on browse network and see if it finds it.

Sorry for the less than helpful response. Hope it's at least somewhat useful. I'm kind of just guessing. Although I'm interested to see how this turns out. I've been looking to get one of these too.

cwrann (cwrann) said : #2

 ifconfig
eth0 Link encap:Ethernet HWaddr 00:1A:92:F0:19:1A
          inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::21a:92ff:fef0:191a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:271 errors:0 dropped:0 overruns:0 frame:0
          TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:203521 (198.7 KiB) TX bytes:55780 (54.4 KiB)
          Interrupt:20 Base address:0x6000

eth1 Link encap:Ethernet HWaddr 00:1A:92:F0:26:FA
          inet addr:192.168.1.64 Bcast:192.168.1.255 Mask:255.255.255.0
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Interrupt:23 Base address:0x8000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5276 (5.1 KiB) TX bytes:5276 (5.1 KiB)

When I type the eth1 IP address into connect to server it creates a link on the desktop that cannot be opened. When I connect it to my router and browse the network it comes up with nothing.

I don't recommend anybody by this particular External hard drive for a number of reasons even on xp (the OS it is formatted for) it gave me problems such as randomly changing the drive letter and becoming unavailable. Alo the light on the front of it some times blinks in what appears to be meaningful an informative sequences but western digital has yet to send me any documentation that deciphers them.

Best Jim Hutchinson (jphutch) said : #3

Well, looks like it has an IP so that's good. What did you select for Service type in the Connect to Server window? I suggested windows share because it's my understanding that almost all network hard drives are. If that doesn't work you could try some of the other options. It's also possible that you just have to mess with samba to do this. I found some info that might help.

http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_mount.2Funmount_network_folders_manually.2C_and_allow_all_users_to_read

http://www.ubuntugeek.com/mount-network-file-systems-nfssamba-in-ubuntu.html

Maybe one of those will help.

cwrann (cwrann) said : #4

Oops. It turns out that when I first set up ubuntu I set my eth0 at static IP, all I had o do was set it to DHCP, plug the hard drive into the router and browse in connect to server. Just as I suspected it is now easier to use than it was on windows XP. In XP they made you use a service called mionet and if you didn't want to use this you had to jump through hopes to get desktop acess to it.

Thanks for the help.
VIVA UBUNTU!!!