UNCLAIMED 88w8335 [Libertas] 802.11b/g Wireless [11ab:1faa] (rev 03) card not working in Ubuntu 10.04 - UNCLAIMED driver

Asked by Roberto on 2010-08-10

I just followed the procedure and find attached the output of it:

bomba@bombaone:~$ sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'ound|irmware|eth|ath|wl|ipw|rtl|rt2|b43|witch|ndiswrapper'; iwconfig; grep b43 /etc/modprobe.d/*; grep wl /etc/modprobe.d/*; sudo hwinfo --netcard ; sudo lsmod; sudo /etc/init.d/networking restart
[sudo] password for bomba:
Hit http://br.archive.ubuntu.com lucid Release.gpg
Ign http://br.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Ign http://br.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Ign http://br.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Ign http://br.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Get:1 http://br.archive.ubuntu.com lucid-updates Release.gpg [189B]
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
Hit http://br.archive.ubuntu.com lucid Release
Get:2 http://br.archive.ubuntu.com lucid-updates Release [44.7kB]
Hit http://br.archive.ubuntu.com lucid/main Packages
Hit http://br.archive.ubuntu.com lucid/restricted Packages
Hit http://br.archive.ubuntu.com lucid/main Sources
Hit http://br.archive.ubuntu.com lucid/restricted Sources
Hit http://br.archive.ubuntu.com lucid/universe Packages
Hit http://br.archive.ubuntu.com lucid/universe Sources
Hit http://br.archive.ubuntu.com lucid/multiverse Packages
Hit http://br.archive.ubuntu.com lucid/multiverse Sources
Get:3 http://br.archive.ubuntu.com lucid-updates/main Packages [273kB]
Get:4 http://security.ubuntu.com lucid-security Release.gpg [189B]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Get:5 http://security.ubuntu.com lucid-security Release [38.5kB]
Get:6 http://br.archive.ubuntu.com lucid-updates/restricted Packages [3,252B]
Get:7 http://br.archive.ubuntu.com lucid-updates/main Sources [99.0kB]
Get:8 http://br.archive.ubuntu.com lucid-updates/restricted Sources [1,292B]
Get:9 http://br.archive.ubuntu.com lucid-updates/universe Packages [88.9kB]
Get:10 http://br.archive.ubuntu.com lucid-updates/universe Sources [29.6kB]
Get:11 http://br.archive.ubuntu.com lucid-updates/multiverse Packages [3,771B]
Get:12 http://br.archive.ubuntu.com lucid-updates/multiverse Sources [1,499B]
Get:13 http://security.ubuntu.com lucid-security/main Packages [57.1kB]
Get:14 http://security.ubuntu.com lucid-security/restricted Packages [14B]
Get:15 http://security.ubuntu.com lucid-security/main Sources [18.6kB]
Get:16 http://security.ubuntu.com lucid-security/restricted Sources [14B]
Get:17 http://security.ubuntu.com lucid-security/universe Packages [27.7kB]
Get:18 http://security.ubuntu.com lucid-security/universe Sources [5,460B]
Get:19 http://security.ubuntu.com lucid-security/multiverse Packages [2,012B]
Get:20 http://security.ubuntu.com lucid-security/multiverse Sources [580B]
Fetched 696kB in 3s (228kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following packages were automatically installed and are no longer required:
  sdparm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libhd16
The following NEW packages will be installed:
  hwinfo libhd16
0 upgraded, 2 newly installed, 0 to remove and 2 not upgraded.
Need to get 744kB of archives.
After this operation, 2,060kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://br.archive.ubuntu.com/ubuntu/ lucid/universe libhd16 16.0-2 [698kB]
Get:2 http://br.archive.ubuntu.com/ubuntu/ lucid/universe hwinfo 16.0-2 [46.1kB]
Fetched 744kB in 2s (327kB/s)
Selecting previously deselected package libhd16.
(Reading database ... 135883 files and directories currently installed.)
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhd16 (16.0-2) ...

Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network
       description: Ethernet interface
       product: nForce2 Ethernet Controller
       vendor: nVidia Corporation
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth1
       version: a1
       serial: 00:0e:a6:6b:2a:a1
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.64 duplex=full ip=187.107.137.32 latency=0 link=yes maxlatency=20 mingnt=1 multicast=yes port=MII speed=100MB/s
       resources: irq:22 memory:ef000000-ef000fff ioport:d000(size=8)
  *-network:0
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 7
       bus info: pci@0000:01:07.0
       logical name: eth0
       version: 10
       serial: 00:08:54:2c:df:5a
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10MB/s
       resources: irq:19 ioport:c000(size=256) memory:ee020000-ee0200ff
  *-network:1 UNCLAIMED
       description: Ethernet controller
       product: 88w8335 [Libertas] 802.11b/g Wireless
       vendor: Marvell Technology Group Ltd.
       physical id: a
       bus info: pci@0000:01:0a.0
       version: 03
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list
       configuration: latency=32
       resources: memory:ee000000-ee00ffff memory:ee010000-ee01ffff
lo Interface doesn't support scanning.

eth1 Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"
00:00.0 Host bridge [0600]: nVidia Corporation nForce2 IGP2 [10de:01e0] (rev c1)
00:00.1 RAM memory [0500]: nVidia Corporation nForce2 Memory Controller 0 [10de:01ea] (rev c1)
00:00.2 RAM memory [0500]: nVidia Corporation nForce2 Memory Controller 4 [10de:01ee] (rev c1)
00:00.3 RAM memory [0500]: nVidia Corporation nForce2 Memory Controller 3 [10de:01ed] (rev c1)
00:00.4 RAM memory [0500]: nVidia Corporation nForce2 Memory Controller 2 [10de:01ec] (rev c1)
00:00.5 RAM memory [0500]: nVidia Corporation nForce2 Memory Controller 5 [10de:01ef] (rev c1)
00:01.0 ISA bridge [0601]: nVidia Corporation nForce2 ISA Bridge [10de:0060] (rev a4)
00:01.1 SMBus [0c05]: nVidia Corporation nForce2 SMBus (MCP) [10de:0064] (rev a2)
00:02.0 USB Controller [0c03]: nVidia Corporation nForce2 USB Controller [10de:0067] (rev a4)
00:02.1 USB Controller [0c03]: nVidia Corporation nForce2 USB Controller [10de:0067] (rev a4)
00:02.2 USB Controller [0c03]: nVidia Corporation nForce2 USB Controller [10de:0068] (rev a4)
00:04.0 Ethernet controller [0200]: nVidia Corporation nForce2 Ethernet Controller [10de:0066] (rev a1)
00:06.0 Multimedia audio controller [0401]: nVidia Corporation nForce2 AC97 Audio Controler (MCP) [10de:006a] (rev a1)
00:08.0 PCI bridge [0604]: nVidia Corporation nForce2 External PCI Bridge [10de:006c] (rev a3)
00:09.0 IDE interface [0101]: nVidia Corporation nForce2 IDE [10de:0065] (rev a2)
00:1e.0 PCI bridge [0604]: nVidia Corporation nForce2 AGP [10de:01e8] (rev c1)
01:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
01:08.0 Modem [0703]: Agere Systems Device [11c1:0600] (rev 03)
01:0a.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless [11ab:1faa] (rev 03)
02:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
Bus 003 Device 002: ID 03f0:7904 Hewlett-Packard
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 1267:0210 Logic3 / SpectraVideo plc
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
======================================================
                            system A7N8X-X
/0 bus A7N8X-X
/0/0 memory 64KiB BIOS
/0/4 processor AMD Athlon(tm) XP 2800+
/0/4/9 memory 128KiB L1 cache
/0/4/a memory 512KiB L2 cache
/0/26 memory 2GiB System Memory
/0/26/0 memory 1GiB DIMM DRAM Synchronous
/0/26/1 memory 1GiB DIMM DRAM Synchronous
/0/26/2 memory DIMM DRAM Synchronous [empty]
/0/100 bridge nForce2 IGP2
/0/100/0.1 memory RAM memory
/0/100/0.2 memory RAM memory
/0/100/0.3 memory RAM memory
/0/100/0.4 memory RAM memory
/0/100/0.5 memory RAM memory
/0/100/1 bridge nForce2 ISA Bridge
/0/100/1.1 bus nForce2 SMBus (MCP)
/0/100/2 bus nForce2 USB Controller
/0/100/2.1 bus nForce2 USB Controller
/0/100/2.2 bus nForce2 USB Controller
/0/100/4 eth1 network nForce2 Ethernet Controller
/0/100/6 multimedia nForce2 AC97 Audio Controler (MCP)
/0/100/8 bridge nForce2 External PCI Bridge
/0/100/8/7 eth0 network RTL-8139/8139C/8139C+
/0/100/8/8 communication Agere Systems
/0/100/8/a network 88w8335 [Libertas] 802.11b/g Wireless
/0/100/9 scsi0 storage nForce2 IDE
/0/100/9/0 /dev/sda disk 120GB ST3120022A
/0/100/9/0/1 /dev/sda1 volume 89GiB Windows NTFS volume
/0/100/9/0/2 /dev/sda2 volume 21GiB Extended partition
/0/100/9/0/2/5 /dev/sda5 volume 20GiB Linux filesystem partition
/0/100/9/0/2/6 /dev/sda6 volume 972MiB Linux swap / Solaris partition
/0/100/9/1 /dev/sdb disk 200GB SAMSUNG SP2014N
/0/100/9/1/1 /dev/sdb1 volume 161GiB Windows NTFS volume
/0/100/9/1/2 /dev/sdb2 volume 24GiB Extended partition
/0/100/9/1/2/5 /dev/sdb5 volume 23GiB Linux filesystem partition
/0/100/9/1/2/6 /dev/sdb6 volume 1090MiB Linux swap / Solaris partitio
/0/100/9/0.1.0 /dev/cdrom disk DVDRAM GSA-4163B
/0/100/1e bridge nForce2 AGP
/0/100/1e/0 display NV34 [GeForce FX 5200]
Linux bombaone 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 06:07:29 UTC 2010 i686 GNU/Linux
[ 0.000000] Phoenix BIOS detected: BIOS may corrupt low RAM, working around it.
[ 0.024564] SMP alternatives: switching to UP code
[ 0.132799] ACPI: No dock devices found.
[ 0.185481] Switching to clocksource tsc
[ 0.191505] pnp: PnP ACPI: found 16 devices
[ 0.240088] Switching to clocksource acpi_pm
[ 0.328443] hub 1-0:1.0: USB hub found
[ 0.422371] hub 2-0:1.0: USB hub found
[ 0.510178] hub 3-0:1.0: USB hub found
[ 0.516825] device-mapper: multipath: version 1.1.0 loaded
[ 0.516829] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.522342] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.858829] isapnp: No Plug & Play device found
[ 1.140408] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[ 1.140663] forcedeth 0000:00:04.0: PCI INT A -> Link[APCH] -> GSI 22 (level, high) -> IRQ 22
[ 1.140670] forcedeth 0000:00:04.0: setting latency timer to 64
[ 1.140733] nv_probe: set workaround bit for reversed mac addr
[ 1.661152] forcedeth 0000:00:04.0: ifname eth0, PHY OUI 0x732 @ 1, addr 00:0e:a6:6b:2a:a1
[ 1.661158] forcedeth 0000:00:04.0: timirq lnktim desc-v1
[ 1.663916] eth1: RealTek RTL8139 at 0xc000, 00:08:54:2c:df:5a, IRQ 19
[ 7.206104] lp: driver loaded but no devices found
[ 7.549741] udev: renamed network interface eth1 to eth0
[ 7.585273] udev: renamed network interface eth0_rename to eth1
[ 10.085165] Console: switching to colour frame buffer device 80x30
[ 13.109698] eth0: link down
[ 13.109987] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 23.720015] eth1: no IPv6 routers present
[ 36.467249] UDF-fs: No VRS found
[ 36.467256] UDF-fs: No partition found (1)
[ 254.469174] rtl8185B: Initializing module
[ 254.469176] rtl8185B: Wireless extensions version 22
[ 254.469178] rtl8185B: Initializing proc filesystem
[ 365.804197] rtl8185B: Exiting
[ 393.275472] rtl8185B: Initializing module
[ 393.275474] rtl8185B: Wireless extensions version 22
[ 393.275476] rtl8185B: Initializing proc filesystem
[ 397.866555] rtl8185B: Exiting
lo no wireless extensions.

eth1 no wireless extensions.

eth0 no wireless extensions.

/etc/modprobe.d/blacklist.conf:# replaced by b43 and ssb.
/etc/modprobe.d/blacklist-watchdog.conf:blacklist twl4030_wdt
21: PCI 04.0: 0200 Ethernet controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_10de_66
  Unique ID: JNkJ.rDRqBOJ4Sq1
  SysFS ID: /devices/pci0000:00/0000:00:04.0
  SysFS BusID: 0000:00:04.0
  Hardware Class: network
  Model: "nVidia nForce2 Ethernet Controller"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0066 "nForce2 Ethernet Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x80a7 "A7N8X Mainboard onboard nForce2 Ethernet"
  Revision: 0xa1
  Driver: "forcedeth"
  Driver Modules: "forcedeth"
  Device File: eth1
  Memory Range: 0xef000000-0xef000fff (rw,non-prefetchable)
  I/O Ports: 0xd000-0xd007 (rw)
  IRQ: 22 (12894 events)
  HW Address: 00:0e:a6:6b:2a:a1
  Link detected: yes
  Module Alias: "pci:v000010DEd00000066sv00001043sd000080A7bc02sc00i00"
  Driver Info #0:
    Driver Status: forcedeth is active
    Driver Activation Cmd: "modprobe forcedeth"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

26: PCI 107.0: 0200 Ethernet controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_10ec_8139
  Unique ID: rBUF.IQxIdIhhuH7
  Parent ID: RE4e.f9Q95vpHUcA
  SysFS ID: /devices/pci0000:00/0000:00:08.0/0000:01:07.0
  SysFS BusID: 0000:01:07.0
  Hardware Class: network
  Model: "Realtek RT8139"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8139 "RTL-8139/8139C/8139C+"
  SubVendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  SubDevice: pci 0x8139 "RT8139"
  Revision: 0x10
  Driver: "8139too"
  Driver Modules: "8139too"
  Device File: eth0
  I/O Ports: 0xc000-0xcfff (rw)
  Memory Range: 0xee020000-0xee0200ff (rw,non-prefetchable)
  IRQ: 19 (134695 events)
  HW Address: 00:08:54:2c:df:5a
  Link detected: no
  Module Alias: "pci:v000010ECd00008139sv000010ECsd00008139bc02sc00i00"
  Driver Info #0:
    Driver Status: 8139too is active
    Driver Activation Cmd: "modprobe 8139too"
  Driver Info #1:
    Driver Status: 8139cp is active
    Driver Activation Cmd: "modprobe 8139cp"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (PCI bridge)

28: PCI 10a.0: 0200 Ethernet controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_11ab_1faa
  Unique ID: HJNj.ptqw5XL7l0A
  Parent ID: RE4e.f9Q95vpHUcA
  SysFS ID: /devices/pci0000:00/0000:00:08.0/0000:01:0a.0
  SysFS BusID: 0000:01:0a.0
  Hardware Class: network
  Model: "Marvell 88w8335 [Libertas] 802.11b/g Wireless"
  Vendor: pci 0x11ab "Marvell Technology Group Ltd."
  Device: pci 0x1faa "88w8335 [Libertas] 802.11b/g Wireless"
  SubVendor: pci 0x11ab "Marvell Technology Group Ltd."
  SubDevice: pci 0x1faa
  Revision: 0x03
  Memory Range: 0xee000000-0xee00ffff (rw,non-prefetchable)
  Memory Range: 0xee010000-0xee01ffff (rw,non-prefetchable)
  IRQ: 12 (no events)
  Module Alias: "pci:v000011ABd00001FAAsv000011ABsd00001FAAbc02sc00i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (PCI bridge)
Module Size Used by
joydev 8708 0
isofs 29250 0
udf 78785 0
crc_itu_t 1371 1 udf
binfmt_misc 6587 1
snd_wavefront 33066 0
snd_cs4236 25514 0
snd_wss_lib 23410 2 snd_wavefront,snd_cs4236
snd_opl3_lib 8966 2 snd_wavefront,snd_cs4236
snd_hwdep 5412 2 snd_wavefront,snd_opl3_lib
snd_mpu401 5123 0
snd_mpu401_uart 5617 3 snd_wavefront,snd_cs4236,snd_mpu401
snd_intel8x0 25588 2
snd_seq_dummy 1338 0
snd_ac97_codec 100646 1 snd_intel8x0
snd_seq_oss 26726 0
ac97_bus 1002 1 snd_ac97_codec
fbcon 35102 71
snd_pcm_oss 35308 0
snd_seq_midi 4557 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_rawmidi 19056 3 snd_wavefront,snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
tileblit 2031 1 fbcon
snd_pcm 70662 5 snd_cs4236,snd_wss_lib,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
font 7557 1 fbcon
snd_timer 19098 4 snd_wss_lib,snd_opl3_lib,snd_pcm,snd_seq
bitblit 4707 1 fbcon
snd_page_alloc 7076 3 snd_wss_lib,snd_intel8x0,snd_pcm
softcursor 1189 1 bitblit
snd_seq_device 5700 6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
nvidia 7087672 34
snd 54148 21 snd_wavefront,snd_cs4236,snd_wss_lib,snd_opl3_lib,snd_hwdep,snd_mpu401,snd_mpu401_uart,snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_pcm_oss,snd_mixer_oss,snd_rawmidi,snd_pcm,snd_seq,snd_timer,snd_seq_device
vga16fb 11385 1
vgastate 8961 1 vga16fb
soundcore 6620 1 snd
ns558 3056 0
i2c_nforce2 5199 0
nvidia_agp 4483 1
gameport 9089 2 ns558
ppdev 5259 0
agpgart 31724 2 nvidia,nvidia_agp
usblp 10481 0
parport_pc 25962 1
shpchp 28820 0
lp 7028 0
parport 32635 3 ppdev,parport_pc,lp
usbhid 36110 0
8139too 18545 0
hid 67032 1 usbhid
8139cp 16186 0
forcedeth 49556 0
pata_amd 8766 2
mii 4381 2 8139too,8139cp
floppy 53016 0
 * Reconfiguring network interfaces... Ignoring unknown interface eth1=eth1.
                                                                         [ OK ]
bomba@bombaone:~$

I have a AMD Athlon 2800+
2 Gb ram

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-11
Last reply:
2010-08-11

This question was reopened

PeterPall (peterpall) said : #1

As far as I can see you have 2 problems, - one of which I hope you don't care:
- powering up one of your two wired ethernet connectors seems not to have worked (according to the message: "unknown interface eth1=eth1"). This problem should have an easy solution, but I am still no expert in wired ethernet problems since I have never seen one that doesn't work like magic.
- your computer contains a marvel 88w8335 wireless chipset - for which there is still no linux driver. But don't despair: you can always use the windows one instead:

Just install ndisgtk - grab the windows driver files files from the driver CD or any windows installation:
WG311v3.INF
WG311v3.SYS
WG311v3XP.SYS
WG311v3.CAT
Press System | Administration | Windows wireless drivers

--- and ndisgtk will tell you what to do.

References:
http://de.linwiki.org/wiki/Netgear_WG311v3
https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper#Installing%20Windows%20driver%20using%20ndisgtk%20%28ndiswrapper%20graphical%20interface%29

Hi,

Please try this installation procedure for your Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless [11ab:1faa] (rev 03) card:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Run the following commands (copy-paste each line below to the Terminal then hit <enter> after each line)

sudo aptitude update
sudo aptitude install ndisgtk ndiswrapper-common ndiswrapper-modules-1.9 ndiswrapper-utils-1.9

Step 3: Download the Windows driver file Marvell_88w8335_WinXP.tar.gz provided by forumuser caljohnsmith at the following location:

http://ubuntuforums.org/showthread.php?t=976928

You will first need to register and log into ubuntuforums with your own username before you can download the file. But it should be worth the effort.

Step 4: Open a Terminal and enter the following command to start ndisgtk:

gksudo ndisgtk

Click on "install new driver". Click on "None", next to "Location". Navigate to the location where you extracted the contents of the downloaded file Marvell_88w8335_WinXP.tar.gz. The extracted folder contents should contain the file mrv8335.inf

Select this driver file mrv8335.inf to install it.

Step 5: Open Terminal from "Applications->Accessories->
Terminal" and enter the following command in Terminal:

gksudo gedit /etc/modules

# Now add the module ndiswrapper to the list of modules to be automatically loaded at boot by adding

ndiswrapper

# to the end of the /etc/modules file. (Gedit editor automatically opens)

Step 6: Reboot your pc and retest wireless

Step 7; If wireless still does not work after rebooting, or if authentication does not work, try disabling security on the router and retry connecting via wireless.

Hope this helps,

Regards,

Mark

Roberto (roberto-roriz-brito) said : #3

Hi Peter, I have one LAn conected and other no... so thatś why the eth1 fails. I tried to use the windows files but it is not working.

Hi Mark, I followed all of you steps and the ndiswrapper always give me a message that the Hardware is not present... funny at all.

Roberto (roberto-roriz-brito) said : #4

Thanks Mark Rijckenberg, that solved my question.

Roberto (roberto-roriz-brito) said : #5

Sorry guys, I put as solved by mistake

PeterPall (peterpall) said : #6

- Until my wlan card started being supported I had to try several windows drivers. Don't know if in the end dhe XP one, the Win2K one - or the Vista one worked.
- Make sure that the drivers are on the hard disk linux is on: Sometimes the driver doesn't work until a reboot - and linux may want to start the ndiswrapper as one of the first things before mounting the other hard disk partitions/media at boot time so until you have typed in your password your WLAN already has detected all the networks.
- I assume you already have made sure the RF kill switch (most of the times really a physical switch at the side of your computer does work) is not switched to "off". I have to admit that the only 2 times I had big problems making the WLAN work it was due to this switch. On some computers you can disable the switch at all in the BIOS of the computer or tell the bios if it itselves should handle the switch or if it should delegate it to the operation system. If it is there play with this setting.
- After trying to set up ndiswrapper open a console and see if there are some useful hints, error messages or warning in the central stores for system messages: /var/log/messages
 (if you don't have the rights to read this file issue the command
  sudo gedit /vat/log/messages
  from a terminal)
  ...and the output of the dmesg command.
 If dmesg - or any other command started in a terminal outputs too many interesting lines you can unlimited add up-and-down-scrolling functionality to the program by adding a
 |less
 to the command:
 dmesg|less
- https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper (and loads of other tutorials) tell you how to use ndiswrapper manually instead of using the graphical ndisgtk tool. You may want to try this: Graphical tools are fine - but if you really need information what went wrong on all operating systems I know they tend to be not really useful, because they try not to scare you with warnings - that might contain a complete description of the solution of your problem, though.

PeterPall (peterpall) said : #7

Just for the unlikely case that the driver itselves is already working - and your system just has failed to see that I linked a FAQ to the question that handles this kind of problem.

FAQ #1233: “Network Troubleshooting”.

Can you help with this problem?

Provide an answer of your own, or ask Roberto for more information if necessary.

To post a message you must log in.