ok so im on a dell inspiron 1545 dual booting windows 7 and ubuntu 10.2(or whatever the latest version is). When i first started up Ubuntu, the wifi connected to my wireless-N network and everything was working fine. Now, the second time i started it, the wifi wouldnt even enable. It works fine on the Windows 7 platform tho. HELP please!

Asked by Michael on 2010-08-07

ok so im on a dell inspiron 1545 dual booting windows 7 and ubuntu 10.2(or whatever the latest version is). When i first started up Ubuntu, the wifi connected to my wireless-N network and everything was working fine. Now, the second time i started it, the wifi wouldnt even enable. It works fine on the Windows 7 platform tho. HELP please!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Do you boot to Windows in between?

Revision history for this message
Michael (mydroid-mas) said :
#2

no, i have to restart my laptop to access windows 7 and vice versa

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

nevermind, ok this is very common because windows has a sucky feature which is fine in single boot systems but can make life hell i dual boot.

In device manager disable power management on the wireless device and also disable the ability for the device to wake up the PC. This annoyance will tie up the device and make it completely inaccessible to other operating systems.

Revision history for this message
Michael (mydroid-mas) said :
#4

ok i followed those instructions, and i restarted my computer, booted ubuntu, but my wifi still wont re-enable

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#5

Ok boot and get the wireless active and run:

dmesg > ~/Desktop/good.txt

Then boot with the wifi disabled then run:

dmesg > ~/Desktop/bad.txt

Open both files and compare.

Revision history for this message
Michael (mydroid-mas) said :
#6

whoa can u explain that more please, i have no idea what to do, im stupid when it comes to terminal stuff like that

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#7

Don't be afraid just because it's not "click this, click that". Its incredibly simple

Use the terminal to run the commands. When you boot and HAVE wireless, run the top command and it will create a file on the deskop named "good.txt". You then reboot to LOSE the wireless and run the second command, You now have the boot messages for the 2 boots, one when it's good and one when its bad, you can now compare.

Simple stuff.

Revision history for this message
PeterPall (peterpall) said :
#8

There are three graphical solutions left, though, as far as I can see:

1.) Install jockey-gtk if it isn't installed yet. This is a program that is started by System/Administration/something I don't remember and that lets you choose which drivers to use
2.) Enable the multiverse+universe set of packages in System/Administration/Software properties or System/Administration/Package repositories or from the preferences of Synaptic and reload the package list using synaptic and see if there are any restricted wifi drivers for you - which you can then enable using Jockey.
3.) start the synaptic package manager and install ndisgtk, which is a program that allows you to use any windows wifi driver. Then search for the appropriate driver in your windows installation - and select it.

Revision history for this message
Michael (mydroid-mas) said :
#9

Thanks actionparsnip, that solved my question.