Ubuntu

Wireless driver for hp mini1100

Asked by Eric S on 2010-08-03

Im using ubuntu 10.04 booting from a 2gb usb drive, (my laptop has no hard-drive). Everything seems to work except the wireless. The hardware driver program says i need a broadcom b43 and sta driver so i install the b43 but nothing happens and the sta driver wont install, (something about cant archive). After a reboot it seems everything goes back to factory default like there were no changes at all and/or im booting it for the first time. Any help will be appreciated. -Noob linux user

heres my output for "iwconfig":
~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
----------------------------------------------------------------
results after "spci -v | less": (shortened)

01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
        Subsystem: Hewlett-Packard Company Device 1507
        Flags: fast devsel, IRQ 16
        Memory at feafc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel modules: wl, ssb

02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller
        Subsystem: Hewlett-Packard Company Device 361a
        Flags: bus master, fast devsel, latency 0, IRQ 26

:

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-04
Last reply:
2010-08-20
Cameron W (cwill747) said : #1

Check out the information in the FAQ, it might help to address your problem.
FAQ #1233: “Network Troubleshooting”.

Eric S (snakeboyeric) said : #2

I looked at it and tried many things however I was missing a package or extension so I couldn't get any further in t5he instructions. I think i figured out how to save my info on reboot but I still can connect wirelessly to the internet. I know that I need a broadcom STU or STA driver but The hardware manager says something about archive not found and manual install attempts fail like the above.

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.