Wireless Network controller [0280]: RaLink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090] not working on MSI GX640 notebook when using built-in rt3090sta driver in Ubuntu 10.04 LTS

Asked by Arturo Corrales V on 2010-07-20

I just installed ubuntu 10.04 into my notebook MSI GX640, but I have problems with my wireless network since it doesn't appear to be working.

Looking into some forums and answers it seams that the problem is with the Wireless driver. This is my Network controller as I get when I run the command "lspci -v | less"

05:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
        Subsystem: Micro-Star International Co., Ltd. Device 6891
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d0200000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: rt3090
        Kernel modules: rt3090sta

As it is shows the network driver that I was looking for is the RT3090. As I found in the forums the answer to make this work is to do:

   $: sudo add-apt-repository ppa:markus-tisoft/rt3090
   $: sudo apt-get update
   $: sudo apt-get install rt3090-dkms

But when I try to do the command "$: sudo apt-get update" it returns me this error:

    Err http://ppa.launchpad.net lucid/main Packages
    404 Not Found

    W: Failed to fetch http://ppa.launchpad.net/markus-tisoft/rt3090/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

    E: Some index files failed to download, they have been ignored, or old ones used instead.

I tried to remove the repository to redo everything again, using the "ppa-purge" but when I tried it gives me this error:

~$ sudo ppa-purge ppa:markus-tisoft/rt3090
PPA to be removed: markus-tisoft rt3090
Warning: Could not find package list for PPA: markus-tisoft rt3090

Thanks for the help, am really looking forward to put the Wireless driver to work so I'll thank very much any advice to fix this :)

If it is need it to help me find my answer, my kernel version is 2.6.32-23

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2010-07-20
Last query:
2010-07-20
Last reply:
2010-07-20

Hi,

I believe the following comment in the bugreport 541620 should solve the issue:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/541620/comments/43

The procedure that you were trying to follow, only works in Ubuntu 9.04 or Ubuntu 9.10, but not in Ubuntu 10.04

The following link only contains directories for jaunty and karmic:

http://ppa.launchpad.net/markus-tisoft/rt3090/ubuntu/dists/

There is no directory entry there for lucid, so please try the following link instead:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/541620/comments/43

Regards,

Mark

If my previous suggestion does not help, please try following this procedure:

http://www.halibutdepot.org/how_to_build_rt3090_for_ubuntu_lucid/

Arturo Corrales V (arttak1586) said : #3

Thanks so much for your answer Mark, I tried the first suggestion that you posted about the bugreport 541620 and it fixed my Wireless issue.

It really surprise me the fast of the answer to my problem so I really want to thank you for it, and now I just have a last question about this:

Each time that I upgrade or reboot into a different kernel version do I need to reinstall the rt3090 driver?

I am wondering about it because in the second suggestion that you posted it says at the end in the Appendix that it can be rebuilt it using the DKMS module when you reboot into a different kernel, but I don't know if it applies also if I used the *.deb directly.

Thanks so much again for your time,

Arturo

Arturo Corrales V (arttak1586) said : #4

Thanks Mark Rijckenberg, that solved my question.

If wireless does not work anymore after upgrading the kernel, just reinstall the same rt3090 driver.....

Arturo Corrales V (arttak1586) said : #6

Ok, will do then.. Thanks again for your answers :)

You are welcome. :-)