Tata Photon + not working on Ubuntu 10.04 LTS

Asked by C.N. Shashidhar on 2010-06-15

Hi,

I've tried using Tata Photon + on Ubuntu 10.04 LTS - Huawei device EC1261.

It connects and displays as wireless broadband connection with IP address, subnet mask etc., but I'm unable to connect to the web. Set it up correctly and have tried to eject and re-insert USB device with same results.

I tried working with the Tata Photon guys to resolve this but not much help came out of it.

Pls help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-15
Last reply:
2011-01-28

Successful configuration of TATA PHOTON+ on Kubuntu on DELL
-------------------------------------------------------------------------------
Modem: Huawei Modem 270+ (EC1261)

All the above post are good but scattered, so here I put a complete details altogether that will be required for the newer modem that has inbuilt storage.

1. You will need usb-modeswitch, usb-modeswitch-data, wvdail . To install issue the command 'sudo apt-get install usb-modeswitch usb-modeswitch-data wvdial''.

2. Check your Modem device - After 5 sec of inserting the modem device, issue the command 'lsusb'
Here you will see your device as 'Bus 002 Device 025: ID 12d1:140b Huawei Technologies Co., Ltd.' or
'Bus 002 Device 007: ID 12d1:1446 Huawei Technologies Co., Ltd.'

3. To avoid any mis-configuration, edit the file '/etc/usb_modeswitch.d/12d1\:1446' at line TargetProductList="1001,1406,140c,14ac" to TargetProductList="1001,1406,140c,14ac,140b"
Create a new file '/etc/usb_modeswitch.d/12d1\:140b:uMa=AnyDATA', you can issue the command
sudo cp "/etc/usb_modeswitch.d/12d1:1446" "/etc/usb_modeswitch.d/12d1\:140b:uMa=AnyDATA".
In the new file '/etc/usb_modeswitch.d/12d1\:140b:uMa=AnyDATA', edit the line TargetProductList="1001,1406,140c,14ac,140b" to TargetProductList="140b"

4. Create the file '/etc/usb-modeswitch.conf' as follow:

########################################################
# Huawei E270+ (HSPA+ modem)

DisableSwitching=0

DefaultVendor= 0x12d1
DefaultProduct=0x1446

TargetVendor= 0x12d1
TargetProductList="1001,1406,140c,14ac,140b"
CheckSuccess=20

MessageContent="55534243123456780000000000000011060000000000000000000000000000"

HuaweiMode=1

EnableLogging=0

5. Then run the command 'sudo usb_modeswitch -c /etc/usb_modeswitch.d/12d1:140b:uMa=AnyDATA'
If it says that 'Waiting for original device to vanish ...', then after say 5 secs issue it again. Now, it will say

Original device is gone already, not checking
Searching for target devices ...
...............
Mode switch succeeded. Bye.

6. Setting up wvdial. Create/edit the file /etc/wvdial.conf. The file should look like

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 115200
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = #777
Password = internet
Username = internet

7. Checking modem : ls -l /dev/ttyU*, it will show something like

crw-rw---- 1 root dialout 188, 0 2011-01-28 16:07 /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 1 2011-01-28 16:07 /dev/ttyUSB1
crw-rw---- 1 root dialout 188, 2 2011-01-28 16:07 /dev/ttyUSB2

8. Dial out - To connect issue the command sudo wvdial.

And you will be connected to internet using your TATA PHOTON+ on Kubuntu

Regards,
Anisur

Can you help with this problem?

Provide an answer of your own, or ask C.N. Shashidhar for more information if necessary.

To post a message you must log in.