gnome mplayer growing playlist

Asked by Mannex on 2011-05-09

Fresh install of 11.04 with Gnome mplayer version 1.0.2.

Open mplayer, select View -> Playlist. The playlist opens, but continues to grow in length, even though it's empty. Please let me know if this is reproducable on other machines so that I can file a bug on this. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-mplayer Edit question
Assignee:
No assignee Edit question
Solved by:
Kevin DeKorte
Solved:
2011-05-14
Last query:
2011-05-14
Last reply:
2011-05-14
Kevin DeKorte (kdekorte-gmail) said : #1

When the global menu option is in use, gnome-mplayer has no way of detecting that the menu is not actually in the window. Recently in SVN (v > 1.0.3) a gconf/dconf key was added named "enable_global_menu" this option should be set to TRUE when the gtk global menu is enabled.

I asked in launchpad on how to automatically detect the global menu feature so this key would not be needed, but the question was ignored.

https://answers.launchpad.net/indicator-appmenu/+question/152538

See gnome-mplayer bug

http://code.google.com/p/gnome-mplayer/issues/detail?id=501

gnome-mplayer packagers will need to patch the gconf or dconf xml schema to set the correct value to true so that the option is enabled properly.

Mannex (russ-mannex) said : #2

I am unable to locate that key in my gconf-editor.

Kevin DeKorte (kdekorte-gmail) said : #3

If you are using SVN of gnome-mplayer and you are using gtk2 2.26 or higher the key might be in dconf. There should be a comparable dconf-editor. If you are not using svn of gnome-mplayer then you won't see the key.

Mannex (russ-mannex) said : #4

Not sure what SVN is, sorry. Either way, I am assuming this is a bug that should be fixed? Are others seeing the same problem?

Best Kevin DeKorte (kdekorte-gmail) said : #5

The fix in in the current development gnome-mplayer code and will be available in release v1.0.4. So the bug has been fixed it is just not released yet.

Mannex (russ-mannex) said : #6

Ah. In that case, I abdicate! Thanks!

Mannex (russ-mannex) said : #7

Thanks Kevin DeKorte, that solved my question.