Ubuntu

Invalid item on Places menu.

Asked by George A on 2009-03-11

Using Ubuntu 8.10

I managed to get a nonexistent partition to appear on my Places menu as described in bug #340682.

Is there a way to remove the menu item? My gtk-bookmarks folder contains only the default entries, so I don't think it's coming from there.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-menus Edit question
Assignee:
No assignee Edit question
Solved by:
Bernhard
Solved:
2009-03-11
Last query:
2009-03-11
Last reply:
2009-03-11
Bernhard (b.a.koenig) said : #1

Did you try this?

http://thetechturf.com/?p=462

Basically, just open nautilus and change it there in the leftmost column.

George A (george20021127) said : #2

Bernhard,

Nautilus does not give me the option to remove the partition as it does for the folder locations. The menu that is given contains the same options as for partitions that actually exist. Unfortunately, the Remove and Rename items are grayed out.

I get the Mount option, but it does not bring up the Authenticate dialog that appears with valid partitions.

Best Bernhard (b.a.koenig) said : #3

Is the bad partition still there if you reboot?

Bernhard (b.a.koenig) said : #4

Btw, please paste the output of

mount

and also

sudo fdisk -l

George A (george20021127) said : #5

mount results:
/dev/sda1 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.27-11-generic/volatile type tmpfs (rw,mode=755)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/george/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=george)

results for sudo fdisk -l:
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x80568056

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 9327 74919096 83 Linux
/dev/sda2 9328 9729 3229065 5 Extended
/dev/sda5 9328 9729 3229033+ 82 Linux swap / Solaris

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa7eba7eb

   Device Boot Start End Blocks Id System
/dev/sdb1 1 9729 78148161 5 Extended
/dev/sdb5 1 3824 30716217 83 Linux
/dev/sdb6 3825 9729 47431881 83 Linux

I noticed the following while playing around.

When I mount /dev/sdb5 through Places, it relabels itself from '31.5 GB Media' to '21.0 GB Media'
I suspect that it's due to the fact that there are actually two non-existent partitions being displayed. I found this by deleting all partitions on sdb.

When I'm in Nautilus, I do get the authenticate dialog for the nonexistent media, but it does not immediately come to the fore.

Bernhard (b.a.koenig) said : #6

I'm not sure if that helps you, but you can set the mount points at boot by changing the file

/etc/fstab

and there is a nice tutorial here
http://mesanna.com/2009/02/02/how-to-mount-a-partition-automatically-in-ubuntu-linux/

George A (george20021127) said : #7

"Is the bad partition still there if you reboot?"

Son of a .....

A good power cycle seems to have fixed it. I can see both logical partitions, with no nonexistent partitions cluttering things up. I can mount and dismount them properly as well.

Thank You for the help.

Bernhard (b.a.koenig) said : #8

One of the few things shared by Windows and Linux: rebooting fixes everything....

George A (george20021127) said : #9

Thanks Bernhard, that solved my question.

Tom (tom6) said : #10

Often just loging out and in again does the trick where only a reboot would do in Windows ;)