No sound is heard on playback with an HDA Intel internal mic

Asked by Sara on 2008-07-24

Binary package hint: gnome-media

I tried changing my sound system from ALSA to OSS and my internal mic *worked*...but I had such severe problems using OSS in general that I had to do a clean install of Ubuntu. I also tried openSUSE and Debian and nothing had changed for the better (now I'm back to Ubuntu). I would really like to use my microphone without having to try OSS again (and, furthermore, understand how the mic worked in OSS but not ALSA; could it have to do with how I had to change my default card in OSS for the sound to work? More specifically, the mic recorded on the default, but playback--along with all other sounds--only worked when I used /dev/oss/oss_hdaudio0/pcm3. This is what ultimately led to problems...).

In Gnome Sound Recorder the dial moves as I am (attempting) to record, but no sound is heard on playback. I don't receive any errors while recording. In alsamixer, I had to manually enable capture, and Digital is the device by default (it was Capture in openSUSE, if that helps). I don't have a Mic Boost option, only a "Mic as Output" from Volume Control. When I raise the volume on Mux, Mux becomes the device by default. Changing the device to any of the others (including and most importantly Capture) doesn't help. The only recording that ever happened with ALSA was when my mic would record whatever was playing on my computer (with a LOT of sound distortion). By the way, playback of my recordings was crystal-clear with OSS (and with Windows Vista, before I became a Linux user), so it certainly can't be a computer problem. The microphone also didn't work on the Ubuntu 8.04 Live CD...

If any more information is needed, I'll try my best to answer it. I'm running Ubuntu Hardy Heron, 64-bit. My sound card is an HDA Intel, with the SigmaTel STAC9221 A1 sound chip.

ProblemType: Bug
Architecture: amd64
Date: Wed Jul 23 21:38:33 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gnome-sound-recorder
Package: gnome-media 2.22.0-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-media
Uname: Linux 2.6.24-20-generic x86_64

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-29
Last reply:
2008-07-30
Sara (sfauzia) said : #1
Sebastien Bacher (seb128) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at [WWW] https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see [WWW] https://help.ubuntu.com/community/ReportingBugs .

Sara (sfauzia) said : #3

Thank you for converting this to a question--it makes more sense.

Sara (sfauzia) said : #4

I did some tests to show that my internal mic is being detected:

<code>sara@ubuntu:~$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdc440000 irq 22
sara@ubuntu:~$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdc440000 irq 22
sara@ubuntu:~$ cat /proc/asound/pcm
00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 2
sara@ubuntu:~$ arecord --list-devices
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
</code>

Sara (sfauzia) said : #5

This is a screenshot of my capture settings from alsamixer:

http://img92.imageshack.us/img92/8003/captureso9.png

Sara (sfauzia) said : #6

I've now installed Audacity, so if anyone has any suggestions, please gear them towards that (rather than Gnome Sound Recorder). Thanks!

Kimberly Jansen (kim-nz1313) said : #7

Hi

On my HDA Intel card using Alsamixer I have two input sources. Mic and Front Mic

Making both capture 1 and 2 set as mic and having both capture volumes at 3/4 with Mic boost at around half.

Looking at your alsamixer screen shot it look like your input source could be incorrect and your capture volumes are at 0.

Sara (sfauzia) said : #8

I had read somewhere about using Front Mic--but I'm ready to take your advice, and hope for the best. Is Mic Boost under your switches? I don't think I have that setting (but I'll try your other suggestions).

Sara (sfauzia) said : #9

Ah now it is playing sound upon recording--and it's very scratchy (my voice is not discernible or detectable. But this time, Audacity showed tiny jagged lines projecting from the main line (unlike being flat, as it was before. Hmmm.

Here is a screenshot:

http://img205.imageshack.us/img205/9552/audacityjb2.jpg

Kimberly Jansen (kim-nz1313) said : #10

Hi

My Mic Boost volume settings are on the playback section of alsamixer. I only have input sources on my Options. Capture, Capture 1 and Digital volumes are under recording.

My HDA Intel has a Realteck ALC268 chip so it's not exactly the same as yours. I did however have a similar issue to begin with. I just had to play around with the volume levels of the capture and mic boosts. I managed to get the internal mic to record but I did get a better result from using an external mic plugged into the front mic port.

I also found I got better control using the graphical volume control within gnome. I did have to edit the preferences to turn on all the volume controls though.

I Hope this helps..

Can you help with this problem?

Provide an answer of your own, or ask Sara for more information if necessary.

To post a message you must log in.