Ubuntu

Speakers not working, but headphone do!

Asked by Linked on 2008-02-14

I am having a problem with the sound. Laptop with ubuntu gutso.

Installed realtek-linux-audiopack-4.07b for Intel 82801G (ICH7 Family).

Sound works fine with headphone but won't get out of the speakers.

It works fine on windows.

I installed alsa and updated it.. even unchecked "headphones" but no sound.

Can you help?

thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Solved by:
Linked
Solved:
2008-02-15
Last query:
2008-02-15
Last reply:
2008-02-14
Savvas Radevic (medigeek) said : #1

You unchecked headphones.. where?

You need to try some stuff, like:
1) Check your cables and power source everything connected ok?
2) Check your connection to the computer, people usually connect it to the wrong input/output jack.
3) Go to menu Applications -> Sound & Video -> Volume Control - Make sure your speakers aren't muted.
Also, check other devices, from the menu File -> Change device.
4) Make sure the program/application you use to play the music is not in mute mode.
5) You'll probably need more info. Go to menu Applications -> Accessories -> Terminal and type:
cat /proc/asound/cards

Savvas Radevic (medigeek) said : #2

I'm sorry, didn't notice it was a laptop in question, ignore the first 2 questions if the speakers are internal :)

Linked (impatized) said : #3

I solved the problem myself. Thank you for you reply.

What you said above was basic steps I already did and unfortunately was not the answer :(.

Thank you :)

williamts99 (williamts99) said : #4

Linked,

Could you please explain how you fixed your issue, so that it can help others with the same problem?

Best Regards,
Williamts99

Linked (impatized) said : #5

Before we start: this tutorial assume that linux detected your sounds card and installed the drivers for it in its installation process. The issue I am flying over is if your drivers are installed correctly but still have no sound in the speakers ( Tested on a laptop ).

Do not forget: It may not work on your computer/laptop. so... BACKUP!!!!!

0) Preparations:
in terminal:
sudo apt-get update
sudo apt-get install po-debconf
sudo apt-get install debhelper
sudo apt-get install quilt
sudo apt-get install alsa-base
sudo apt-get install libc6-dev

NOTE! sudo command will always prompt you for your root password!

1) in the terminal type
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.15.tar.bz2

1.2) go in your home folder if you're not already in:
( long way for those you don't know about linux )
cd /
cd home
cd username (basically the username you used to log in your account)

2) unpack the file
tar xvjf alsa-driver-1.0.15.tar.bz2

3) go in the directory tar unpacked it
cd alsa-driver-1.0.15

3.2) then type
./configure
/make
sudo make install

NOTE! alsamixer mutes your sound!!!! step 4 will explain how you fix this.

4) after it installed type
alsamixer

4.2) you should be in the alsamixer program which is like when you double click the sound icon in GUI.
scroll with left and right keys. mute/unmute with M key. you should already have noticed the squares below the sound bars ( and even when there is no sound bars ). if you see MM, the sound is muted, if you see OO highlighted in green, your sound is on. Make sure the Master bar is in the green and not muted. use the up/down arrows to adjust it. Press escape to exit.

5) Now that we setted up the drivers, we'll force linux to load the modules. first type
vi /etc/modprobe.d/alsa-base

5.2) scroll down where you'll see all the options. there add at the end of the list
options snd-hda-intel model=X

NOTE! X being your laptop brand, i.e lg,hp,dell or (not tested) your sound card brand on desktop computer

5.3) To save and quit, type
:wq

6) now we're going to tell the kernel to load some modules on boot. type
sudo vi /etc/modules

6.2) make sure the file looks like this one ( the lines starting with # are comments and can be ignored )
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
sbp2

6.3) to save and quit, type
:wq

7) now you will have to reboot ubuntu, for this, type
shutdown -r now

8) Congratulation, you should be able to hear your login sound and all! If not, im sorry this little how to couldn't help you.

Regards,
Linked

Linked (impatized) said : #6

PLEASE read EVERYTHING BEFORE starting!!!!!

ktym08 (kittymama) said : #7

!! please do not try this unless you fully understand what each part of the instructions does exactly.
I tried it and it messed up all the sound drivers, and i had to reinstall everything.

lasma (lasmasi) said : #8

Thanks Linked!
I got my lenovo laptop making some sound :)
Though as a newbie I can admit that your instructions were not complete. I got file writing/saving problem in vi because you didn' t point that vi should be called with sudo (i.e. "sudo vi /etc/modprobe.d/alsa-base") to get administrator privileges to write in read-only files...
I hope this will help to other newbies while following your instructions.
Now I have to solve no-sound problem of my headphones...
But thanks once more time!

Linked (impatized) said : #9

I apologize for your trouble with vi. Here is a quick tutorial about it

You can navigate through your text file with the arrows. to do so ( and safely ) press the esc key. by doing so you won't be in insert mode. Then when you want to enter anything press i key to enter in insert mode. PLEASE note that once in insert mode you should only use alphanumerical keys. others will make you ( mostly) do unwanted things.

TO SAVE AND QUIT VI

Press the escape key. once in command mode type
:wq

to quit.

OR if you're logged in linux in graphic mode ( not in command line with no mouse interraction possible ) you can also open your text file with

sudo gedit /etc/modprobe.d/alsa-base

It will make you open the text editor mode in a graphic app, not in command line.

Once again, I apologize.

COMMAND IN STEP 5, TYPE AS BELOW!

sudo vi /etc/modprobe.d/alsa-base

OR IF NOT USED WITH VI

sudo gedit /etc/modprobe.d/alsa-base

Thanks and I hope this will help :)

Linked

Linked (impatized) said : #10

As for your headphone problem....

This is a known problem for many users because you cant tell if this will waork or not. I've read MANY things about alsa-drivers and depending of your hardware set-up, it might screw up up your mic or headphone.... maybe both.... or even not work at all... that is why you always need to back up your files before starting...

I apologize that I cant be of any help

lasma (lasmasi) said : #11

Hi again...
Thanks, vi is a bit complicated :) If I can, I use nano...
I solved my headphone problem.

First, I have one more entry under "sudo vi /etc/modules" which is "rtc".

----------
#/etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
rtc <----- this is what i have extra!!!!!
sbp2
----------------

I don' t know what fore it is but i turned " rtc" off (hided by adding # in the front) when i followed your (Linked) instructions, just in the case it is critical.
When I got my laptop singing I thought I might want to turn " rtc" on and see what happens. I restarted my computer and got sound from headphone jack :)
But laptop was also playing at the same time. I guess that is GNU/Linux thing because Windows automatically turns laptop speakers off. I just opened volume control and mutted laptop speakers and left headphones on. Now laptop is silent and I can listen to my music in the headphones don' t bothering others :)

Good luck to others!

Chris R (digressed) said : #12

When I try to type in my password I cannot type anything. Do you know how I can fix this?

@ Chris R
When you give your user password, you don't see nothing when you type it, then press enter.

arief (rifu-xiansheng83) said : #14

hai lasma,
i would like to ask you some question regarding sound problem in lenovo, by the way i'm using lenovo y4oo centrino duo with onboard soundcard...

i already follow all the step whic is mr linked wrote, but i still could not hear any sound from my laptop's speaker. but there is no problem with my headphone...

and my question is in this part " options snd-hda-intel model=X " what information that you write in X label...

Thank you very much.

Linked (impatized) said : #15

Greeting Arief,
I am sorry that you're having problems solving your sounds issue. You might want to try the following setup in your /etc/modprobe.d/alsa-base file

Try ( Only choose one of them, having more than one of these options will not work and you might have to reinstall the driver again. )

options snd-hda-intel model=3stack
options snd-hda-intel model=laptop
options snd-hda-intel model=lenovo

if that still not work, you can also try...

options snd-hda-intel model=auto

Hope this works.

Regards,
Linked

arief (rifu-xiansheng83) said : #16

hai linked,
thank you for your fast replay,
but i still can't hear any sound from my laptop's speaker..

what kind of status report that i could give you,
so maybe could make you easier to figure out the problem...

thank you very much....

Linked (impatized) said : #17

I couldn't really be of any help about that... I am using Debian etch as a server with windows clients ( and freespire gnu clients ).

On a server I don't need any sounds and the freespire autodetects drivers for me ><.

Linked

Froz3n (pedro-mendes-marques) said : #18

hey,, i ve done everything you said, and now i cant get sound on headphones as well :S
i have a toshiba satellite, if you want more info, just pm or reply.
pls help me now i cannot get any sound from any device

By the way: when i try to open Volume Control, i get an error message:
"No volume control GStreamer plugins and/or devices found."

Pradeepa (pradeepa-bk) said : #19

I too have done every thing.. along with speaker, earphones are not working..
How to revert it back? or solve it completely?
Could you tell me what exactly the problem and how to rectify such things?