Problems to see WMV

Asked by JOSE LUIS CERDAN on 2012-12-15

I can't see WMV, I have already bought and installed Fluendo Windows Media Pack without success. I have Ubuntu 12.04.1 LTS installed. AMD Athlon 64 3000+ and VESA 6330.
Many Thanks in advance for your help and for your great project.
Jose Luis Cerdan.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2012-12-15
Last query:
2012-12-15
Last reply:
2012-12-15

Please try running these commands:

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list --output-document=/etc/apt/sources.list.d/medibuntu.list

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -

sudo apt-get -q update

sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring

sudo apt-get -q update

sudo apt-get install ubuntu-restricted*

sudo apt-get install mplayer vlc

sudo apt-get install w32codecs libdvdcss2

sudo apt-get install w64codecs libdvdcss2

Run the previous line if you are using the 64-bit version of Ubuntu.

Then try viewing the .wmv file using vlc or mplayer.

JOSE LUIS CERDAN (jlc-cerdan) said : #2

Thank you very much Mark,
I think I may have a problem because I have windows Vista Basic still installed in my computer. I had this message installing the last command:
pepe@ubuntu:~$ sudo apt-get install w32codecs libdvdcss2
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete libdvdcss2 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: No se ha podido localizar el paquete w32codecs
E: El paquete «libdvdcss2» no tiene un candidato para la instalación
(sorry it's in spanish)
I will try to unistall Windows Vista (in fact I hate it!)
Thanks again.

Can you please send us the full Terminal output from all the commands you executed, including the commands themselves?

I get the impression that the commands above were not correctly copied into the Terminal....

It is not normal that w32codecs was not found.....

JOSE LUIS CERDAN (jlc-cerdan) said : #4

Here it is, may be I am doing something wrong, it's the first time I'm using the Ubuntu commands line.
The problem may be with the second command.

pepe@ubuntu:~$ sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list
[sudo] password for pepe:
Sorry, try again.
[sudo] password for pepe:
--2012-12-15 15:05:34-- http://www.medibuntu.org/sources.list.d/precise.list
Resolviendo www.medibuntu.org (www.medibuntu.org)... 88.191.127.22
Conectando con www.medibuntu.org (www.medibuntu.org)[88.191.127.22]:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 284 [text/plain]
Grabando a: “precise.list.6”

100%[======================================>] 284 --.-K/s en 0s

2012-12-15 15:05:55 (15,9 MB/s) - “precise.list.6” guardado [284/284]

pepe@ubuntu:~$ wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-
sudo: apt-: orden no encontrada
pepe@ubuntu:~$ key add -
Enter passphrase :
SCAR SAFE BHOY JURY MAUL LAIN
pepe@ubuntu:~$ sudo apt-get -q update
Ign http://es.archive.ubuntu.com precise InRelease
Ign http://es.archive.ubuntu.com precise-updates InRelease
Ign http://es.archive.ubuntu.com precise-backports InRelease
Obj http://es.archive.ubuntu.com precise Release.gpg
Ign http://security.ubuntu.com precise-security InRelease
Obj http://es.archive.ubuntu.com precise-updates Release.gpg
Des:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Obj http://es.archive.ubuntu.com precise-backports Release.gpg
Des:2 http://security.ubuntu.com precise-security Release [49,6 kB]
Obj http://es.archive.ubuntu.com precise Release
Obj http://es.archive.ubuntu.com precise-updates Release
Obj http://es.archive.ubuntu.com precise-backports Release
Obj http://es.archive.ubuntu.com precise/main Sources
Obj http://es.archive.ubuntu.com precise/restricted Sources
Obj http://es.archive.ubuntu.com precise/universe Sources
Obj http://es.archive.ubuntu.com precise/multiverse Sources
Obj http://es.archive.ubuntu.com precise/main i386 Packages
Obj http://es.archive.ubuntu.com precise/restricted i386 Packages
Obj http://es.archive.ubuntu.com precise/universe i386 Packages
Obj http://es.archive.ubuntu.com precise/multiverse i386 Packages
Obj http://es.archive.ubuntu.com precise/main TranslationIndex
Des:3 http://security.ubuntu.com precise-security/main Sources [58,4 kB]
Obj http://es.archive.ubuntu.com precise/multiverse TranslationIndex
Obj http://es.archive.ubuntu.com precise/restricted TranslationIndex
Obj http://es.archive.ubuntu.com precise/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/main Sources
Obj http://es.archive.ubuntu.com precise-updates/restricted Sources
Obj http://es.archive.ubuntu.com precise-updates/universe Sources
Obj http://es.archive.ubuntu.com precise-updates/multiverse Sources
Obj http://es.archive.ubuntu.com precise-updates/main i386 Packages
Obj http://es.archive.ubuntu.com precise-updates/restricted i386 Packages
Obj http://es.archive.ubuntu.com precise-updates/universe i386 Packages
Des:4 http://security.ubuntu.com precise-security/restricted Sources [1.950 B]
Des:5 http://security.ubuntu.com precise-security/universe Sources [18,1 kB]
Des:6 http://security.ubuntu.com precise-security/multiverse Sources [1.382 B]
Des:7 http://security.ubuntu.com precise-security/main i386 Packages [215 kB]
Obj http://es.archive.ubuntu.com precise-updates/multiverse i386 Packages
Obj http://es.archive.ubuntu.com precise-updates/main TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/restricted TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/main Sources
Obj http://es.archive.ubuntu.com precise-backports/restricted Sources
Obj http://es.archive.ubuntu.com precise-backports/universe Sources
Obj http://es.archive.ubuntu.com precise-backports/multiverse Sources
Obj http://es.archive.ubuntu.com precise-backports/main i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/restricted i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/universe i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/multiverse i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/main TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/restricted TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise/main Translation-es
Obj http://es.archive.ubuntu.com precise/main Translation-en
Obj http://es.archive.ubuntu.com precise/multiverse Translation-es
Obj http://es.archive.ubuntu.com precise/multiverse Translation-en
Obj http://es.archive.ubuntu.com precise/restricted Translation-es
Obj http://es.archive.ubuntu.com precise/restricted Translation-en
Obj http://es.archive.ubuntu.com precise/universe Translation-es
Obj http://es.archive.ubuntu.com precise/universe Translation-en
Des:8 http://security.ubuntu.com precise-security/restricted i386 Packages [3.968 B]
Des:9 http://security.ubuntu.com precise-security/universe i386 Packages [59,1 kB]
Obj http://es.archive.ubuntu.com precise-updates/main Translation-es
Obj http://es.archive.ubuntu.com precise-updates/main Translation-en
Obj http://es.archive.ubuntu.com precise-updates/multiverse Translation-es
Obj http://es.archive.ubuntu.com precise-updates/multiverse Translation-en
Obj http://es.archive.ubuntu.com precise-updates/restricted Translation-es
Des:10 http://security.ubuntu.com precise-security/multiverse i386 Packages [2.392 B]
Obj http://security.ubuntu.com precise-security/main TranslationIndex
Obj http://security.ubuntu.com precise-security/multiverse TranslationIndex
Obj http://security.ubuntu.com precise-security/restricted TranslationIndex
Obj http://security.ubuntu.com precise-security/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/restricted Translation-en
Obj http://es.archive.ubuntu.com precise-updates/universe Translation-es
Obj http://es.archive.ubuntu.com precise-updates/universe Translation-en
Obj http://es.archive.ubuntu.com precise-backports/main Translation-en
Obj http://es.archive.ubuntu.com precise-backports/multiverse Translation-en
Obj http://es.archive.ubuntu.com precise-backports/restricted Translation-en
Obj http://es.archive.ubuntu.com precise-backports/universe Translation-en
Obj http://security.ubuntu.com precise-security/main Translation-en
Obj http://security.ubuntu.com precise-security/multiverse Translation-en
Obj http://security.ubuntu.com precise-security/restricted Translation-en
Obj http://security.ubuntu.com precise-security/universe Translation-en
Ign https://private-ppa.launchpad.net precise InRelease
Obj https://private-ppa.launchpad.net precise Release.gpg
Obj https://private-ppa.launchpad.net precise Release
Obj https://private-ppa.launchpad.net precise/main i386 Packages
Ign https://private-ppa.launchpad.net precise/main TranslationIndex
Ign https://private-ppa.launchpad.net precise/main Translation-es_ES
Ign https://private-ppa.launchpad.net precise/main Translation-es
Ign https://private-ppa.launchpad.net precise/main Translation-en
Descargados 410 kB en 31seg. (13,2 kB/s)
Leyendo lista de paquetes...
pepe@ubuntu:~$ sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring
Leyendo lista de paquetes...
Creando árbol de dependencias...
Leyendo la información de estado...
E: No se ha podido localizar el paquete medibuntu-keyring
pepe@ubuntu:~$ sudo apt-get -q update
Ign http://security.ubuntu.com precise-security InRelease
Obj http://security.ubuntu.com precise-security Release.gpg
Ign http://es.archive.ubuntu.com precise InRelease
Obj http://security.ubuntu.com precise-security Release
Ign http://es.archive.ubuntu.com precise-updates InRelease
Ign http://es.archive.ubuntu.com precise-backports InRelease
Obj http://es.archive.ubuntu.com precise Release.gpg
Obj http://es.archive.ubuntu.com precise-updates Release.gpg
Obj http://security.ubuntu.com precise-security/main Sources
Obj http://es.archive.ubuntu.com precise-backports Release.gpg
Obj http://es.archive.ubuntu.com precise Release
Obj http://security.ubuntu.com precise-security/restricted Sources
Obj http://security.ubuntu.com precise-security/universe Sources
Obj http://security.ubuntu.com precise-security/multiverse Sources
Obj http://security.ubuntu.com precise-security/main i386 Packages
Obj http://security.ubuntu.com precise-security/restricted i386 Packages
Obj http://security.ubuntu.com precise-security/universe i386 Packages
Obj http://security.ubuntu.com precise-security/multiverse i386 Packages
Obj http://security.ubuntu.com precise-security/main TranslationIndex
Obj http://security.ubuntu.com precise-security/multiverse TranslationIndex
Obj http://security.ubuntu.com precise-security/restricted TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates Release
Obj http://security.ubuntu.com precise-security/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports Release
Obj http://security.ubuntu.com precise-security/main Translation-en
Obj http://security.ubuntu.com precise-security/multiverse Translation-en
Obj http://es.archive.ubuntu.com precise/main Sources
Obj http://es.archive.ubuntu.com precise/restricted Sources
Obj http://es.archive.ubuntu.com precise/universe Sources
Obj http://es.archive.ubuntu.com precise/multiverse Sources
Obj http://es.archive.ubuntu.com precise/main i386 Packages
Obj http://es.archive.ubuntu.com precise/restricted i386 Packages
Obj http://es.archive.ubuntu.com precise/universe i386 Packages
Obj http://security.ubuntu.com precise-security/restricted Translation-en
Obj http://es.archive.ubuntu.com precise/multiverse i386 Packages
Obj http://es.archive.ubuntu.com precise/main TranslationIndex
Obj http://es.archive.ubuntu.com precise/multiverse TranslationIndex
Obj http://es.archive.ubuntu.com precise/restricted TranslationIndex
Obj http://security.ubuntu.com precise-security/universe Translation-en
Obj http://es.archive.ubuntu.com precise/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/main Sources
Obj http://es.archive.ubuntu.com precise-updates/restricted Sources
Obj http://es.archive.ubuntu.com precise-updates/universe Sources
Obj http://es.archive.ubuntu.com precise-updates/multiverse Sources
Obj http://es.archive.ubuntu.com precise-updates/main i386 Packages
Obj http://es.archive.ubuntu.com precise-updates/restricted i386 Packages
Obj http://es.archive.ubuntu.com precise-updates/universe i386 Packages
Obj http://es.archive.ubuntu.com precise-updates/multiverse i386 Packages
Obj http://es.archive.ubuntu.com precise-updates/main TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/restricted TranslationIndex
Obj http://es.archive.ubuntu.com precise-updates/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/main Sources
Obj http://es.archive.ubuntu.com precise-backports/restricted Sources
Obj http://es.archive.ubuntu.com precise-backports/universe Sources
Obj http://es.archive.ubuntu.com precise-backports/multiverse Sources
Obj http://es.archive.ubuntu.com precise-backports/main i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/restricted i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/universe i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/multiverse i386 Packages
Obj http://es.archive.ubuntu.com precise-backports/main TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/restricted TranslationIndex
Obj http://es.archive.ubuntu.com precise-backports/universe TranslationIndex
Obj http://es.archive.ubuntu.com precise/main Translation-es
Obj http://es.archive.ubuntu.com precise/main Translation-en
Obj http://es.archive.ubuntu.com precise/multiverse Translation-es
Obj http://es.archive.ubuntu.com precise/multiverse Translation-en
Obj http://es.archive.ubuntu.com precise/restricted Translation-es
Obj http://es.archive.ubuntu.com precise/restricted Translation-en
Obj http://es.archive.ubuntu.com precise/universe Translation-es
Obj http://es.archive.ubuntu.com precise/universe Translation-en
Obj http://es.archive.ubuntu.com precise-updates/main Translation-es
Obj http://es.archive.ubuntu.com precise-updates/main Translation-en
Obj http://es.archive.ubuntu.com precise-updates/multiverse Translation-es
Obj http://es.archive.ubuntu.com precise-updates/multiverse Translation-en
Obj http://es.archive.ubuntu.com precise-updates/restricted Translation-es
Obj http://es.archive.ubuntu.com precise-updates/restricted Translation-en
Obj http://es.archive.ubuntu.com precise-updates/universe Translation-es
Obj http://es.archive.ubuntu.com precise-updates/universe Translation-en
Obj http://es.archive.ubuntu.com precise-backports/main Translation-en
Obj http://es.archive.ubuntu.com precise-backports/multiverse Translation-en
Obj http://es.archive.ubuntu.com precise-backports/restricted Translation-en
Obj http://es.archive.ubuntu.com precise-backports/universe Translation-en
Ign https://private-ppa.launchpad.net precise InRelease
Obj https://private-ppa.launchpad.net precise Release.gpg
Obj https://private-ppa.launchpad.net precise Release
Obj https://private-ppa.launchpad.net precise/main i386 Packages
Ign https://private-ppa.launchpad.net precise/main TranslationIndex
Ign https://private-ppa.launchpad.net precise/main Translation-es_ES
Ign https://private-ppa.launchpad.net precise/main Translation-es
Ign https://private-ppa.launchpad.net precise/main Translation-en
Leyendo lista de paquetes...
pepe@ubuntu:~$ sudo apt-get install ubuntu-restricted*
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Nota, seleccionando «lubuntu-restricted-extras» para la expresión regular «ubuntu-restricted*»
Nota, seleccionando «xubuntu-restricted-extras» para la expresión regular «ubuntu-restricted*»
Nota, seleccionando «lubuntu-restricted-addons» para la expresión regular «ubuntu-restricted*»
Nota, seleccionando «xubuntu-restricted-addons» para la expresión regular «ubuntu-restricted*»
Nota, seleccionando «kubuntu-restricted-extras» para la expresión regular «ubuntu-restricted*»
Nota, seleccionando «kubuntu-restricted-addons» para la expresión regular «ubuntu-restricted*»
Nota, seleccionando «ubuntu-restricted-extras» para la expresión regular «ubuntu-restricted*»
Nota, seleccionando «ubuntu-restricted-addons» para la expresión regular «ubuntu-restricted*»
kubuntu-restricted-addons ya está en su versión más reciente.
kubuntu-restricted-extras ya está en su versión más reciente.
lubuntu-restricted-addons ya está en su versión más reciente.
lubuntu-restricted-extras ya está en su versión más reciente.
ubuntu-restricted-addons ya está en su versión más reciente.
ubuntu-restricted-extras ya está en su versión más reciente.
xubuntu-restricted-addons ya está en su versión más reciente.
xubuntu-restricted-extras ya está en su versión más reciente.
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  language-pack-zh-hans kde-l10n-es language-pack-kde-en language-pack-kde-es
  linux-headers-3.2.0-29 language-pack-kde-zh-hans language-pack-kde-en-base
  kde-l10n-engb linux-headers-3.2.0-29-generic-pae kde-l10n-zhcn
  language-pack-kde-es-base language-pack-zh-hans-base
  language-pack-kde-zh-hans-base
Utilice «apt-get autoremove» para eliminarlos.
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
pepe@ubuntu:~$ sudo apt-get install mplayer vlc
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
mplayer ya está en su versión más reciente.
vlc ya está en su versión más reciente.
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  language-pack-zh-hans kde-l10n-es language-pack-kde-en language-pack-kde-es
  linux-headers-3.2.0-29 language-pack-kde-zh-hans language-pack-kde-en-base
  kde-l10n-engb linux-headers-3.2.0-29-generic-pae kde-l10n-zhcn
  language-pack-kde-es-base language-pack-zh-hans-base
  language-pack-kde-zh-hans-base
Utilice «apt-get autoremove» para eliminarlos.
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
pepe@ubuntu:~$ sudo apt-get install w32codecs libdvdcss2
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete libdvdcss2 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: No se ha podido localizar el paquete w32codecs
E: El paquete «libdvdcss2» no tiene un candidato para la instalación
pepe@ubuntu:~$

Yep, just as I suspected...

You cut the following 2 commands into lots of INVALID pieces:

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list --output-document=/etc/apt/sources.list.d/medibuntu.list

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -

Please use a browser like Firefox or Chromium and visit the following page:

https://answers.launchpad.net/ubuntu/+question/216873

CAREFULLY compare my commands with what you did....

For example:

You tried

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list

but I CLEARLY gave you this command

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list --output-document=/etc/apt/sources.list.d/medibuntu.list

which is a SINGLE command and a LOT longer than yours.....

JOSE LUIS CERDAN (jlc-cerdan) said : #6

You're right Mark, I did it wrong.
Sorry for the delay in answering, but I have detected other problems and I'm going to install again SO.
Thanks for your help.

I also suggest reading these guides:

https://help.ubuntu.com/community/ExternalGuides