DVD won't play

Asked by Jared on 2012-10-16

Ok, I have researched until my eyes started bleeding. I cannot get any of my dvd's to play. I installed restricted software, I added the whole medi ubuntu repo and installed libdvdread4. I have installed region set and set my region to 1 for North America. I have tried using Mplayer and VLC. both will show the name of the dvd and the drive spins for thirty seconds or so. with movi player I still get the error that it is encrypted and I'm missing libraries.

Question information

English Edit question
Ubuntu gnome-media Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jared (tortuga-guy69) said :

Did some more digging and I am able to get vlc to play but the quality is horrible. I can't make anything out and it cuts in and out along with the audio

Revision history for this message
Warren Hill (warren-hill) said :

By default Ubuntu only plays unrestricted DVDs because of licensing issues and the the software to decode them not being open source. This means almost no DVDs

You can get round that however see here: https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

Revision history for this message
Jared (tortuga-guy69) said :

I have followed that thread and many others to a T. I have spent hours trying to get this to work and no matter how many variations of installing liddvdcss2 or libdvdread4 I'm still having trouble. I have gotten to the point where VLC will play the video however, kaffeine and mplayer still give the encrypted data error. The problem I have now is how blocky and pixelated the movie is. almost to the point that its not worth watching. VLC player works fine when I boot up windows 7 and try to watch the same dvd.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you help with this problem?

Provide an answer of your own, or ask Jared for more information if necessary.

To post a message you must log in.