What am I doing wrong here in Mencoder?

Asked by AlexOnVinyl on 2012-04-17

Here's basically what I'm attempting to do - convert .mkv to .avi

Here's the command(s) I used:
here's the first one I tried, which worked - but had no sound at all:

    $ mencoder Immortals.2011.720p.BRRip.x264.mkv -ovc xvid -xvidencopts bitrate=800:pass=2 -oac copy -o Immortals.2011.720p.BRRip.xviD.avi

This one gave more results about an unsupported pixel format with the audio
Both gave moments of the same frames..

    $ mencoder Immortals.2011.720p.BRRip.x264.mkv -ovc xvid -xvidencopts bitrate=800:pass=2 -oac mp3lame -lameopts vbr=1 -o Immortals.2011.720p.BRRip.xviD.avi

both gave the following:

> MP3 audio selected. Unsupported PixelFormat 61 Unsupported PixelFormat
> 53 Unsupported PixelFormat 81
>
> This one specifically gave this:
>

    $ mencoder Immortals.2011.720p.BRRip.x264.mkv -ovc xvid -xvidencopts
    bitrate=800:pass=2 -oac mp3lame -lameopts vbr=1 -o
    Immortals.2011.720p.BRRip.xviD.avi

>
> success: format: 0 data: 0x0 - 0x7a1b4576 libavformat version 53.21.0
> (external) Mismatching header version 53.19.0 libavformat file format
> detected. [matroska,webm @ 0xb6aced80]max_analyze_duration reached
> [matroska,webm @ 0xb6aced80]Estimating duration from bitrate, this may
> be inaccurate [lavf] stream 0: video (h264), -vid 0 [lavf] stream 1:
> audio (ac3), -aid 0, -alang eng [lavf] stream 2: subtitle (text), -sid
> 0, -slang eng VIDEO: [H264] 1280x690 0bpp 23.976 fps 0.0 kbps (
> 0.0 kbyte/s) [V] filefmt:44 fourcc:0x34363248 size:1280x690 fps:23.976 ftime:=0.0417
> ========================================================================== Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
> libavcodec version 53.35.0 (external) Mismatching header version
> 53.32.2 AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000) Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
> ========================================================================== xvid: using library version 1.3.2 (build xvid-1.3.2) Opening video
> filter: [expand osd=1] Expand: -1 x -1, -1 ; -1, osd: 1, aspect:
> 0.000000, round: 1
> ========================================================================== Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
> Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
> ========================================================================== MP3 audio selected. Unsupported PixelFormat 61 Unsupported PixelFormat
> 53 Unsupported PixelFormat 81 Pos: 0.0s 2f ( 0%) 0.00fps Trem:
> 0min 0mb A-V:0.004 [0:0] Movie-Aspect is 1.86:1 - prescaling to
> correct movie aspect. videocodec: XviD (1280x690 fourcc=44495658
> [XVID]) xvid: par=0/0 (vga11), displayed=1280x690, sampled=1280x690
> xvid: 2Pass Rate Control -- 2nd pass -- bitrate=800kbit/s Writing
> header... ODML: vprp aspect is 16384:8831. Setting audio delay to
> 0.048s. Writing header... ODML: vprp aspect is 16384:8831. Setting audio delay to 0.048s.
>
> 1 duplicate frame(s)! Pos: 1.2s 29f ( 0%) 0.00fps Trem: 9min
> 47mb A-V:0.084 [98:169]]
>
> Skipping frame! Pos: 1.9s 48f ( 0%) 13.11fps Trem: 56min 285mb
> A-V:0.051 [1081:192Pos: 2.0s 49f ( 0%) 12.24fps Trem: 61min
> 310mb A-V:0.055 [1170:193Pos: 2.0s 50f ( 0%) 12.10fps Trem:
> 63min 323mb A-V:0.051 [1201:195

Then I stopped the command

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-17
Last reply:
2012-04-17

why not just rerip the DVD with different options if mencoder is giving you issues...

Can you help with this problem?

Provide an answer of your own, or ask AlexOnVinyl for more information if necessary.

To post a message you must log in.