I have ubuntu 12.04 and I want to watch a movie in movie player.

Asked by oocevin on 2012-01-10

When I put the dvd in it says it needs
Gstreamer extra plugins
codecs to play mp3, sid, mpeg1, mpeg3, AC-3, DVD (without encription)
Gstreamer plugins for mms, wavpack, quicktime, musepack
Codects to play
gstreamer0, 10-plugins-bad:i386
Gstreamer plugin from the "bad" set
gstreamer0, 10-plugins-ugly:i386
Gstreamer plugin from the "ugly" set.

And when I try to install them I get these errors:

 The following packages have unmet dependencies:

gstreamer0.10-plugins-bad: Depends: libc6 (>= 2.7) but 2.13-24ubuntu2 is to be installed
                           Depends: libcairo2 (>= 1.2.4) but 1.10.2-6.1ubuntu2 is to be installed
                           Depends: libcdaudio1 (>= 0.99.12p2) but 0.99.12p2-10 is to be installed
                           Depends: libcurl3-gnutls (>= 7.16.2-1) but 7.22.0-3ubuntu1 is to be installed
                           Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.2-10ubuntu1 is to be installed
                           Depends: libglib2.0-0 (>= 2.26.0) but 2.31.8-0ubuntu1 is to be installed
                           Depends: libgsm1 (>= 1.0.13) but 1.0.13-3 is to be installed
                           Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.33) but 0.10.35.2-2build1 is to be installed
                           Depends: libgstreamer0.10-0 (>= 0.10.33) but 0.10.35.2-1ubuntu1 is to be installed
                           Depends: libjasper1 (>= 1.900.1) but 1.900.1-12ubuntu1 is to be installed
                           Depends: libmpcdec6 (>= 1:0.1~r435) but 2:0.1~r459-1ubuntu1 is to be installed
                           Depends: libmusicbrainz4c2a (>= 2.1.5) but 2.1.5-6.2 is to be installed
                           Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                           Depends: libpng12-0 (>= 1.2.13-4) but 1.2.46-3ubuntu1 is to be installed
                           Depends: librsvg2-2 (>= 2.14.4) but 2.34.2-1ubuntu1 is to be installed
                           Depends: librtmp0 (>= 2.3) but 2.4~20110711.gitc28f1bab-1 is to be installed
                           Depends: libschroedinger-1.0-0 (>= 1.0.9) but 1.0.10-2.1 is to be installed
                           Depends: libsndfile1 (>= 1.0.20) but 1.0.25-3 is to be installed
                           Depends: libssl1.0.0 (>= 1.0.0) but 1.0.0e-2ubuntu4 is to be installed
                           Depends: libstdc++6 (>= 4.1.1) but 4.6.2-10ubuntu1 is to be installed
gstreamer0.10-plugins-bad:i386: Depends: libc6 (>= 2.7) but 2.13-24ubuntu2 is to be installed
                                Depends: libcairo2 (>= 1.2.4) but 1.10.2-6.1ubuntu2 is to be installed
                                Depends: libcdaudio1 (>= 0.99.12p2) but 0.99.12p2-10 is to be installed
                                Depends: libcurl3-gnutls (>= 7.16.2-1) but 7.22.0-3ubuntu1 is to be installed
                                Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.2-10ubuntu1 is to be installed
                                Depends: libglib2.0-0 (>= 2.26.0) but 2.31.8-0ubuntu1 is to be installed
                                Depends: libgsm1 (>= 1.0.13) but 1.0.13-3 is to be installed
                                Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.33) but 0.10.35.2-2build1 is to be installed
                                Depends: libgstreamer0.10-0 (>= 0.10.33) but 0.10.35.2-1ubuntu1 is to be installed
                                Depends: libjasper1 (>= 1.900.1) but 1.900.1-12ubuntu1 is to be installed
                                Depends: libmpcdec6 (>= 1:0.1~r435) but 2:0.1~r459-1ubuntu1 is to be installed
                                Depends: libmusicbrainz4c2a (>= 2.1.5) but 2.1.5-6.2 is to be installed
                                Depends: libopenspc0 but it is not going to be installed
                                Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                                Depends: libpng12-0 (>= 1.2.13-4) but 1.2.46-3ubuntu1 is to be installed
                                Depends: librsvg2-2 (>= 2.14.4) but 2.34.2-1ubuntu1 is to be installed
                                Depends: librtmp0 (>= 2.3) but 2.4~20110711.gitc28f1bab-1 is to be installed
                                Depends: libschroedinger-1.0-0 (>= 1.0.9) but 1.0.10-2.1 is to be installed
                                Depends: libsndfile1 (>= 1.0.20) but 1.0.25-3 is to be installed
                                Depends: libssl1.0.0 (>= 1.0.0) but 1.0.0e-2ubuntu4 is to be installed
                                Depends: libstdc++6 (>= 4.1.1) but 4.6.2-10ubuntu1 is to be installed
gstreamer0.10-plugins-ugly: Depends: libc6 (>= 2.7) but 2.13-24ubuntu2 is to be installed
                            Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.2-10ubuntu1 is to be installed
                            Depends: libglib2.0-0 (>= 2.31.2) but 2.31.8-0ubuntu1 is to be installed
                            Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.26) but 0.10.35.2-2build1 is to be installed
                            Depends: libgstreamer0.10-0 (>= 0.10.26) but 0.10.35.2-1ubuntu1 is to be installed
                            Depends: libid3tag0 (>= 0.15.1b) but 0.15.1b-10build2 is to be installed
                            Depends: libmad0 (>= 0.15.1b-3) but 0.15.1b-6ubuntu1 is to be installed
                            Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                            Depends: libstdc++6 (>= 4.1.1) but 4.6.2-10ubuntu1 is to be installed
gstreamer0.10-plugins-ugly:i386: Depends: libc6 (>= 2.7) but 2.13-24ubuntu2 is to be installed
                                 Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.2-10ubuntu1 is to be installed
                                 Depends: libglib2.0-0 (>= 2.31.2) but 2.31.8-0ubuntu1 is to be installed
                                 Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.26) but 0.10.35.2-2build1 is to be installed
                                 Depends: libgstreamer0.10-0 (>= 0.10.26) but 0.10.35.2-1ubuntu1 is to be installed
                                 Depends: libid3tag0 (>= 0.15.1b) but 0.15.1b-10build2 is to be installed
                                 Depends: libmad0 (>= 0.15.1b-3) but 0.15.1b-6ubuntu1 is to be installed
                                 Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                                 Depends: libstdc++6 (>= 4.1.1) but 4.6.2-10ubuntu1 is to be installed
Can any body figure it out?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-01-10
Last query:
2012-01-10
Last reply:
2012-01-10

I suggest you report a bug. Precise is not ready and not stable so you WILL get issues.

If you need a stable OS that works then use Oneiric, if you are happy to use a half ready OS and want to report bugs to get the release ready for april, then use Precise.

oocevin (ccct007) said : #2

Yes another friend to me that before I installed.

So I will use you info and install Oneiric

oocevin (ccct007) said : #3

This is what I did:
sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdread4

sudo /usr/share/doc/libdvdread4/install-css.sh

I installed vlc and that is what I'm using.
Same problem as u 11.10

oocevin (ccct007) said : #4

I did a reinstall to see just what I needed to make it work.
You do not have to install sudo apt-get install ubuntu-restricted-extras