One user account can't watch videos

Asked by LEGOManiac on 2012-01-03

I used to be able to watch local videos of all formats on my account. A couple of weeks ago the video stream stopped, but I still get the sound. I can watch videos via a web browser, but not if I copy them to my desktop.

Today I just stumbled on something:

I was enabling the Guest account for my son's friends and discovered that the Guest account could play the same videos (copied to the Guest's Desktop) with both audio and video.

I went back to my account and confirmed that I only get audio.

I then opened a terminal and switched to root (sudo su) and ran Totem, then tried playing the videos. I still only get audio and no video.

That would seem to eliminate a problem with either codes, medibuntu, or the players themselves.

I'm guessing some file in my local profile is corrupted and is preventing me from seeing the video streams, but I have no idea what it would be.

Can anyone suggest something?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Solved by:
LEGOManiac
Solved:
2012-01-13
Last query:
2012-01-13
Last reply:
2012-01-03

Can you give the output of:

groups

as the troublesome account.

I also suggest you se:

sudo -i

to get a root terminal.

LEGOManiac (bzflaglegomaniac) said : #2

Thanks, actionparsnip for assisting...

sudo -i
totem /home/legomaniac/Desktop/snow.flv

still produces sound but no video.

Output from groups:

legomaniac adm lp dialout cdrom plugdev lpadmin admin sambashare vboxusers

That gives me an idea: I'll see what the output of groups is when I log into the guest account to see what's different.

LEGOManiac (bzflaglegomaniac) said : #3

I logged in as "guest" and copied a video from my desktop to the guest desktop, then re-confirmed that the guest account could get both sound and video.

Output from groups as user "guest"

nogroup cdrom video plugdev fuse nopasswdlogin

The most obvious thing is the addition of the "video" group, so I made my account a member of that group, logged out and logged back in again and used "groups" to confirm I was now a member of the 'video' group and tried a video again.

I still only get sound and no video.

Groups look good

LEGOManiac (bzflaglegomaniac) said : #5

It would seem that there is something in this one account's profile that has been corrupted, but I don't know where to look,

Does anyone have any ideas?

LEGOManiac (bzflaglegomaniac) said : #6

Solution
 Open the Configuration Editor (run gconf-editor in the terminal). Navigate to system > gstreamer > 0.10 > default, double-click on videosink and change the setting from autovideosink to ximagesink