Unable to watch any video via mplayer, vlc, etc

Asked by LEGOManiac on 2011-12-31

For some reason, about a week ago, my computer stopped playing videos.

When I try to watch any kind of video, I get the sound, but no picture. To be clear(er) I can watch a flash video on youtube, but if I save it locally, it won't play. Neither will avi, mp4, mov, etc. etc. The same applies to DVDs - sound but no video.

I've tried VLC, mplayer, totem and xine.

Up until about two weeks ago, everything was working fine. I'm not sure what I did to kill it. I've tried re-installing medibuntu via

sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

followed by

sudo apt-get install app-install-data-medibuntu apport-hooks-medibuntu

In both cases I get a message that I already have the latest versions installed and nothing is added, removed or updated.

I'd appreciate some guidance on how to fix this.

For now, I'm having to boot a live CD to watch videos - very inconvenient.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Solved by:
LEGOManiac
Solved:
2012-01-13
Last query:
2012-01-13
Last reply:
2012-01-03
Chris (fabricator4) said : #1

It sound like the codecs and other stuff need for video replay has been messed up. You could try installing it again:

sudo apt-get install ubuntu-restricted-extras

If this doesn't work maybe do a complete purge and the try re-installing again:

sudo apt-get purge ubuntu-restricted-extras && sudo apt-get autoremove
sudo apt-get install ubuntu-restricted-extras

Chris

LEGOManiac (bzflaglegomaniac) said : #2

Thanks for the help. I had tried re-installing the extras. I didn't know about apt-get purge, mind you, so I tried it, but I still get audio only on anything outside of a web browser.

Chris (fabricator4) said : #3

OK, the problem may be with alsamixer. There's more than just the obvious master volume and if they are set wrong it can cause you problems. Open up alsa-mixer from a terminal window:

alsamixer

and set all the levels to max, or at least most of the way. Don't forget to scroll over to the right: on systems with lots of controls the amount of settings can be extensive.

Chris

LEGOManiac (bzflaglegomaniac) said : #4

Thanks for the help, Chris, but I think you've misread the question... I have sound but no video (not the other way around).

LEGOManiac (bzflaglegomaniac) said : #5

Solution
 Open the Configuration Editor (run gconf-editor in the terminal). Navigate to system > gstreamer > 0.10 > default, double-click on videosink and change the setting from autovideosink to ximagesink