Ubuntu

mp4 and m4v files not recognised, despite enabling video plugin

Asked by Peter Harvey on 2011-11-30

I have an up to date Oneiric installation. Gtkpod works OK, but I am unable to add video files of format mp4 and m4v. In either case an error message complains that the file type is not recognised. I have enabled the Video Filetype Plugin.

Is there a dependency missing, or is it me?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Last query:
2011-12-24
Last reply:
2012-01-09
Peter Harvey (pdqharvey) said : #1

BTW: I should have siad that I use an iPod Classic 120GB

Did you install ubuntu-restricted-extras

You may also want to add the medibuntu repo and install w32codecs (I assume 32bit Gnome desktop).

Peter Harvey (pdqharvey) said : #3

Thanks for the quick response. I did have restricted extras installed, but not the win codecs in the Medibuntu repository. I'm using Unity 3D on a 64bit machine (I should have said) so I installed the w64codecs package. That was the right thing to do, I presume?

Am sad to report that the problem remains, and I have tested it with some videos I previously had working on the same iPod, but an earlier version of Ubuntu and GTKPod. (I subsequently scrubbed everything and reformatted the iPod using iTunes under Windows, as I hit a major corruption problem. However, I think that should be irrelevant, as it has had a clean install, in effect.)

Any other ideas?

try playing the same files with VLC. if it's playing, then it is the problem with the installed plugins. then you need the remove all installed pluging (from software center and use computer janitor to clean once..it is very much required) and install the following:

gstreamer ffmpeg

gstreamer extra plugins

gstreamer plugins for mms, wavepack.......

gstreamer plugins for aac, xvid.....

Just install the mentioned plugins. all are available in software center. nothing else required.

Peter Harvey (pdqharvey) said : #5

Thanks for the suggestions. Yes indeed, these files are all playable in VLC or whatever, and yes, I have all the necessary gstreamer plugins. However, for good measure, I uninstalled all of them and gtkpod, then reinstalled, just in case it made any difference to install gtkpod with the plugins already in place. It did not, of course. So I'm still left without video support.

I tried adding a video (one of thise which failed under Ubuntu) using iTunes under Win7, which worked and was recognised in GTKPod (though checking the checksums took an age when connecting the iPod the next time under Ubuntu). At least the hardware is OK.

Can anyone confirm that they have GTKpod fully working with video support on an Ubuntu 11.10 64bit (Unity3D) system? It would be very useful to know that this is not simply a bug.

NB: No disrespect intended, but...
The Computer Janitor is no longer part of the Ubuntu release as it is redundant (apt does it better and more carefully) and can be destructive. However, wishing to follow Murali's advice, I proceeded with caution with it. With no warnings, it merely attempted to remove a couple of innocent applications I had installed from debs. Sorry to contradict you, but that was misleading advice. As far as I have been able to ascertain, one should steer well clear of Computer Janitor and instead (carefully) use apt's commands. There are also useful things one can do within Synaptic, under the 'status' tab.

It is in the release:

andy@D420:~$ apt-cache policy computer-janitor
computer-janitor:
  Installed: (none)
  Candidate: 2.1.0-0ubuntu7
  Version table:
     2.1.0-0ubuntu7 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

It's even in precise. It does an okay job but imho bleachbit is more thorough.

Peter Harvey (pdqharvey) said : #7

Computer Janitor is in the release, but no longer included by default, correct? And it does have destructive tendencies (identifying manually installed applications as ripe for deletion), which (I have read) is why it is only an optional application. Bleachbit is fine, yes. But none of that (starting with the suggestion that Computer Janitor would fix GTKPod) is really relevant to this particular problem, and this is drifting a bit off-topic...

Which was: GTKPod is unable to add video files - on my system.

Is anyone actually able to add video files in version 2.1.0? If not, this would seem to be a bug, and I'd like to rule that out before chasing a solution.

All suggestions, and especially confirmation of it working (or not) for you would be very gratefully received.

tqft (ianburrows-au) said : #8

I have exactly this problem.

Additional information: I have my main (older) desktop - Ubuntu 11.04 x32 - the files I rip on my laptop (11.10 x64) using Handbrake I load and play on my iPod, if and only if I use 11.04 to load them.

What I have learnt so far - libmp4v2 has apparently been removed from Oneiic
http://www.ubuntuupdates.org/packages/show/325915
I https://bugs.launchpad.net/ubuntu/+source/easytag/+bug/880625
https://bugs.launchpad.net/ubuntu/+source/easytag/+bug/880625/comments/2
"libmp4v2 has been removed from the package due to licensing issues and replaced by taglib."

Am about to try the natty libmp4v2 (x64) deb in oneiric

Peter Harvey (pdqharvey) said : #9

@IanBurrows:

This is really useful, thanks. I was pretty sure it wasn't something obvious. I too had discovered that libmp4v2 was missing (but how I came to that conclusion, I cannot for the life of me remember - some late-night googling) and failed to find the library file in the Oneiric repos. Using one from an earlier release seems a clever idea. I'll try that as well, and report back. Look forward to your results as well.

Maybe the developers of GTKPod could have a look at this? This issue must be affecting many people.

Anybody else come across this problem, or find a solution yet?

tqft (ianburrows-au) said : #10

Natty version didn't help (reinstalled gtkpod, a sudo ldconfig & a machine restart to cover all bases).

Can't build from source, some incompatability with faac. I note the version available of ubuntu's mpeg4ip appears to be 1.6, the "official" version is much older and apparently dormant.

There appears to be a dev version of libmp4v2 in the works, but no usable version.

I have a workaround, but obviously no help to anyone else.

Peter Harvey (pdqharvey) said : #11

I tried and failed, too. At least we know roughly where we stand - that it's not some error we should be trying to trace in our particular installations.

I too, have a workaround, but it involves Windows 7 and a painfully long wait when starting GTKPod on each occasion following a brush with iTunes... Ugh.

Launchpad Janitor (janitor) said : #12

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

cometdog (ericctharley) said : #13

I have exactly the same issue... No solution so far? It seems like it should be kind of a big deal that there is absolutely no way to add video to an ipod in Oneiric.

Peter Harvey (pdqharvey) said : #14

No solution that I have come across, no. Just another possible problem:

I've never before tried to add AAC audio files to an iPod, but it is said to be possible, so it should be. But I cannot make it work. I suspect it might be related to the mp4 problem, as some of the dependencies seem to overlap.

Not a huge issue - I can always convert to MP3 - but still...

I agree that in a non-life-threatening way, this (iPod management) is quite an important issue, since it is a major put-off for anyone looking at Ubuntu as a possible *replacement for* (rather than addition to) Windows. Ipods are NOT exactly rare!

cometdog (ericctharley) said : #15

Right -- it used to be working just fine in Maverick (I never ran Natty, so I don't know). I'm concerned that if this isn't prioritized it won't be fixed in time for Precise, and that means the next LTS will be hobbled forever for iPod users. Cannot transfer video to arguably the most popular series of personal media devices.

This issue should also not be a codec problem. It shouldn't matter whether I can play the video files on my computer (although I can). That should be independent of whether my computer can put them on an iPod, which it used to be able to do when running Lucid and Maverick.

Also still not able to work-around. I installed a version of libmp4v2 and all the other "dev" dependencies and was unable to build / make any gtkpod 2.1.0, either from the "release" tar.gz or from the git repository. Earlier versions of gtkpod failed because they seemed to want an ealier version of libanjuta, and the current version fails to build / make because of some bug in the code which is documented online but has no responses that I can see.

tqft (ianburrows-au) said : #16

I tried

Uninstalled gtkpod
downloaded mp4v2-trunk-r479/, libgpod-0.8.2 & gtkpod-2.1.1~a7d8db4 source
all compiled & installed fine with liberal doses of sudo ldconfig and restarts
set the environment variables in .bashrc
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
export LD_LIBRARY_PATH
export PKG_CONFIG_PATH

Slightly different error
http://imgur.com/xalj6
but still the same problem

Looks like it wants to work but doesn't

anyone know of any other similar bugs or questions?

Peter Harvey (pdqharvey) said : #17

Happy Christmas to all...

I came across a page listing the availability of libmp4v2, libmp4v2-2 and libmp4v2-dev in the various Ubuntu releases. Oneiric is simply not listed, though Precise is, so I would hope that the next release will have this fixed.

See: http://packages.ubuntu.com/search?keywords=libmp4v2

I'm going to give up on this one, unless someone comes up with a solution in the meantime. Thanks for all the comments and help.

Launchpad Janitor (janitor) said : #18

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Forage (forage) said : #19

I was fed up with this...

https://launchpad.net/~forage/+archive/gtkpod

Install the updated gtkpod with mp4 support enabled, as well as libmp4v2 (thanks to Jonas). Enable the mp4 plugin in gtkpod and off you go.

Enjoy.

Spam Jim (spamjim) said : #20

Thanks Forage!