Microphone does not work.

Asked by R00K

Hello everybody.
I have a problem: Microphone doesn't work (neither in Sound Recorder nor in Skype).
The microphone itself is OK (Works on neighbour's Windows machine).
Perhaps there is a problem with software.
I'm running Gutsy (October 16, i386, GNOME) on a machine with Realtec ALC883 sound chip (m/b ASUS P5K SE).

Already tried the following:
* Checked everything everywhere is unmuted, enabled and set on 100%.
* Googled a lot.
* Changed everything possible in System->Preferences->Sound.
* Checked everything in alsamixer (including those opening on F5 key).
* Googled again.
* Reinstalled in Synaptic every package found by searching "alsa".
* Tried plugging the Mic into Line In, then checking System->Preferences->Sound once again.

Nothing helped. Sometimes I heard some noise instead of my voice, but even this was unstable.

What would you advice me to do next?
I need this microphone badly :-(

Question information

English Edit question
Ubuntu gnome-media Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Olivier (olivier-lacroix) said :

Hi !

try to get the capture panel to show up in gnome volume manager (you will find this option in the preference) and switch on the "capture" part.

tell me if that helps

Revision history for this message
R00K (7er-mail) said :

I already enabled everything in Edit->Preferences.
I also already made sure that everything is enabled and unmuted in "Recording" tab. (have 3 channels there: "Capture", "Capture 1" and "Digital".
I even tried disabling some of those channels.
But still no effect.

Revision history for this message
Olivier (olivier-lacroix) said :


please go through the steps given at https://help.ubuntu.com/community/DebuggingSoundProblems and report the outputs here

Revision history for this message
Olivier (olivier-lacroix) said :

you may want to try to install a newer version of alsa before and see if it helps. Do as instructed there http://linuxtechie.wordpress.com/2007/10/19/getting-intel-ich8-family-rev-3-sound-card-to-work-in-gutsy/

Revision history for this message
R00K (7er-mail) said :

I've installed the newer version. 2 new channels appeared: "Mic Boost" and "Front Mic Boost". By manipulating these I can now hear some noices in the headphones. Those noices are synchronous with what I say. I mean, when I say "test message" it sounds like "pfff pfffpff". However, still nothing can be recorded.

What about reporting:

Revision history for this message
R00K (7er-mail) said :

Oh, I forgot to change Input source back to Mic (tried to set "Front Mic" instead).
With Mic input, I am able to record not only noices, but also a faint shade of my voice behind them. If Boosts are muted, it's only recorded in right side. If Boost are set on maximum, it's in both sides. Anyway, the voice is blurred by noices badly and almost undistinguishable.

Hearing my own voice is a great progress, but of cource I still need to get rid of those noices, so the problem remains.

Revision history for this message
R00K (7er-mail) said :
Revision history for this message
R00K (7er-mail) said :

Just now checked it with Skype. Strangely, works just fine, only a bit quiet. ("Allow Skype automatically adjust my mixer levels" checkbox is checked, Sound devices are set to default.)
But Sound Recorder continues to record noisy mess. Also Skype echoes the same noisy mess when I uncheck above-mentioned checkbox. Obviously, there is something wrong with my mixer levels, but I didn't manage to adjust them to make it work fine (just reducing volume doesn't help). So the problem remains to make other applications (like sound recorder) record clean sound and to make skype record with a normal volume.

Revision history for this message
R00K (7er-mail) said :

Upon the next boot nothing works again, and no manipulations can make it work. It seemed to me that the thing was almost fixed but now i don't know what does it depend on. Just now the microphone doesn't react on anything. Just pure silence. I am resubmitting that auto-collected stuff again, maybe something changed. http://pastebin.ca/780889

Revision history for this message
Olivier (olivier-lacroix) said :

From the script result, the card seems to be well recognized

I think it is a mixer problem

have a look at

and as you have 2 microphone inputs, be sure to select the right one

Revision history for this message
R00K (7er-mail) said :

Finally, I made it work stable.

That's how it looks:
Upon each reboot the microphone doesn't work at all.
The script says: http://pastebin.ca/784475

Then I open "Volume Control", enter "Options" tab and change both input sources from "Mic" to "Front Mic". After that I close "Volume Control".
Guess what's next?
Then I open "Volume Control", enter "Options" tab and change both input sources from "Front Mic" to "Mic". After that I close "Volume Control".
Mysteriously, microphone begins to work just fine.
The script says: http://pastebin.ca/784480

Well, I am really happy about it, and spending 10 seconds on this simple operation after each boot is not a problem for me at all. So the problem is solved.
Huge thanks for your help, Olivier!

Revision history for this message
Michael Losonsky (michl) said :

I was looking for a solution to a similar problem I
have with a USB mic Hardy Beta. This kludge
doesn't work for me, but my main point here is
that this is not really a solution. Having the mic
killed every time you reboot and opening and
closing the volume control a couple of times is
like fixing a car by kicking it.