Ubuntu

sonido no funciona

Asked by Sovietzug on 2007-08-14

 en un portatil toshiba sattelite A105-S2236 he instalado en UBUNTU 7.04 de Linux y no consigo que funciones el sonido. De hecho no detecta ningun problema y puedo acceder al control de volumen pero no se oye nada.

 Los dispositivos que me da a elegir UBUNTU son el HDA ATI SB (Alsa mixer) y el Generic 11c1 Si3054 (OSS Mixer) pero con ninguno de los dos reproduzco ningun sonido.

 Donde puedo descargar los drivers adecuados ??

 gracias de antemano por su atencion

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu gnome-media Edit question
Assignee:
No assignee Edit question
Solved by:
Javier Jardón
Solved:
2007-09-01
Last query:
2007-09-01
Last reply:
2007-09-01

This question was reopened

Javier Jardón (jjardon) said : #1

Hola!

Para la proxima versión de Ubuntu este problema ya esta solucionado, para Feisty (7.04) haz lo siguiente:

Añade la siguiente linea al final del fichero /etc/modprobe.d/alsa-base:
options snd-hda-intel probe_mask=8 model=3stack

Reinicia y comprueba que funciona. Espero que te sirva.

Saludos

Sovietzug (sovietzug) said : #2

Lo he hecho pero no me funciona.

El Ubuntu ejecuta el sonido y las animaciones de plugin se reproducen correctamente pero el sonido no llega ni a los auriculares ni a los altavoces del portatil (laptop). Por supuesto el mute esta quitado en todas las opciones: tanto el control de volumen como en las funciones del portatil.

 Ahora los 2 dispositivos de sonido que me aparecen en el mezclador de sonido son:

Realtek ALC861-VD (OSS Mixer)
y
HDA ATI SB (Alsa Mixer)

el modelo del portatil es Toshiba Sattelite A105-s2236 con ATI incorporada

A mi cliente le esta gustando mucho las opciones de programas educativos que se pueden instalar con el ubuntu pero es un problema que no pueda escuchar musica ni oir videos :(

Es el primer linux que instalo y pues voy aprendiendo a usarlo. Cuando me recomendaste incluir la linea de codigo tuve que averiguar como. Porque tuve q activar la posibilidad de entrar como admin root y poder modificar el archivo alsa-base. Como quiera logre incluir esa ultima linea :D

gracias por toda la atencion y pues sigo esperando soluciones jeje

saludos

Javier Jardón (jjardon) said : #3

Hola!

Bueno a ver si lo solucionamos ahora ;-)

Pon esto en el fichero /etc/modprobe.d/alsa-base:
options snd-hda-intel probe_mask=8 model=auto

Reinicia y a ver si asi funciona. Para editar el fichero como root solo tienes que poner en consola
>sudo gedit <fichero>
Te pedira tu clave y listo. Ubuntu no trae la cuenta de roor activada por defecto (y ni falta que hace ;-))

Saludos y espero que se solucione!

Sovietzug (sovietzug) said : #4

sigo sin oir nada :(

como soy novato en linux creo que mejor te copio lo que encuentro en la seccion de sonido del archivo alsa:

# Load snd-seq for devices that don't have hardware midi;
# Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
# non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
 options snd-cmipci mpu_port=0x330 fm_port=0x388
# options snd-hda-intel probe_mask=8 model=3stack
options snd-hda-intel probe_mask=8 model=auto

espero que asi se vea mas claro porque yo no lo se jeje

gracias de antemano por las molestias, en cierto modo estoy contento porque porfin le estoy metiendo mano al ubuntu :D

Javier Jardón (jjardon) said : #5

He estado leyendo por ahi y parece que es necesario que tengas la ultima version de los drivers de audio (alsa). Estos ya vienen incluidos en la proxima version de Ubuntu (Gutsy) que saldra en octubre. Te puedes bajar la version que ahora esta en pruebas y ver si te funciona el sonnido (no hace falta que la instales): Mira las novedades en https://wiki.ubuntu.com/GutsyGibbon/Tribe5/ y bajatela en http://cdimage.ubuntu.com/releases/gutsy/tribe-5/

Sovietzug (sovietzug) said : #6

OK

solo q tardare un poco en probarlo por las descargas.

 Una cosa antes de dar esto por solucionado.

 que instalacion pruebo ???

PC (Intel x86) desktop CD

PC (Intel x86) server install CD

o

PC (Intel x86) alternate install CD

para probar y para definitivamente instalar ??!!

Javier Jardón (jjardon) said : #7

Hola,

seguramente la que debes escoger es el desktop CD. El server install es para montar servidores (no instala nada de entorno grafico) y el alternate es para instalaciones "alternativas", esto es, equipos con poca RAM que no soporten la instalación grafica, para OEM's, etc...

Saludos!

Sovietzug (sovietzug) said : #8

Thanks Javier Jardón, that solved my question.

Sovietzug (sovietzug) said : #9

 Buenooo, ahora sí que me he complicado :D

 Instalé la actualización al Gutsy de ubuntu y ahora no me funciona el entorno gráfico y no sé solucionarlo desde la consola que aparece de inicio :(

 Ahora sí que me quedé atascado :)

Sovietzug (sovietzug) said : #10

Fatal Server Error: No Screens Found

Best Javier Jardón (jjardon) said : #11

Hola Sovietzug,

te aconsejo que cierres esta pregunta y abras otra nueva con tu nuevo problema, ya que no tiene mucho que ver con el sonido ;-)

Saludos!

Sovietzug (sovietzug) said : #12

Thanks Javier Jardón, that solved my question.