How can I change "unlock keyring" pass word?

Asked by George A on 2010-01-30

Good day. I an new to Ubuntu and run 9.04. I set up a secure wireless connection to the internet a few weeks ago, and entered the required password for "unlock keyring", which was the same as my logon PW. My wireless hub has a separate hex PW. Everytime I logon to my pc I'm prompted for the "key ring" PW to enable my wireless connection - I find this quite bothersome.

Recently I changed my logon password, however, the keyring application does not accept my new password. I've tried deleting and reinstalling the wireless network using my new password, however, I get dialog box from "unlock keyring" :

The application "nm-connection-editor" (/usr/bin/nm-connections-editor) wants access to the default keyring, but it is locked. It prompts for a password, and it will not accept my new password, however, my old password is accepted and the wireless connection to my internet hub is completed.

I would be obliged for any help in getting the keyring application to accept my new PW. Many thanks,

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-keyring Edit question
Assignee:
No assignee Edit question
Solved by:
Larry Jordan
Solved:
2010-02-02
Last query:
2010-02-02
Last reply:
2010-01-31
Best Larry Jordan (larryjor) said : #1

     I hate this myself. Even if I have passwords "remembered" by the system for email accounts, the GNOME keyring asks for a password to unlock the keyring to the saved passwords. Best response I have seen on this, though I haven't tried it myself, is at:
http://ubuntu-tutorials.com/2007/07/12/automatically-unlocking-the-default-gnome-keyring-pam-keyring/ (an external help area). This seems to be an old link, but I've checked and found that the necessary packages to enable it are installed in 9.10 - they just don't seem to set it up as a default.
     Hope the instructions there can help you out.

George A (gka1999) said : #2

Larry:
Thank you very much for your input and the link you've kindly provided. I'll follow the link and see if I'm able to glean (based on my non-existent knowledge of Linux and Ubuntu) any useful info relative to my inquiry. After glancing through some of the material in the Encryption & Keyring Manual (9.04), and several hours after posting my question to launchpad, I became impatient and found a go-around for my keyring problem.

I went in via Applications --> Accessories → Passwords and Encryption Key → Password Tab, and deleted the bothersome files (I had to enter pw several time to authorize deletions) and subsequently I had to respond to the dialog box associated with accessing my secure wifi hub. Now whenever I boot-up “seahorse 2.26.1” no longer holds me at bay for a pw. I made the problem go away – I was unable to solve it!
Again, many thanks for your input.

George A

George A (gka1999) said : #3

Thanks Larry Jordan, that solved my question.

I am running ubuntu 10.04 on an Acer Laptop and I was being asked to enter password for "default keyring" to connect wirelessly.I got fed up with this and found that by right click on internet icon in toolbar.then "edit connection". Network connections window comes up click on "Wireless".click on router you want to use then click "edit". input user password. Editing window appears, click "connect automatically" then click on "available to all users" click "apply"
log out. when you log back in you should go straight to internet without any input. This works ok for me.
                                                                                                                                                                         J.J