Help can not be shown in gnome-games anymore

Asked by BryanFRitt on 2009-08-10

When I try to view the a gnome-games help menu, it doesn't work, anymore.
For Aisleriot I get this message:
Could not show Aisleriot help
There was an error launching the default action command associated with this location.
How can I get the help back for gnome-games?

p.s. I'm on KUbuntu 8.04.3 64bit

Question information

English Edit question
Ubuntu gnome-games Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Tom (tom6) said : #1

In Synaptic Package Manager try "Fix broken packages" from the "Edit" menu and then "Apply", good luck with this!

System - Administration - Synaptic Package Manager

Regards from
Tom :)

BryanFRitt (bryanfritt) said : #2

I tried 'Fix Broken Packages' from 'Synaptic Package Manager', nothing changed. The help still doesn't show up for any of the gnome-games. (that I tested)

When I goto the help menu in gnome-sudoku, the konsole window will display
Unable to display help: There was an error launching the default action command associated with this location.

Tom (tom6) said : #3


I think you only have to test one game to see that it's not working properly. Do you get normal help on your desktop? On a blank area of your desktop press F1. Also try the blue question mark on the top taskbar. Are either of these working and allow you to navigate through tpo help about games? Could you try launching the games from a command-line and give us the output, if any, when you try to select Help from the games menu
Usually that's just type the name of the game in to start it from there.

Also on the command-line you can sometimes get help by typing

man gamename

which should give the text-manual. Another thing that might help is typing " -h" after the gamename, eg

rollerball -h

Good luck with trying these!
Regards from
Tom :)

BryanFRitt (bryanfritt) said : #4

Maybe it's a whole gnome thing not just a gnome-games issue, so this bug might be better put someplace else instead of gnome-games. Knowing this is still progress. Anyway help seams to still work for my KDE apps, but not my gnome apps. Any ideas on what to do next?

I tried to get help for nautilus and it gave an error.
There was an error displaying help:
Help document user-guide/user-guide.xml not found
I tried help with "sudo gparted" and got
Sorry, not yet implemented.
Please visit for more information and support.
So maybe that wasn't a good one to test, so

I also tried it with Rhythmbox 0.11.5
Couldn't display help
There was an error launching the default action command associated with this location.

However, quicklist stills gives a 'help'

'sound-juicer' gives
Could not display help for Sound Juicer
There was an error launching the default action command associated with this location.

Totem could not display the help contents.
There was an error launching the default action command associated with this location.
rollerball -h
bash: rollerball: command not found
p.s. I'm on KUbuntu 8.04.3 64bit using KDE 3.5.10

BryanFRitt (bryanfritt) said : #5

I installed 'gnome-user-guide' using Adept Manager as suggested by
and that solved it!
Thanks for the idea to test help in other applications...

Selecting previously deselected package gnome-doc-utils.
(Reading database ... 247195 files and directories currently installed.)
Unpacking gnome-doc-utils (from .../gnome-doc-utils_0.12.2-1ubuntu1_all.deb) ...
Selecting previously deselected package librarian0.
Unpacking librarian0 (from .../librarian0_0.8.0-0ubuntu1_amd64.deb) ...
Selecting previously deselected package yelp.
Unpacking yelp (from .../yelp_2.22.1-0ubuntu2.8.04.3_amd64.deb) ...
Selecting previously deselected package gnome-user-guide.
Unpacking gnome-user-guide (from .../gnome-user-guide_2.22.0+svn20080407ubuntu1_all.deb) ...
Setting up gnome-doc-utils (0.12.2-1ubuntu1) ...

Setting up librarian0 (0.8.0-0ubuntu1) ...

Setting up yelp (2.22.1-0ubuntu2.8.04.3) ...

Setting up gnome-user-guide (2.22.0+svn20080407ubuntu1) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
dpkg run finished!

BryanFRitt (bryanfritt) said : #6

It could have been installing some of or one of the packages that got installed along with 'gnome-user-guide' that actually fixed the error, I don't know, and didn't test that, but it works now...

The command line would be something like this
sudo apt-get install 'gnome-user-guide' 'yelp' 'librarian0' 'gnome-doc-utils'

Tom (tom6) said : #7

I think the apt-get install list doesn't need the ' marks. So for people that like to copy&paste dodgy commands from the internet without checking up on what they do

sudo apt-get install gnome-user-guide yelp librarian0 gnome-doc-utils

I got the game name wrong but it sounds like you've never tried "neverball" which is shocking. I think its got to be worth installing if you like highly addictive games

Congrats at fixing this and thanks for giving us the link to the answer :)
Welcome to Linux-land, especially the Ubuntu corner of it
Regards from
Tom :)

BryanFRitt (bryanfritt) said : #8

It'll work with or without the ' ' and if you pick just the gnome-user-guide one, apt-get will add the other ones so they're not needed too, but if someone wants to figure out the minimum to install to fix the problem, having the extra packages listed can be helpful, so they don't have to figure that part out for themselfs.

I've never played the exact game 'neverball' until just a few minutes ago(unless I forgot doing so), but my aunt gave me real rollerball game (or what ever they're called) as a present, it had a metal marble, a maze, and holes would fall down if the marble went the wrong way. I think it had to rotating knobs that would control the angle of the maze, but I forgot how the knobs physically got the maze to tilt. I also used to use Legos to make mazes for the ball to go through. Lots of fun. Thanks for the tip.

Tom (tom6) said : #9

Thanks :) Wow, a real game in physical reality! I hardly ever go there these days tho lol ;) Lego was great 'back in the day'. Neverball started easy but got really difficult quite fast. I think i got stuck on level 3! Perhaps it's possible to create your own levels in there? I would be surprised if there wasn't a website for the game that would welcome any help like that :)

Good luck and regards from
Tom :)