Ubuntu

error updating gnomes-game-data

Asked by David Garcia Rojo on 2008-09-25

Binary package hint: gnome-games-data

in 8.10

after an update I have that:

Usage: gconf-schemas --[un]register file1.schemas [file2.schemas [...]]

gconf-schemas: error: You need at least a file to (un)register.
dpkg : erreur de traitement de gnome-games-data (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 2
dpkg : des problèmes de dépendances empêchent la configuration de gnome-games :
 gnome-games dépend de gnome-games-data (>= 1:2.24) ; cependant :
 Le paquet gnome-games-data n'est pas encore configuré.
 gnome-games dépend de gnome-games-data (<< 1:2.25) ; cependant :
 Le paquet gnome-games-data n'est pas encore configuré.
dpkg : erreur de traitement de gnome-games (--configure) :
 problèmes de dépendances - laissé non configuré
No apport report written because the error message indicates its a followup error from a previous failure.
                          Des erreurs ont été rencontrées pendant l'exécution :
 gnome-games-data
 gnome-games
E: Sub-process /usr/bin/dpkg returned an error code (1)

since that, every update reproduce this error.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-games Edit question
Assignee:
No assignee Edit question
Last query:
2008-09-25
Last reply:
2008-09-29

This question was originally filed as bug #274565.

Greg Unger (mr-ory) said : #1

i have the same problem installing gnome-games. i eventually purged gnome-games and gnome-games-data from my computer. now, attempting to install the package with aptitude produces a similar error. here is aptitude's output:

The following NEW packages will be installed:
  gnome-games gnome-games-data{a}
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/14.7MB of archives. After unpacking 45.2MB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 129814 files and directories currently installed.)
Unpacking gnome-games-data (from .../gnome-games-data_1%3a2.24.0-0ubuntu1_all.deb) ...
dpkg-deb: subprocess paste killed by signal (Broken pipe)
dpkg: error processing /var/cache/apt/archives/gnome-games-data_1%3a2.24.0-0ubuntu1_all.deb (--unpack):
 short read in buffer_copy (backend dpkg-deb during `./usr/share/gnome/help/iagno/pt_BR/figures/START.png')
Selecting previously deselected package gnome-games.
Unpacking gnome-games (from .../gnome-games_1%3a2.24.0-0ubuntu1_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for menu ...
Errors were encountered while processing:
 /var/cache/apt/archives/gnome-games-data_1%3a2.24.0-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of gnome-games:
 gnome-games depends on gnome-games-data (>= 1:2.24); however:
  Package gnome-games-data is not installed.
 gnome-games depends on gnome-games-data (<< 1:2.25); however:
  Package gnome-games-data is not installed.
dpkg: error processing gnome-games (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-games

Michael Vogt (mvo) said : #2

@Greg: The error message indicates that you might have a filesystem error on your computer. Could you please run a filesystem check (availabe in the ubuntu rescue mode) and a momory check (availabe start startup with the ESC key) and check if those report no error?

Sebastien Bacher (seb128) said : #3

the error seems to indicate a local installation issue or local changes, that's not a package bug, changing to an user question

Greg Unger (mr-ory) said : #4

@Micheal: Memtest passed with no errors. I also ran fsck, which didn't report an error on my root partition. however, it gave me a warning about checking mounted filesystems when it tried to check my /home partition. A filesystem error would make sense, though. On an earlier boot of Intrepid, the automatic filesystem check ran and corrected some errors on the root partition. I have had numerous problems with filesystem errors and random system crashes in recent weeks. I suspect my hard drive is beginning to fail.

While the original problem regarding gnome-games isn't solved, at least my suspicions about the filesystem and my hardware has been confirmed.

Can you help with this problem?

Provide an answer of your own, or ask David Garcia Rojo for more information if necessary.

To post a message you must log in.