Quadrapassel flashes on and off when used...

Asked by Ruy Valle on 2010-07-13


The game called which is now called Quadrapassel (a.k.a Gnometris in the past) works very strangely on my computer. When I open it, there is nothing but grey until I click new. When I click new (game), the background appears for about 1 second and I see the shape which is falling, but the screen turns grey again. This happens throughout the games: every time a new shape appears, the background and shape are visible, but they get covered by gray again everytime, and when I move the mouse around, everything stays gray no matter what. I do not know if this is due to my computer or some sort of setting, but I think it is. My brother has the game too on his computer, but his works and mine doesn't. We both have Ubuntu 10.4 Lucid Lynx; the only difference is that my brother has the 32-bit version and I have the 64-bit. I know a bit of programming, but I do not consider myself a too experienced or talented one. However, if there is a solution to my problem that involves a bit of programming or modifying scripts or something like that, I should be able to do it as long as there are relatively clear explanations.

I know this isn't a too important problem, and I am disposed to wait for quite some time before getting some answers, but I would enjoy being able to play Tetris without going to an online site on my computer.

Thank you very much for your time and help.

Question information

English Edit question
Ubuntu gnome-games Edit question
No assignee Edit question
Solved by:
Ruy Valle
Last query:
Last reply:

launch the app from terminal. When it crashes, paste the output here.

Ruy Valle (ruyvalle) said : #2

Actually, the game doesn't crash, it's just that you can't see the screen half or even more of the time, so it's annoying. Anyway, I ran Quadrapassel in terminal like you asked and I had the following output:
ruy@ruy-laptop:~$ quadrapassel

(quadrapassel:1748): ClutterGLX-CRITICAL **: Unable to make the stage window 0x4200006 the current GLX drawable

(quadrapassel:1748): ClutterGLX-CRITICAL **: Unable to make the stage window 0x4200007 the current GLX drawable

Thanks again for your help.

I'd log a bug by running:

ubuntu-bug quadrapassel

Paste the output you gave above as extra info too.

Ruy Valle (ruyvalle) said : #4

Good news! I installed Gnome-shell just for the sake of it (and I tried it of course). There was too much lag too my liking so I went back to normal Gnome. That was yesterday. Today, I decided to give Quadrapassel a try again and *pouf* it works! I have no clue as to why it works now, for I don't really recall changing anything... The only thing I did that differs somewhat from the usual is what I said above: I installed and tried out Gnome-shell. Hopefully this might give some clue to programmers about why this bug arose. I won't put this bug as solved just yet. I'll just wait a bit to see if the problem comes back or not. Hopefully though it won't.

Cool, you got the gold. Please mark as solved.

Ruy Valle (ruyvalle) said : #6

Fine then. I'd just like to give a hypothesis: I just remembered that in the steps required to install Gnome-shell it was necessary to disable special effects (System-->Preferences-->Appearance-->Visual Effects) before installing it. I think that it's probably related somehow to Quadrapassel. Anyway, yeah problem solved!