Hdd format/Partition Input/Output Error

Asked by Phil Byer

Hi I am trying to upgrade my laptop HDD 120GB to a 500GB
Gparted does not show drive, my system bios does not show drive
Fdisk in terminal and disk utility say 'Input/Output Error'

Currently have it hooked up as a external usb drive with adapter from 2TB drive. Would that be the reason for input/output error?
bootable usb not working, shows boot error. so i'm a little stumped on what to do here.

I am looking just to get the drive formatted.

Question information

English Edit question
Ubuntu gnome-disk-utility Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

Sometimes the usb-cases are not working well. This might be the situation here.

Have you tried to plug in the drive directly to the laptop ? Can you do that? Is the drive compatible with Laptop motherboard ?

If the BIOS does not recognize the drive, then is not an Operating System (Ubuntu) specific problem.


Revision history for this message
Phil Byer (byer-phil-x) said :

drive is compatible with motherboard.
Possibly if i can get into recovery off boot disk if i can get that working. i could reformat that way.
What would you recommend for a burn program iso to disk or usb?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Do you have the latest BIOS?
Have you tried setting it to IDE compatibility mode in BIOS?

I had this and I replaced the drive and all was well.

Can you help with this problem?

Provide an answer of your own, or ask Phil Byer for more information if necessary.

To post a message you must log in.