Disk Utility Won't Change Partition Type

Asked by Joe DiGiovanni

I have a Seagate FreeAgent external drive (320 GB), with one ext4 partition for Ubuntu backup purposes, and a 43 GB partition that I'm trying to set up as a NTFS partition for Windows XP backup purposes (my machine is dual boot). When I create the 43 GB partition in Disk Utility, it sets the type to "Linux Basic Data Partition". I edit the partition to change the type to Microsoft Basic Data Partition" but the change doesn't take.

If I boot into Windows XP, I cannot see the 43 GB partition at all.

I've also tried just leaving the 43 Gb unallocated, but Windows still won't see it.

Please advise!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-disk-utility Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Why not use the XP disk manager and setup the partition there?

Revision history for this message
Joe DiGiovanni (mrcpuhead) said :
#2

Already tried - as I mentioned. XP doesn't see the 43 GB partition at all. XP Disk Management tool only shows the ext4 partition (as GPT) and makes it appear as though there is no available disk space left on the Seagate FreeAgent disk.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Delete the partition and leave free space, then in WIndows create the new partition

Revision history for this message
Joe DiGiovanni (mrcpuhead) said :
#4

Tried that option also - same result. I've decided to rsync everything off the FreeAgent drive to my primary internal drive, so I can start fresh and format the FreeAgent drive completely as NTFS, since Ubuntu can certainly use that filesystem.

I will first try formatting just part of the drive NTFS, then the rest as ext4, to see if both OS can work with the corresponding partitions. I'd rather do this to allow backups from each OS to a partition that is native to the active OS.

Can you help with this problem?

Provide an answer of your own, or ask Joe DiGiovanni for more information if necessary.

To post a message you must log in.