palimpsest segfault

Asked by Mike Witt

Hi, I'm new to the Ubuntu bug tracking system and I don't know if (1) this is a bug or not and (2) whether it's already been reported. I've looked around and I was not able to find it here, but I may not know how to search correctly.

I have a 12.04 system running on my desktop on an internal SSD drive. I just added a 500 Gig hard drive to the system and used the Disk Utility to format it and create a single partition on it. This all appeared to have worked, as I can read and write files on the new partition.

However, I can't seem use the Disk Utility to test the disk. If I bring up the "SMART Data" panel and then click on either "Refresh" or "Run Self-Test" then the Disk Utility dies and in the log I see something like:

Jun 19 16:47:24 vector kernel: [ 1579.461730] palimpsest[3917]: segfault at 0 ip b6e8123a sp bff22100 error 4 in[b6e68000+4a000]

Can anyone advise me on this?

Question information

English Edit question
Ubuntu gnome-disk-utility Edit question
No assignee Edit question
Solved by:
Mike Witt
Last query:
Last reply:
Revision history for this message
Sasa Paporovic (melchiaros) said :

Yes, a segfault is a bug and should be reported.

Normally apport should regognize it by itself and pop-up a reporting window for yoWhen this is not happening you can look in var/crash if there are any .crash files.

You can report them with right mouse -> open with -> report(first entry).

For reporting in common please read carefully:


When you have done a search and find nothing do not thing to much about duplicates.

There are bugsquads for doing the refinement state:


After reporting please link this question to the report.

Revision history for this message
Mike Witt (msg2mw) said :

I don't get any of the "GUI" stuff discussed in the links above. The Disk Utility just "goes away" and I get that one line in my syslog about the seqfault. I also, unfortunately, don't really have the time to spend learning about all this right now. I see that there are many bugs on palimpsest, so perhaps this has already been reported. I don't think I'm able to spend any more time on it, in any event.

Revision history for this message
Sam_ (and-sam) said :

Please have a look at /var/crash.
If it contains a crash file from palimpest, right click to open it with Apport and upload.

They've changed the GUI behaviour about bug uploads, so if above doesn't work, try this, open a terminal: ctrl+alt+t
ubuntu-bug gnome-disk-utility

This should open a GUI to upload.
Include a step by step description how the bug is reproducable.

Revision history for this message
Sam_ (and-sam) said :

Of course you can install smartmontools and test the drive via terminal. No GUI no hassle. ;-)

Revision history for this message
Mike Witt (msg2mw) said :

I did my best to create a bug report following Sam's directions above. I really need to close this question now as I'm not planning to use the configuration described any longer. I really can't afford to take the time away from work, and I need to set up something else that works. I appreciate the time people spent giving me advice, and I'm sorry that I don't have the time or know-how to pusrue this further.