Disk Utility reports Hard Drive File System NOT Clean

Asked by Usksider on 2011-11-18

Since upgrading to Ubuntu 11.10 I am no longer able to write to my Samsung 1TB USB drive. Disk Utility reports the file system is NOT clean, which is not particularly helpful since it doesn't suggest what can be done to change that state.

I've got the 32 bit version of Ubuntu installed and didn't have a problem reading/writing to the USB drive prior to upgrading to version 11.10.

fdisk -l provides the following information:

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0003fc5a

   Device Boot Start End Blocks Id System
/dev/sdb1 63 1125385379 562692658+ 7 HPFS/NTFS/exFAT
/dev/sdb2 1125385380 1953520064 414067342+ 7 HPFS/NTFS/exFAT

Can anyone please help?

Question information

English Edit question
Ubuntu gnome-disk-utility Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Usksider (john-usksider) said : #1

I think I may have found the answer to this...

NTFS-3G installed (NTFSPROGS removed) and immediately able to write to the USB drive, which I am currently using to back-up my system. If back-up completes as expected I'll close this query.

Usksider (john-usksider) said : #2

System back-up appears to have worked perfectly - I can read/write to my USB drive once more. :)