Ubuntu

Getting an error trying to format external harddrive

Asked by Jeff on 2011-07-22

I already posted my question here:
http://www.reddit.com/r/techsupport/comments/iwaio/formatting_external_hard_drive/
But I need as much help as I can get.

I am at the point where So I opened up the Disk Utility tool and saw the external drive was being read. I clicked on it and tried formatting it to GUID Partition Table like you said and I got an error reading:

**An error occurred while performing an operation on "320GB Hard Disk" (Ext Hard Disk): The daemon is being inhibited** Under details, "Daemon is inhibited"

I tried formatting to any other format and I get the same error.

Help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-disk-utility Edit question
Assignee:
No assignee Edit question
Solved by:
Jeff
Solved:
2011-08-04
Last query:
2011-08-04
Last reply:
2011-07-30

How does the drive connect? What methods of format have you tried?

Jeff (jeffreyabr) said : #2

The drive is connected to my USB port. I have tried the 4 different format methods that are available (sorry I can't be more specific - I'm at work and can't pull it up). I was told on Reddit that I should be trying a GUID Partition Table or something like that.

I tried all of them, but I still got the error:

An error occurred while performing an operation on "320GB Hard Disk" (Ext Hard Disk): The daemon is being inhibited** Under details, "Daemon is inhibited"

I am on a Windows 7 Ultimate 64bit Dell Vostro 1520

delance (olivier-delance) said : #3

Ultimate 64bit Dell Vostro 1520 uses an UEFI BIOS, so you could need a GUID/GPT partition

table.http://ubuntuforums.org/showthread.php?t=1604563&page=3
1-did you unmount disk before trying to update partition table ?
2-you could try gparted
    sudo apt-get install gparted
    System->Administration->Gparted partition editor (but close Disk Utility before)
3-try
    sudo killall udisks
to avoid disk to be mounted again

Jeff (jeffreyabr) said : #4

Someone on Reddit recommended "sudo killall udisks." I will try this when I get home from work.

The biggest issue was that the harddrive wasn't showing up on any lists (I know a regular drive should pop up on the desktop when plugged in or in the Places menu).

delance (olivier-delance) said : #5

"The drive is connected to my USB port."
Please connect the disk, open a terminal (Ctrl+Alt+T), run command:
   sudo lsusb
and report result.

delance (olivier-delance) said : #6

How to provide partition table https://answers.launchpad.net/grub/+faq/1678
N.B.: I will stop for today.

Jeff (jeffreyabr) said : #7

I entered the command and it allowed me to begin formatting the drive. After about a minute, the format failed and I got this message. http://i.imgur.com/U04j2.png

What now?

Jeff (jeffreyabr) said : #8

I entered "sudo killall udisks"

delance (olivier-delance) said : #9

Could be an hardware issue, USB or hard disk.
Could you redo on plugging device on another USB PC plug.
Could you try to make a DOS partition table, to guess if issue is related to hardware or GUID partition table.

Jeff (jeffreyabr) said : #10

I got a suggestion from someone on Reddit that I try a partition recovery program. I am running Easeus Data Recovery Wizard Pro and it found a file after running all night. I restored it (to a folder on my C drive since I couldn't see my external), but I have no idea what it is. It's a generic FILE001.file thing. No idea what to do with it.

Are there any diagnostics or software programs you can suggest?

delance (olivier-delance) said : #11

On Linux, you could try:
   od -c FILE001.file | head 20
and looks on first characters displayed. A lot of file format use a "magic" signature at start of file to check consistency between file extension and real contents. E.g. PNG files start with "PNG" as three first letters.
Please post result, and I will look if I can guess.

delance (olivier-delance) said : #12

sorry,
od -c FILE001.file | head -20

Jeff (jeffreyabr) said : #13

Is there any way to do this from Windows 7? I copied the file to my desktop in Ubuntu and it ran saying there is no such file. Either I have it in the wrong place or it's just going to be easier doing it from Windows...

I opened the file in Notepad on Windows and I saw lines of text referring to those setup programs you get on an external hdd that help you format and partition it.

Other than that, I don't know...

delance (olivier-delance) said : #14

There are free hexadecimal editors available in Windows.

Jeff (jeffreyabr) said : #15

Can you name one?

I will try it when I get home tonight.

Will it be able to read my drive even if it doesn't come up in a place like My Computer?

Jeff (jeffreyabr) said : #17

Not sure how to export the file for you other than this, but here is a screenshot of what I see. I know it isn't everything in the whole file.

http://i.imgur.com/9t4mw.jpg

Is this enough?

Jeff (jeffreyabr) said : #18

http://hotfile.com/dl/125156885/114d69b/FILE001.GZ.html

I uploaded the zip of the file to HotFile in case one of you can extrapolate more from it than I can.

Jeff (jeffreyabr) said : #20

So what does this mean? What do I do?

delance (olivier-delance) said : #21

Get file on a Windows system, and try to open it with Autocad. You can also change file name extension to SLD, and see if one of your software can read it.

Jeff (jeffreyabr) said : #22

Tried changing the file to SLD - no go. It doesn't know how to run it.

AutoCAD is a design program isn't it? I don't even have that.

delance (olivier-delance) said : #23

Autocad is a 3D mechanical/architectural software. Perhaps you have a software who uses same format. I don't have time to have a look now, but I believe it was about house.

Jeff (jeffreyabr) said : #24

I'm done with this. I am just going to have to return it. At this point, I've managed without it, so it's moot.

Thanks to everyone who put tips in. I really appreciate your time. I love knowing I can always find support through your random acts of kindness.