changing Edit Partition/type made external disk unreadable

Asked by Francois Laferriere

Binary package hint: gnome-disk-utility

I had an USB had disk that was formated in FAT32.
I tried to changed it to NTFS unsing Edit Partition -> type -> HPFS/NTFS
Afterward, the disk type is no more recognisable by any tool palimpsest, gparted etc, nor any OSes I have at hand MacOsX, LINUX, Windows 7
How can I reset partition type without erasing my datas

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-disk-utility 2.32.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sun Jun 5 12:29:23 2011
ExecutablePath: /usr/bin/palimpsest
 PATH=(custom, no user)
SourcePackage: gnome-disk-utility
UpgradeStatus: Upgraded to natty on 2011-05-05 (30 days ago)
XsessionErrors: (nautilus:2106): GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion `format != NULL' failed

Question information

English Edit question
Ubuntu gnome-disk-utility Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Marcel Stimberg (marcelstimberg) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at if you are uncertain if they are bugs. For help on reporting bugs, see There is also a vibrant support community available at and you might consider asking your question there.

Revision history for this message
Best delance (olivier-delance) said :

Les données ont déjà été détruites lors du formatage en NTFS. Basculer de FAT32 en NTFS n'est pas simplement un changement de flag, mais la redéfinition de la manière d'accéder et de stocker les données.
Si la table des partitions du support est corrompue, le plus simple est de la recréer avec Gparted.

Revision history for this message
Francois Laferriere (francoislaferriere2) said :


En fait, les données n'ont pas été détruite, mais justement, je soupconne que disk-utility a juste changé le flag, rendant la partition incohérente.

Finalement, j'ai récupéré l'ensemble de mes données avec testdisk en mettant type à "none" (même si c'est déconseillé). Ensuite, j'ai reformaté la partition et remis mes données récupérée dessus.