Some Gnome apps get "KDEzed" after installing KDE

Asked by enemotrop on 2012-10-22


I use Ubuntu 12.04 with Unity as my default and original desktop environment, and I have added the KDE desktop environment to the system recently. Since that, some apps (Firefox, Chromium, Thunderbird, LibreOffice, as far as I've noticed) have changed their internal decoration (controls, colours, even sometimes the mouse cursors), different to the rest of GTK apps originally included or installed into the Unity desktop environment. It's like if this apps has been 'forced' to use qt instead of gtk to decorate them.

I can assume that this behaviour can or must be normal in KDE native apps (Amarok, Konqueror...), even ran at Unity desktop environment (for instance, if I select the Oxygen theme in KDE, these apps are shown with the same effects under Unity), but, what about that independent apps that were originally installed into the Unity environment? Is there a way to force them to be drawn as the rest of the apps, whith the gtk decoration engine?

I realized that not only some apps are using the KDE decoration, but most of the Unity environment is 'contaminated'.

If I open gcalctool, for instance, and do a right-click over its main textbox control (that which displays the results), the pop-up menu is drawed with the Unity theme:

But, if I do a right-click over the window titlebar, the pop-up is shown in the KDE selected theme (in this case, Ozone):

I don't want to use the same themes in KDE and in Unity/Gnome... it's supposed to be easy to get uniformity in each desktop environment.

What can I do?

Thanks in advance

Question information

English Edit question
Ubuntu gnome-desktop Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

If you install ubuntu-tweak can you set stuff up there?

enemotrop (enemotrop) said : #2

I've tried with ubuntu-tweak, myunity, unsettings, gnome-tweak-tool... even with galternatives, with no results. I can change the cursors, the fonts, the theme, but there are plenty of KDE controls remaining unaltered into the forms (the scrollbars, the pop-up menus, buttons...)

enemotrop (enemotrop) said : #3

Besides, I tried using emerald as the window decorator. Nothing.

I also uninstalled all traces of KDE or kubuntu-desktop on the system, and the problem persists. In fact, now there is an additional issue with the battery icon of the Unity panel, wich is different to the original ubuntu mono dark icons theme.

I guess there must be some libraries 'stranded' that are interfering with gtk-window-decorator...

enemotrop (enemotrop) said : #4

UPDATE: the issue of the battery icon in the Unity panel fixed itself... after two reboots.

The problem with the windows decoration persists.

enemotrop (enemotrop) said : #5

UPDATE: the problem with the windows decoration is PARTIALLY solved. I've:

renamed ~/.config/gtk-3.0/settings.ini
renamed ~/.config/Trolltech.conf
deleted all subfolders under ~/.config/ relative to KDE or the Oxygen theme.
uninstalled al gtk-oxygen* packages present on the system (I thought they were already gone).

At this moment, al Mozilla apps and the LibreOffice suite have return to its normal appearance and the contextual menus of all apps have been restored to the nice and default Ambiance Unity theme.

The only remaining issue I've noticed at this point is the scrollbar in every apps (even the distro's natives like gnome-terminal or nautilus). It's not the typical minimalistic orange scroll bar of Unity, buf a conventional (although stylish) scrollbar. I'll keep trying to solve this, but any further help is welcomed, of course.


enemotrop (enemotrop) said : #6

At this moment, I've got the overlay scrollbars running in a few apps. The major part of the system is using the old fashioned scrollbars, although I've tried with several possible solutions to restore the overlay -Ayatana- scrollbars.

In any case, I think that the main question of the topic has been solved, and mark this thread like that. I'll open another one more specific with the scrollbars issue.

Thank you!

Leonardo Corato (leocor) said : #7

Same problem here with Raring