How to detect System Tray ?

Asked by Navin Talati on 2012-10-21

As mentioned in the Question #211792, I could recover the loading of ubuntu session. It was according the the link:
http://riveridea.wordpress.com/2012/03/22/how-to-solve-failed-to-load-session-ubunt
Now my desk top appears as it was before upgrading Ubuntu 12.04 to 12.10. The difference is that, its icon-bar (at the top of desktop) and launcher scrolling bar (at the left side orf the desktop) are not loaqding/appearing. These are lost. I am unable to assess files/folders/partitions/applications/tools etc from the desktop directly. Also unable to open/launch Terminal through even CTRL+ALT+T. I also updated and upgraded the system through tty (virtual console). Despite all these efforts, the warning appears as "No system tray detected on this system. Unable to start, exiting [OK]"
Please, guide me How to get this back ?
Navin Talati / 21-10-2012

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-desktop Edit question
Assignee:
No assignee Edit question
Solved by:
Navin Talati
Solved:
2012-11-04
Last query:
2012-11-04
Last reply:
2012-10-31
samuel (samuel-h) said : #1

Can you post the ouput of running this in a ctrl+alt+f1 terminal: dpkg -l hplip, this issue can be caused by the hplip package, and I need to know if it is installed

Navin Talati (n-m-talati) said : #2

ok. I am also getting notification on the screen that "Latest HPLIP-3.12.10a is available".
Now sir, let me bring into your kind information that the CTRL+ALT+F1 gives total screen but from this , through which command I can select, copy and paste the output or whole tty screen's data here? So that I can send you the output.
Please guide me.
Navin Talati / 22-10-2012

samuel (samuel-h) said : #3

If you are getting that message then that means that you have an old version installed, so I don't need the output from that command, unless you require the hlip package a lot I would recommend running sudo apt-get remove hlip from ctrl+alt+f1 to uninstall

Navin Talati (n-m-talati) said : #4

Sir, I need further guidance regarding:
(1). How to come back to the running session after completing the work in tty (which is resulted from CTRL+ALT+F1) ? I do not know the required command and so I implement "sudo reboot" and get my machine restarted and so on...
(2). I run "sudo apt-get remove hplip" from ctrl+alt+f1 , which uninstalled some (about 3 as I remember) packages. Rebooted the machine but despite that its icon-bar (at the top of desktop) and launcher scrolling bar (at the left side orf the desktop) are not loaqding/appearing. What to do ?
Thanks in anticipation.
Navin Talati /22-10-2012

samuel (samuel-h) said : #5

ctrl+alt+f7 will return you back to the gui session. Also are you still getting the error message, or is the gui just not loading now?

Navin Talati (n-m-talati) said : #6

ctrl+alt+f7 returns me to the page on which I was before running ctrl+alt+f1. It is o.k., I got the solution of my first question.

After booting, typical red/megenta coloured login screen appears. On this screen all standard icons at top right appears along with the Ubuntu version at bottom right and system name at top left. But after giving password, the screen opens only with saved data (file, folder, etc) on the desktop but its icon-bar (at the top of desktop) and launcher scrolling bar (at the left side orf the desktop) are not appearing. So it is difficult to launch any application. e.g. to run firefox, there is no icon available on the desktop so i open any file, goes to help and then online help. It starts the firefox and I do my work.

How to bring back ICONS BAR and LAUNCHER SCROLLING BAR on the desktop?
Navin Talati /22-10-2012

samuel (samuel-h) said : #7

Ah ok, I did understand what you were asking, I was just checking if you still got the "No system tray detected on this system. Unable to start, exiting [OK]" message. Try running this from tty1 however: unity --reset (make sure you are logged into the broken desktop session before however)

Navin Talati (n-m-talati) said : #8

Have I to run the command in tty1 as under:
however: unity --reset
I run it but could no solve the problem.
Pl, tell me the commans to Select, Copy and Paste the output on tty so that I can send you the output detail for your further analysis and checks to guide me ahead.
Navin Talati / 24-10-2012

Manfred Hampl (m-hampl) said : #9

You wrote in another question that the beginning of the proble was an interrupted upgrade from 12.04 to 12.10.

Just to make sure if your system now is thinking that it is 12.04 or 12.10, open a terminal or switch to a virtual console and enter the two commands

lsb_release -a
uname -a

As you cannot copy/paste from a virtual console, just note down the important information:
is the version 12.04 or 12.10
and the kernel version 3.2.0 or 3.5.0
?

Navin Talati (n-m-talati) said : #10

The system reads the version 12.10. It shows as under:
Welcome to Ubuntu 12.10 (GNU/Linux 3.2.0-32-generic-pae i686

Manfred Hampl (m-hampl) said : #11

The information that you gave shows that the update was interrupted, and that the system now is in a strange state:
The release information is "quantal", but the kernel in use is still the old "precise" version. I guess that also for some other packages there is still the old precise version active, which most probably is the cause for incompatibilities and problems.

I see two possibilities:
1. You restart from the beginning with a new installation of quantal. This will probably cause that you lose all your current data on the system.
2. You try doing all the steps that are missing to complete the upgrade to quantal (yet we have to find out what is missing, and how to best stimulate the upgrade to continue).

There is one piece of information that might provide an important indicator how far the upgrade process went and what the next steps might have to be:
Please issue the following command:

cat /etc/apt/sources.list

and look what release name is there.
You will see a lot of similar lines that might either be
deb <servername> precise <repository names>
or
deb <servername> quantal <repository names>

Please tell us what release name you see.

Furthermore please decide: whether you think that going back to a clean new-installation of your system is feasible, or if you want to do an attempt to continue the upgrade of your current installation (with all the potential problems that still may be ahead).

Navin Talati (n-m-talati) said : #12

Sir,
It seems me batter to accept your advice for installing the Fresh Quantal Quetzal (Ubuntu 12.10).
However, I am sending you the outpot of your suggested command "cat /etc/apt/sources.list " for your comments and suggestions along with the major points that what the output inferes and implies.

OUTPUT
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://in.archive.ubuntu.com/ubuntu/ quantal main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ quantal restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://in.archive.ubuntu.com/ubuntu/ quantal-updates main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://in.archive.ubuntu.com/ubuntu/ quantal universe
deb http://in.archive.ubuntu.com/ubuntu/ quantal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://in.archive.ubuntu.com/ubuntu/ quantal multiverse
deb http://in.archive.ubuntu.com/ubuntu/ quantal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://in.archive.ubuntu.com/ubuntu/ quantal-security main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-security restricted main multiverse universe #Added by software-properties
deb http://in.archive.ubuntu.com/ubuntu/ quantal-security universe
deb http://in.archive.ubuntu.com/ubuntu/ quantal-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu quantal partner
deb-src http://archive.canonical.com/ubuntu quantal partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu quantal main
deb http://archive.canonical.com/ quantal partner
deb-src http://archive.canonical.com/ quantal partner
deb-src http://extras.ubuntu.com/ubuntu quantal main
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Sir, your reply will be vrery very useful to me in creating more better understanding and clarity about the lunux.
Please, reply and OBLIGE.
Thanks in anticipation.
Navin Talati / 27-10-2012

Manfred Hampl (m-hampl) said : #13

The upgrade process (when successful) does several steps.
One of the steps is modifying the sources.list to reflect the new release, and another step is downloading new program versions and installing them.

As far as I can see from your output the sources.list has already been adapted (you can see "quantal"), but the download and installation of the new package versions apparently has not yet been completed (you wrote about "3.2.0-32-generic-pae" kernel version which is the version installed for precise).

You wrote "I also updated and upgraded the system through tty (virtual console)." which seems contradictory to the kernel version.

What I want to suggest is to try updating again.

Switch to a virtual console and issue the command

sudo apt-get update

check if there is any warning or error message, and if it seems ok, issue the command

sudo apt-get upgrade

and again carefully check for error messages.
You might try "sudo apt-get upgrade" even several times, as long as there is a change in the output of the command.

Navin Talati (n-m-talati) said : #14

Sir,
I updated and upgraded again twice through tty1.
The last upgrade output is as under:

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Reading package lists...
Building dependency tree...
Reading state information...
The following packages have been kept back:
  apport apport-gtk aptdaemon apturl apturl-common baobab checkbox checkbox-qt
  colord command-not-found compiz compiz-core compiz-gnome
  compiz-plugins-default couchdb-bin cpp cpp-4.6 cups cups-bsd cups-client
  cups-filters dbus dconf-gsettings-backend dconf-service debhelper digikam
  digikam-data dolphin dpkg-dev empathy empathy-common enblend enfuse eog
  erlang-base erlang-crypto erlang-inets erlang-mnesia erlang-public-key
  erlang-runtime-tools erlang-ssl erlang-syntax-tools erlang-xmerl evince
  evince-common evolution-data-server evolution-data-server-common g++ g++-4.6
  gcc gcc-4.6 gcc-4.6-base gettext gettext-base gimp gimp-data
  gir1.2-gnomebluetooth-1.0 gir1.2-gtk-3.0 gir1.2-peas-1.0 gir1.2-rb-3.0
  gir1.2-totem-1.0 gir1.2-unity-5.0 gnome-bluetooth gnome-control-center
  gnome-control-center-data gnome-desktop3-data gnome-disk-utility
  gnome-font-viewer gnome-keyring gnome-nettool gnome-online-accounts
  gnome-orca gnome-screensaver gnome-settings-daemon gnome-system-log
  gnome-user-share grub-common grub-pc grub-pc-bin grub2-common
  gstreamer0.10-plugins-bad gtk2-engines-pixbuf gvfs gvfs-backends gvfs-bin
  gvfs-common gvfs-daemons gvfs-fuse gvfs-libs gwibber gwibber-service
  gwibber-service-facebook gwibber-service-identica gwibber-service-twitter
  hugin hugin-data hugin-tools icedtea-plugin imagemagick indicator-appmenu
  indicator-datetime indicator-messages indicator-printers irqbalance katepart
  kde-baseapps-bin kde-baseapps-data kde-runtime kde-runtime-data kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdoctools kipi-plugins kipi-plugins-common
  konqueror konqueror-nsplugins language-selector-common
  language-selector-gnome libatk-adaptor libclass-load-perl libcompizconfig0
  libcups2 libcups2-dev libcupsimage2 libcupsimage2-dev libdconf-dbus-1-0
  libdecoration0 libdpkg-perl libfolks-eds25 libgail-3-0 libgail-common
  libgail18 libgcc1 libgck-1-0 libgcr-3-1 libgdata13
  libgeo-googleearth-pluggable-perl libgettextpo0 libgexiv2-1 libgimp2.0
  libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgnome-control-center1
  libgoa-1.0-0 libgoa-1.0-common libgomp1 libgpod-common libgpod4
  libgstreamer-plugins-bad0.10-0 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libgtk2.0-0 libgtk2.0-bin libgtkmm-3.0-1 libhsqldb-java
  libkatepartinterfaces4 libkcalcore4 libkcmutils4 libkde3support4
  libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkfile4 libkgeomap1 libkhtml5 libkidletime4 libkio5
  libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4
  libkntlm4 libkonq-common libkonq5abi1 libkonqsidebarplugin4a libkparts4
  libkpty4 libkrosscore4 libksane0 libktexteditor4 libnepomuk4
  libnepomukquery4a libnepomuksync4 libnepomukutils4 libopencv-calib3d2.3
  libopencv-core2.3 libopencv-features2d2.3 libopencv-flann2.3
  libopencv-highgui2.3 libopencv-imgproc2.3 libopencv-legacy2.3
  libopencv-objdetect2.3 libopencv-video2.3 libpam-winbind
  libparams-validate-perl libpeas-1.0-0 libplasma3 libplymouth2
  libpoppler-glib8 libquadmath0 libraptor2-0 librdf-kml-exporter-perl
  librdf-query-client-perl libreoffice-pdfimport libsane libsane-common
  libsane-dev libsolid4 libsoprano4 libstdc++6 libstdc++6-4.6-dev
  libstreamanalyzer0 libstreams0 libthreadweaver4 libtiff4 libtiff4-dev
  libtiffxx0c2 libtotem0 libunity9 libwbclient0 libxatracker1
  linux-generic-pae linux-headers-generic-pae linux-image-generic-pae
  marble-plugins metacity nautilus nautilus-data nautilus-sendto
  nautilus-sendto-empathy network-manager-gnome onboard overlay-scrollbar
  plasma-scriptengine-javascript plymouth plymouth-label poppler-data
  poppler-utils procps python-apt python-aptdaemon
  python-aptdaemon.gtk3widgets python-debian python-pyexiv2
  rapid-photo-downloader rhythmbox rhythmbox-data rhythmbox-mozilla
  rhythmbox-plugin-cdrecorder rhythmbox-plugin-magnatune
  rhythmbox-plugin-zeitgeist rhythmbox-plugins rpm rpm-common rpm2cpio
  samba-common seahorse shotwell smbclient software-properties-common
  software-properties-gtk soprano-daemon system-config-printer-udev
  thunderbird thunderbird-globalmenu thunderbird-gnome-support
  thunderbird-locale-en totem totem-common totem-mozilla totem-plugins
  transmission-common transmission-gtk ubuntu-wallpapers unity unity-common
  unity-lens-applications unity-lens-files unity-lens-music unity-lens-video
  unity-scope-musicstores unity-scope-video-remote unity-services upower
  usbmuxd vlc-nox vlc-plugin-notify vlc-plugin-pulse whoopsie winbind
  xdiagnose xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-geode xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-s3 xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware xz-utils
0 upgraded, 0 newly installed, 0 to remove and 329 not upgraded.
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I restarted the machine every time. 329 packages' "NON UPGRADED" status remains the same since the problem arised.
Is there any method to upgrade these 329 packs? Probably that may solve the problem.
Navin Talati 29-10-2012

Manfred Hampl (m-hampl) said : #15

The output that you have does not come unexpected.
You have to know that "apt-get upgrade" performs upgrades on packages only if there is no need to uninstall other packages. In cases like yours with an upgrade to a new release it is very likely that some old outdated packages have to be removed and be replaced by other newer packages. The command to allow apt-get to remove obsolete packages is

sudo apt-get dist-upgrade

You should try running that command. If you are lucky it will upgrade all packages to the quantal release, but it might as well fail with error messages.

Navin Talati (n-m-talati) said : #16

Sir,
the command "sudo apt-get dist-upgrade" worked very nicely.
It Upgraded 327, Newly Installed 221, Removed 24 and Not Upgraded 0 (Is it not contradictory that " Upgraded 327 & Not Upgraded 0" ? Why so ? or What is the meaning?)
The Distro upgraded with additional 319 MB download and 394 MB on the disc.
The system was restarted. and the GRUB / Option screen seen as under:
(GNU GRUB Version 2.00-7ubuntu11)
Booting/Loading Options are as follows
Ubuntu
Advance Options for Ubuntu
Memory Test (memetest86+)
Memory Test (memetest86+) Serial console 115200
Win.7
Win XP
Then the login screen comes through "Ubuntu" selection and shows Ubunty 12.10
Now I am able to open Terminal (Ctrl + Alt + T )
sudo apt-get update and sudo apt-get upgrade works normally. It shows system fully updated bur a NEW PROBLEM has been arised. An ICON BAR from the top and LAUNCHER from Left-side of the DESKTOP is DISAPPEARED !
Is there any specific TRICK in the new version to bring them back on the desktop ?
 Navin Talati / 31-10-2012

samuel (samuel-h) said : #17

try opening a terminal and run unity --reset

Navin Talati (n-m-talati) said : #18

It shows the ERROR as under:
------------------------------------------------------------------------------------------------------
navin@navin:~$ unity --reset
ERROR: the reset option is now deprecated
navin@navin:~$
------------------------------------------------------------------------------------------------------
This may be due to the undermentioned command I run
------------------------------------------------------------------------------------------------------
navin@navin:~$ sudo apt-get install --no-install-recommends gnome-panel
[sudo] password for navin:
------------------------------------------------------------------------------------------------------
The present status of the above comman is as under :
------------------------------------------------------------------------------------------------------
navin@navin:~$ sudo apt-get install --no-install-recommends gnome-panel
[sudo] password for navin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
gnome-panel is already the newest version.
The following packages were automatically installed and are no longer required:
  g++-4.6 icedtea-6-plugin libattica0.3 libauthority-shared-perl
  libavahi-client-dev libavahi-common-dev libbabl-0.0-0 libbloom-filter-perl
  libboost-filesystem1.46.1 libboost-python1.46.1 libboost-regex1.46.1
  libboost-signals1.46.1 libboost-system1.46.1 libboost-thread1.46.1
  libcelt0-0 libclass-load-perl libclass-singleton-perl libcrypt-gpg-perl
  libdatetime-format-w3cdtf-perl libdatetime-locale-perl libdatetime-perl
  libdatetime-timezone-perl libexif-dev libfile-slurp-perl libgegl-0.0-0
  libgeo-distance-perl libgeo-distance-xs-perl libgetopt-simple-perl
  libglew1.5 libgphoto2-2-dev libhttp-link-parser-perl libhttp-lrdd-perl
  libicon-famfamfam-silk-perl libieee1284-3-dev libjbig-dev libjpeg-dev
  libjpeg-turbo8-dev libjpeg8-dev libkdcraw20 libkexiv2-10 libkipi8
  liblzma-dev libmarblewidget13 libmath-round-perl
  libmodule-implementation-perl libnepomukdatamanagement4 libopenspc0
  libparams-validate-perl libparse-recdescent-perl libpng12-dev
  librdf-prefixes-perl librdf-query-client-perl librdf-query-perl
  librdf-rdfa-generator-perl librdf-trineshortcuts-perl librpmio2
  libservlet2.5-java libstdc++6-4.6-dev libtiff4-dev libtiffxx0c2 libtiffxx5
  libtry-tiny-perl libusb-dev libv4l-dev libx264-120 libxml-atom-owl-perl
  libxrd-parser-perl libyaml-libyaml-perl libyaml-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
navin@navin:~$
---------------------------------------------------------------------------------------------------------
If this is the unwanted stuff I have applied, HOW TO RECTIFY AND RESET THE DESKTOP ?
Please reply.
Navin Talati / 31-10-2012

Navin Talati (n-m-talati) said : #19

Further GUIDANCE is eagerly awaited.
Navin Talati / 03-11-2012

Navin Talati (n-m-talati) said : #20

Friends,
This has reference to the following initial questions asked on the launchpad.net
(1).What to do if Reset Option is Deprecated ? Question #213078
And
(2).How to detect System Tray ? Question #211868
Problems arised while interruption and failure of power during the upgrading of Ubuntu 12.04 to 12.10 through Update Manager. Different actions were taken during the course of various suggestions and advises and guidance provided by the experts. All step-wise detail is well explained in full text under the above questions. Lots of changes were also caused due to the stuffs applied as per suggestions and many other experiments I carried out in order to solve the problem. The main focus was on getting reset original formate and look after upgradation. Googling was also carried out to resolve the matter. Finally it could be regained as under:
In a terminal I run “ccsm”.
Window opened.
Many of the options were UN-ticked. (i.e. Not Ticked)
Sequentially I went on ticking the options.
Warned interfering/conflicting options were selected in favor of avoiding the conflicting situations.
Accordingly made all ticked at the most default balanced status.
All of a sudden, the Laincher at the Left and Toolbar at the top of the desktop appeared.
Finally I applied the stuff “ sudo shutdown -r now
The machine shutdowned and restarted.
And I got the LOST APPEARANCE
At present the problem is SOLVED.
An ICON BAR at the top and LAUNCHER at Left-side of the DESKTOP is RE-APPEARED ! which was already there in Ununtu 12.04.
Of course, this may not be the pure result of the only above TWO commands but I am sure that everybody who suggested different solutions and made me applying different stuffs would have certainly made favorable changes leading last two stuffs in becoming determinants to achieve the goal.
ONCE AGAIN “MANY MANY THANKS” TO ALL OF YOU.
Navin Talati /04-11-2012