How to load "Ubuntu" Session?

Asked by Navin Talati on 2012-10-20

The problem arised while upgrading the O.S.
I run Ubuntu 12.04 on my machine. All are well aware that Ubuntu 12.10 is made available. To upgrade from Ubuntu 12.04 to 12.10, I opened/launched the Update Manager. for higher version installation/upgradation, I entered to upgrade to the hi9gher version through U.M. The process was nicely going on. As almost more then 70 % of the fatching process was over, suddenly the power failure took place and the system was shut-down before I switch it off through command. After the restoration of the power, it was Ubuntu 12.04. On opening the U.M., partial upgrade option was available. I opted through Terminal - sudo apt-get update and sudo apt-get upgrade. The process completed. Exited the terminal. To complete the installation, I restarted the machine, The login screen appears, but after writing the password, and giving the 'enter' there comes a warning/notice appears as ---> [Fail to load session "Ubuntu"]. I tried through recovery mode in Grub, but does not give any success.
Please,
(1) Guide me with full detail and required commands (if any) about how to get ride of this difficulty arised?
(2) Show me the way to effectively Login and Upgrade the OS to Ubuntu 12.10

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-desktop Edit question
Assignee:
No assignee Edit question
Solved by:
Navin Talati
Solved:
2012-10-21
Last query:
2012-10-21
Last reply:
2012-10-20

Please select unity-2d by clicking on the little ubuntu circle icon it may solve...
then try this:
http://riveridea.wordpress.com/2012/03/22/how-to-solve-failed-to-load-session-ubuntu/

Navin Talati (n-m-talati) said : #2

By clicking on the tiny icon - a ubuntu circle it shows only TWO options - 'Back' and 'Ubuntu'

Navin Talati (n-m-talati) said : #3

I tried the commands given in the above link. Initially none of them worked to give positive result. My machine has also Win-7 as OS. I connected Internet through it and rebooted the system to login through Ubuntu. Then these command worked:
First I opened virtual consol, text mode only as tty1 by CTRL+ALT+F1
Secondly, I entered following first three commands as mentioned in the link one by one

sudo apt-get update
sudo apt-get install ubuntu-desktop
sudo apt-get -f install
sudo dpkg-reconfigure ubuntu-desktop
sudo reboot

I could not get the result. The warning [Fail to load session "Ubuntu"] reappeared as it was.

Thirdly, I entered/tried next three commands one-by one

sudo apt-get install gnome-session
sudo apt-get install lightdm
sudo apt-get install unity-greeter
sudo dpkg-reconfigure lightdm

Finally I got the Login screen for UBUNTU 12.10
So as per the question, [Fail to load session "Ubuntu"] is solved.
But the standard icon bar at the top of the desk-top and launcher bar at the left side of the desk-top disappeared. This I am putting as a seperate question.
Thanks to you all.
 Navin Talati / 21-10-2012