Jin.jar used for playing chess has delayed sound on ubuntu.

Asked by jerry coppa on 2012-10-10

I use JIN as my interface to the internet chess club. On slackware the sound and the move happen in the correct order. When using ubuntu to move sound is delayed two or three moves then trigger. I've noticed this since I started using ubuntu 9. It happens on two seperate platforms. It's one of the reasons I keep going back to slackware and microsoft (for chess sanity, I play a lot of speed chess). If this issue can be overcome, I may finally cut down on the different os's running in my house.

Jerry Coppa

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-desktop Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-10-11
Last query:
2012-10-11
Last reply:
2012-10-11

Have you tried the Unity2D session?

jerry coppa (jerry-coppa) said : #2

I apologize, I don't know what the Unity2D session is. I'll see what I can find out and get back to you.

You select it on the login screen.

jerry coppa (jerry-coppa) said : #4

I followed the wiki instructions and had to figure out how to use the icon to the right on the login to select unity2d. Still did not work. I still get delayed sound when playing a game of speed chess. It may be the program I'm using but it runs like a charm on slackware or windows but not ubuntu.

What is the output of:

java -version

Thanks

jerry coppa (jerry-coppa) said : #6

I'm running 12.04 of ubuntu
the output of java -version is
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-1ubuntu0.12.04.1)
OpenJDL 64-Bit Server VM (build 20.0-b12, mixed mode)

Have you tried Oracle Java?

http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

You are currently using OpenJDK.

jerry coppa (jerry-coppa) said : #8

After install oracle java the sound and the move synced up. Thanks to all.