standard account automatically reverts to administrator

Asked by Still2L on 2012-09-30

I recently changed an account that I use regularly (for ease of explanation, hereonafter known as "Account Reg") from Adminitrator to Standard as I learnt it is better for security. I created a new Administrator account (for ease of explanation, hereonafter known as "Account H") before converting my original account to Standard.

However, each time I restart the computer, the account that I normally logs into, Account Reg, has the status reverted back to Administrator automatically. I've tried changing the status of Account Reg to Standard in User Accounts many times, both from within Account Reg and Account H, but the user privileges of Account Reg automatically revert back to Administrator each time the computer is rebooted.

I suspected virus infection and used Clamscan to no avail.

I'm using 12.04 on a MSI Wind Netbook. I've been using 12.04 a few months now and before that upgraded through 10.04 to 10.10, 11.04, 11.10 over a 2-year period.

I'd appreciate any advice. Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-desktop Edit question
Assignee:
No assignee Edit question
Solved by:
Still2L
Solved:
2012-10-06
Last query:
2012-10-06
Last reply:
2012-09-30

As the Reg account, run:

groups

What is output?

Thanks

Still2L (maildtfam-ljx) said : #2

xxx adm dialout cdrom plugdev lpadmin admin sambashare
where xxx is user id at login

Thanks.

then add the user to the sudo group and you will be ok

Still2L (maildtfam-ljx) said : #4

I'm sorry that I may not be as familiar with the process. Which user to add to sudo group?

When I changed Account Reg to Standard, I had thought I removed Account Reg from sudo group and by changing Account H from Standard to Administrator, I had added Account H to sudo group.

I did the changes mentioned above through User Accounts. Is that not the right way to do it?

Thanks.

You will need to be able to run admin commands and run:

sudo usermod -a -G sudo username

Next time you log in, you will be in the group and have admin access

Still2L (maildtfam-ljx) said : #6

Think I understood the problem. I made the changes through the GUI of User Accounts before and there are limitations as to what one can change and see what the changes really involve through this method.

Under Administration>Users & Groups>Advanced Settings>User Privileges, I noticed that only Account Reg was allowed to "Administer the system" (Genuine Root privilege perhaps?). Although Account H was designated as Administrator, under its User Privileges, somehow the privilege to "Administer the system" was not checked.

Therefore, in effect only Account Reg was the only account allowed to Administer the system; Account Reg was the only real administrator of the system.

This difference was not noticable from GUI of User Accounts, which was how I made the changes. One can only see the differences if one tries to make the changes through GUI of Users & Groups instead.

I first checked the privilege to "Administer the system" of Account H and unchecked the privilege to "Administer the system" of Account Reg and so far the problem does not recur. The need to assign the privilege to Account H first then remove the privilege from Account Reg is, what appears to me, because Ubuntu has this built in as a safety - so that at least an account that has the privilege is available at any given time.

Thank you, actionparsnip, for your attention and assistance. I do apologize that I don't have enough experience and background to comprehend your suggested solution but your original suggestion to run <groups> helped me to understand the problem better.

I think if there is no further comment, I should close this query as "Problem Solved"?

Still2L (maildtfam-ljx) said : #7

The problem is considered solved because so far the Account Reg doesn't revert to Administrator automatically with each reboot.

In my case, for someone who is still more comfortable with GUI, key to troubleshoot/address similar similar problem is to access Users&Groups to check User Privileges of each account.

There should always be at least one account that is allowed to "Administer the system" under User Privileges and that should only be assigned to an account that is meant to be the Administrator account. My mistake was the Administrator account intended (Account H in my scenario here) was not assigned the privilege to "Administer the system" and therefore since I had only a Standard account (Account Reg in my scenario here) that was assigned the privilege to "Administer the system", I could not just revoke the privilege of the Standard account because then the pc would not have any user that is able to "Administer the system".