computer wont boot

Asked by Eric Vallon on 2012-02-05

I had an issue in which I could not update. This was solved. So I updated. Now the computer will not boot. I can get it to boot with the live CD but would really like to get to my old files before reinstalling Ubuntu. This is what I get as it tries to boot.
Additional executable binary formats binfmt-support
FATAL: could not load /lib/modules/2.6.35-32-generic/modules.dep: No such file or directory

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-desktop Edit question
Assignee:
No assignee Edit question
Solved by:
Chris
Solved:
2012-02-05
Last query:
2012-02-05
Last reply:
2012-02-05
Best Chris (fabricator4) said : #1

I'm not sure why it's look at the dep file on boot, but obviously it's missing.

To copy your files to an external hard drive (or another partition if you have one) Boot off the LiveCD and open File manager. You should see on the left any other partitions that are readable but not yet mounted: eg "xxxGB filesystem" Click on this and it should open. If you've got the partition with your /home directory on it you should be able to navigate to /home/username. Make sure all your files are there (if not, then you might be on the wrong partition). Press <ctrl>h and you should be able to see all the dot file (start with a '.') and directories. These are all your configuration files. You can copy these as well if you want to keep the previous configuration, or not if you want to start fresh (something to be said for that on a broken system sometimes).

If you now press <F3> Nautilus will open an extra pane in which you can navigate to the external drive if one is plugged in. You can then copy your files and directories just by dragging and dropping. If the external drive is NTFS or FAT then it will not save any owner information, which actually might be a help when you come to copy the files back into your new /home directory after installation, otherwise the owner will most likely be changed to root. This can be overcome later if it's an issue.

Chris

Eric Vallon (hdlr1) said : #2

Thanks Chris, that solved my question.