No GUI After update

Asked by Mohamed Nagi on 2010-12-16

Hello there
I've just updated my ubuntu 10.04 LTS and after reboot no gui but text mode only is availabe asking me to log in.
I logged in but still no gui. I used this command sudo /etc/init.d/gmd restart but still no gui.
But when I load my os using the third choise in the list - I think it is my os before update - it started normally without any problem. So I think one pf the updates has a conflict.............
ANY IDEAS ??

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-desktop Edit question
Assignee:
No assignee Edit question
Last query:
2010-12-18
Last reply:
2010-12-20
Theodotos Andreou (theodotos) said : #1

It seems that after the update a new kernel was installed that break the GUI on you system. The easiest way is to remove the newer kernel and keep the old one:

In Terminal type:

   dpkg --get-selections | grep ^linux- | awk '{print $1}'

This will list your installed kernels:

linux-firmware
linux-generic-pae
linux-headers-2.6.35-22
linux-headers-2.6.35-22-generic-pae
linux-headers-2.6.35-23
linux-headers-2.6.35-23-generic-pae
linux-headers-generic-pae
linux-image-2.6.35-22-generic-pae
linux-image-2.6.35-23-generic-pae
linux-image-generic-pae
linux-libc-dev
linux-sound-base

Remove the newest version:

  sudo apt-get --purge remove linux-headers-2.6.35-23 linux-headers-2.6.35-23-generic-pae linux-image-2.6.35-23-generic-pae

You can also send us the logs of your Xorg if you prefer to troubleshoot the problem instead. Do this:

  cat /var/log/Xorg.0.log

And paste the output in the pastebin (http://paste.ubuntu.com)

Mohamed Nagi (honeyman-1989) said : #2

Sorry for being late in my response
here is the link you requested http://paste.ubuntu.com/544830/
Waiting for your reply

Theodotos Andreou (theodotos) said : #3

It does not have any (EE) lines which will imply an error. Can you type the "startx" command from CLI and tell me the output. Also try the command "sudo start gdm"

Mohamed Nagi (honeyman-1989) said : #4

Sorry again for being late !!
"startx" through using "su" gave me this
Fatal server error:
Server is already active for display 0
 If this server is no longer running, remove /tmp/.X0-lock
 and start again.

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.

 ddxSigGiveUp: Closing log
----------------------
and "sudo start gdm" in "su" also gave me this
start: Job is already running: gdm
----------------------
I did what you said and removed the newly installed package as you said using dpkg
now I'm running freely but now I'm not free to update as one of my updates is conflicting with my x server...........
by the way, my VGA Driver I downloaded from nVIDIA official site and installed it manually following the recommended steps....
So where is the problem now !!!

Theodotos Andreou (theodotos) said : #5

It seems that your X server is running (!) but somehow you are redirected in CLI. Can you try the command "sudo restart gdm"

Mohamed Nagi (honeyman-1989) said : #6

I tried it but nothing happened. Just as it is, black back with white line !!!

Theodotos Andreou (theodotos) said : #7

OK Let's try this:
Backup the current configuration:

  sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Then restart GDM:

  sudo restart gdm

Can you also show me the output of this command?:

  sudo lshw -c display

Can you help with this problem?

Provide an answer of your own, or ask Mohamed Nagi for more information if necessary.

To post a message you must log in.