which network settings for proxy with authentication ?

Asked by niconil on 2019-09-29

on a ubuntu 18.04 LTS
in a environment with a proxy that requires basic authentification

there is no way to browse internet with Firefox configured to use proxy system

1 - if in network control center panel i put
<user_proxy>:<password_proxy>@<proxy_host>
Firefox do not find the proxy host
(but other apps [wget, chromium, ...] work well)

2 - if in network control center panel i put
<proxy_host>
Firefox find the proxy host and ask for authentication
(but other apps like wget, no success to reach internet)

i have open a bug against firefox
https://bugzilla.mozilla.org/show_bug.cgi?id=1582359

first question :
is <user_proxy>:<password_proxy>@<proxy_host> is a correct value for
settings > network > proxy > http_proxy field ?

second question :
which settings put in gnome control center for all my application uses system proxy setup ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-control-center Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2019-09-30
Last query:
2019-09-30
Last reply:
2019-09-30

You can setup the proxy settings in network manager. Does this help?

wget uses settings in ~/.wgetrc and you can set the proxy there. You can also set bash variables for the proxy

http_proxy
https_proxy

niconil (laurent-combe) said : #3

thanks for your answer
no is does not help, you not answer to the two questions

i would like my ubuntu applications (wget, vscodium, evolution, firefox, pidgin, ...) uses proxy system
(because my proxy environment may change and i do not want to set proxy param in all apps each time)
at this time, i'm focus on Firefox

wget get his proxy setup from environment varaibles and no particular problem with it

i search which settings i have to declare in "ubuntu settings > network > proxy" to have a firefox working with "use proxy from system" ?
i suspect that there is no correct answer and there is an hidden issue

i open a bug against firefox, please read it there is some info in it
https://bugzilla.mozilla.org/show_bug.cgi?id=1582359

How does

"wget uses settings in ~/.wgetrc and you can set the proxy there"

Not answer

i would like my ubuntu applications (wget

?

Manfred Hampl (m-hampl) said : #5

If all applications work with the same settings except Firefox, then you need only to set Firefox to use a different proxy definition in its settings.
So there is no need "to set proxy param in all apps each time", but just once for Firefox and once for all other applications.

niconil (laurent-combe) said : #6

ok firefox do not work with the mechanism provided by ubuntu
so let's try to do differently ???

if i post here, it's to try to find a solution to correct this

i would like that firefox works with system proxy defined by ubuntu
i'm not saying it's a problem of ubuntu

i just asking first if it's correct too put
<user_proxy>:<password_proxy>@<proxy_host>
as string defining proxy in "ubuntu settings > network > proxy > http_proxy"

but difficult to have a answer to this

niconil (laurent-combe) said : #8

my english is certainly very bad and i don't succeed to be understand

i'm not interesting howto configure proxy for wget or another app
i do not ask a such question here

i just would like to have the answer to the following question

in a environment with a proxy that need authentication, is it correct to set :
<user_proxy>:<password_proxy>@<proxy_host>
as string defining proxy in "ubuntu settings > network > proxy > http_proxy"
(or is this field just dedicated to the host part only ?)

doc in ubuntu are not precise on this point
on the web it seems to be correct
but i would like to check this information

You can set what you are saying as a bash variable (as I said before). Yes that will be the correct format.

niconil (laurent-combe) said : #10

thanks,

i go back to the see firefox guys to ask them to correctly decode this format
Firefox don't do that !
actually Firefox is only waiting for a host in this field

why do you talk about a bash variable ?
i just ask about the field in Gnome control center
firefox do not read proxy environment variables on Ubuntu

niconil (laurent-combe) said : #11

ok
i close the case here

firefox confirm the issue
https://bugzilla.mozilla.org/show_bug.cgi?id=1582359

thanks

niconil (laurent-combe) said : #12

Thanks actionparsnip, that solved my question.