Gnome Alert beep not working (and I need a software system beep)

Asked by Arnaud Soyez on 2009-01-20

Hi,

I need a software system (audio) beep (like when I type 'echo -e "\a"' in a terminal for example, it should make a beep sound), I thought gnome could do it because there is an option in the System/Preferences/Sound menu, but it doesn't work.

All my sound devices are working properly (I'm playing music and all that, it's fine and working).
I checked the needed checkboxes in the sound properties (see attachment).
The visual beep is working (but it's really annoying to the eye! that's why I need a software beep).
My hardware speaker is unplugged (I hate it, that's also why I need a software beep).

Thanks!

Question information

Have you already installed the 'beep' package...?

Please first enable the universe repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Community Maintained open source software (universe)"
Close and confirm the repository reload.

Then open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo aptitude update
sudo aptitude install beep

give your user password when requested, you don't see nothing when you type it, then press enter.

------------------------------------------------------

Then to play a beep open a terminal and type:

beep
or
/usr/bin/beep

To get beep usage, type:

man beep

Try it....

Arnaud Soyez (weboide) said : #3

My internal speaker is unplugged, so beep doesn't do anything.

Have you already tried to activate the "terminal bell" in the profile of Terminal...?
Open a terminal and open menu Edit → Profile preferences → General [tab] and check the "Terminal bell" check box...

Using the

echo -e "\a"

i can hear the beep tone coming from my internal speaker... i can't understand what you are looking for...

Hope this helps

Ok... ;-) you don't want to have the usual beep of gnome-terminal coming from internal speaker: the bee must activate the Alert Sound of gnome...

Arnaud Soyez (weboide) said : #6

Thanks for your reply but this is not what I'm looking for.

My internal speaker is unplugged and I don't wish to use it. Instead I want *Gnome* (and not my internal speaker) to make a sound when for example I type echo -e "\a".

I think it could because if you look at this window (screenshot below) it says "alert sound" and you can choose what you want, but it doesn't work!
http://weboide.codealpha.net/files/soundproperties.png

(But note that the Terminal bell check box is checked in gnome-terminal)

Arnaud Soyez (weboide) said : #8

This was not my problem but from this I found the right bug which I linked.
This hasn't solved my problem yet but I'll keep looking and keep this question updated!
Thanks for your help!

Arnaud Soyez (weboide) said : #10

Thanks marcobra, that solved my question.