Can't unlock User Accounts

Asked by Shahar Or on 2012-09-13

I'm running a headless LTSP server. Precise.

Even though my user is in the sudo group, that user can't modify system users using the control center.

The Unlock button in User Accounts is unavailable and pointing at it pops up a tooltip saying "System policy prevents changes. Contact your system administrator".

I've tried two users that are in the 'sudo' group and they both have the same issue. This is both through an LTSP client session and through 'ssh -X <server> gnome-control-center'.

Please help me solve this issue.

Thanks,
Shahar

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-control-center Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-11-19
Last query:
2012-11-19
Last reply:
2012-11-19

Why not do it via SSH / Terminal:

sudo passwd -u username

And the account will be enabled.

Shahar Or (mightyiam) said : #2

Thanks. Perhaps I shouldn't have made this a question at all. Because this looks like a bug.

What I mean is not enabling users. It is the "Unlock" button in the GUI. Which enables changes once authenticated.

try:

gksudo gnome-control-center user-accounts

Shahar Or (mightyiam) said : #4

Ok, that's a nice workaround. Thanks, actionparsnip.

Is that meant only as a workaround or will that help solving the issue? What is this "system policy" referring to?

Shahar Or (mightyiam) said : #5

Thanks actionparsnip, that solved my question.

No idea, I just know what works. I don't use those GUI things, they take too long to do most things.

anthony (aedwards521) said : #7

hi.im having the same problem.is there a command i can permanently unlock the user account settings?