Keyboard shortcuts get reset to "Deactivated" after restart

Asked by Daygan on 2012-08-23

Every restart, my keyboard shortcuts (Navigation, Universal Access, Windows) get reset to "Deactivated". The end result is that every other restart, I have to re-configure the shortcuts that I want to use. It's every other restart and not every restart because evidently, after I restart once, the shortcuts that I configured during the previous session will be adopted during the current session, but the actual configured settings in Keyboard shortcuts become deactivated. During this session, I will usually not take time to reconfigure the shortcuts in the Keyboard shortcuts menu, because they are working for me, but then a restart results in a loss of all shortcut effectiveness for those that had been previously configured in the Navigation, Universal Access, and Windows categories.

Here's the simple explanation:

Start computer > Keyboard shortcuts ineffective > Configure keyboard shortcuts to my preferences > Keyboard shortcuts effective > restart computer > Keyboard shortcuts effective > Keyboard shortcut settings have returned to display as "Deactivated" > restart computer > Keyboard shortcuts ineffective > Reconfigure keyboard shortcuts to my preferences.

Is there a setting somewhere that I have set incorrectly, thus resulting in my problem? Is this a bug? It's not eactly the same as the bug mentioned here: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/965921 , as my keyboard shortcuts actually do work when they are configured.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-control-center Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-08-26
Last query:
2012-08-26
Last reply:
2012-08-24

What do your shortcuts achieve?

Daygan (sheerzeal) said : #2

If you mean the shortcuts that I configure, they're really just basic shortcuts that should exist and be effective by default. Alt-Tab (for switching windows), Super+D for show desktop, and Alt+F4 for close window. I'm using Unity 2D, and many of those shortcuts have been taken over by Unity in the 3D version but seem to revert to gnome-shell in the 2D version, so I need them to be effective in gnome-shell keyboard settings.

ALT+TAB is configured in CCSM as are most of the others you are making.

Daygan (sheerzeal) said : #4

This is true. However, I do have Compiz Configuration Settings Manager set to allow Alt-tab to switch windows, and it still does not work. That, however, is not the root issue here. The issue is that the keyboard shortcuts should not be resetting to 'default' upon reset.

If you make a fresh Ubuntu user, is it the same?

Daygan (sheerzeal) said : #6

I should have tried this from the beginning. No, with a fresh user, the keyboard shortcuts do not get set to "disabled" after a restart. What might I do to determine what configuration in my regular user account might be causing this issue?

N1ck 7h0m4d4k15 (nicktux) said : #7

Hi ,
from your problematic user , open a terminal and run
+++++++++++
unity --reset
+++++++++++
leave it for 10 - 15 minutes (maybe longer).
See if this fixed your problem. Maybe wants a reboot (or logout - login)
Thank you

Daygan (sheerzeal) said : #8

Thanks for the idea, but that did not resolve my problem. It essentially turned my Unity 2D session into a 3D session, in which case Alt-Tab and Unity shortcuts do work, but that's under Unity control, while the gnome-shell keyboard shortcuts did not get fixed. After restart, any gnome-shell keyboard shortcuts that I manually configured were still reset to the "disabled" configuration.

From my inexperienced perspective, it seems to make sense that, as this is a gnome-shell keyboard shortcuts issue, any resolution involving Unity would be ineffective, as the two are separate. I'm not looking for a Unity 3D workaround; I'm interested in restoring gnome-shell keyboard shortcuts to their proper functionality, such that they do not get disabled every time I restart. Evidently, since the problem is not present in the new user that I created as a test, this problem was created by myself in some settings file or another that I changed, but I'm not sure exactly what setting that is...

Daygan (sheerzeal) said : #9

Perhaps someone can tell me how to reset the gnome-shell keyboard shortcuts settings to "factory settings" i.e. default settings. I imagine that would be the first logical step to try, from my perspective... Perhaps I can uninstall and then re-install whatever controls gnome-shell keyboard shortcuts? I imagine that would be the gnome-control-center - is that correct?

Best N1ck 7h0m4d4k15 (nicktux) said : #10

Hi ,

I know a method to reset all your settings , but you must have in mind you will lose EVERYTHING. Even the wallpaper.

If you want to continue , open a terminal and execute carefully bellow commands

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
gconftool --shutdown
killall -r -I gconf
killall -r -I dconf
tar czf confbackup.tar.gz .compiz* .gconf* .config/dconf/ .config/compiz*
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

above commands it is just a backup of your current settings.

Below command is the reset and a reboot of your system
++++++++++++++++++++++++++++++++++++++++++++++
 rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*
sudo reboot
++++++++++++++++++++++++++++++++++++++++++++++

If for any reason something goes wrong you can always bring back your previous settings from the backup file with these commands
+++++++++++++++++++++++++++++++++++++++++++++
gconftool --shutdown
killall -r -I gconf
killall -r -I dconf
rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*
tar xzvf confbackup.tar.gz
sudo reboot
+++++++++++++++++++++++++++++++++++++++++++++

Maybe it is better to run above commands(for reseting) from the Console mode (Ctrl+alt+F2) , but you must be careful . Do not make a mistake.

Thank you

Daygan (sheerzeal) said : #11

That worked perfectly. Thanks!

HumanPlayer2 (humanplayer2) said : #12

I experience the same pattern of loosing shortcuts (though they do not get deactiveated, but reset to their defaults), however the above solution *does not work for me*.

I've tried setting up a new user, and there I also have the problem (I don't have to restart, log out is enough).

On my primary user, my custom shortcuts remain (I haven't tried on new user). However, I also loose Commands in Compiz' CCSM, along with their keybindings.

I'm running 12.10, 64bit.

I confirm, I also lose my shortcuts and it happens via session many times.