12.04, Keyboard Shortcuts do not work

Asked by Per Wahlström on 2012-05-29

Upgraded from 10.04 to 12.04. Keyboard shortcuts do not work. They show up in Keyboard Shortcuts though.

I have added two Custom Shortcuts:

  "Alt++" and "Alt+-".

which should run a script.

I have also modified keys for Sound and Media, volume down and up:

  "Pause" and "ScrollLock" respectively.

Also tried "Alt+Pause" instead of ScrollLock. ScrollLock will never work as a shortcut (worked fine on 10.04)

Strangely, the "Pause" shortcut always works (increase volume) - the others do not.

It does happen that they do work after a reboot (except for the ScrollLock one), and going to Keyboard Shortcuts Settings, but rarely.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-control-center Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-24
Last reply:
2012-05-30
Per Wahlström (per-wahlstrom) said : #1

If I go and change the shortcut key, then change it back, it works - until I reboot.

Sam_ (and-sam) said : #2

Maybe search bug reports and in case report a new one.
The issue with 'altxxx' may have some conflict with HUD which is assigned to 'alt L'.
Maybe disable HUD and test your custom shortcut again.
#1
System settings - keyboard - shortcuts - launchers
Delete the shortcut <Alt L> or change it.
#2
## If compizconfig-settings-manager is installed.
CCSM - workspace (category) - unity - behaviour - key to show the HUD
Click on <Alt> and deactivate.

Or login to guest account and test custom shortcuts there.

Morten Hansen (mshh80) said : #3

Thanks to Sam - for me it works to use the same shortcuts as in guest account.....

- Sorry for my english but danish is not gut here.... :-)

Per Wahlström (per-wahlstrom) said : #4

Update fixed the issue, except for the still unmappable scroll-lock key.

Per Wahlström (per-wahlstrom) said : #5

I was mistaken, the shortcuts just happened to work across several consecutive reboots, but it seems like random chance whether they do or not. When they don't, remapping them fixes it.

Possible scenario - bootup race condition between loading of shortcuts and something else that "unsets" them.

Can you help with this problem?

Provide an answer of your own, or ask Per Wahlström for more information if necessary.

To post a message you must log in.