Ubuntu 12.04 unstable: how to set the profile of a sound card ?

Asked by Simon Déziel on 2012-04-02

With Ubuntu < 12.04, the Sound menu allows to select various profiles for each sound cards a drop down list in the Hardware tab. I couldn't find this feature in the latest daily-live image of Ubuntu 12.04 (from April 1st).

I'd appreciate if someone would kindly point me where to change this ?

Thanks in advance

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-control-center Edit question
Assignee:
No assignee Edit question
Solved by:
Simon Déziel
Solved:
2012-06-21
Last query:
2012-06-21
Last reply:
2012-06-21

Sounds like a bug. You can use alsamixer to set it in CLI though

Simon Déziel (sdeziel) said : #2

@actionparsnip, thanks for the suggestion but unfortunately I cannot find how to set a card's profile in alsamixer.

What I am interested in is the way to select the "Active Profile" from the "Profiles" list :

$ pactl list cards
Card #0
 Name: alsa_card.pci-0000_00_1b.0
 Driver: module-alsa-card.c
 Owner Module: 4
 Properties:
  alsa.card = "0"
  alsa.card_name = "HDA Intel"
  alsa.long_card_name = "HDA Intel at 0xf2620000 irq 43"
  alsa.driver_name = "snd_hda_intel"
  device.bus_path = "pci-0000:00:1b.0"
  sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
  device.bus = "pci"
  device.vendor.id = "8086"
  device.vendor.name = "Intel Corporation"
  device.product.id = "3b56"
  device.product.name = "5 Series/3400 Series Chipset High Definition Audio"
  device.form_factor = "internal"
  device.string = "0"
  device.description = "Internal Audio"
  module-udev-detect.discovered = "1"
  device.icon_name = "audio-card-pci"
 Profiles:
  output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority. 6000)
  output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority. 6060)
  output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority. 5400)
  output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (sinks: 1, sources: 1, priority. 5460)
  output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (sinks: 1, sources: 0, priority. 300)
  output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (sinks: 1, sources: 1, priority. 360)
  input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority. 60)
  off: Off (sinks: 0, sources: 0, priority. 0)
 Active Profile: output:analog-stereo

This kind of control is available in the GUI in Ubuntu < 12.04 so I think that is a bug/regression as you suggested.

Thanks again.

@Simon, Sorry for the late answer. I only seen this moring and providing an answer.

That problem was already occurred mine. I think it is occurring with Intel cards only.

I have this card: 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04).

I solved that problem, of not being able to select a profile in Audio settings.
I had only a profile for : "Digital Output: S/PDIF" only, no "Analog Stereo Output" like older releases.
And when i select the only available profile, all sound gone.

 I need to logout and login again (after deleting .pulse folder in home directory) to activate the sound.

There is two solutions : (both I tested) as I answer the problem in several question in askubuntu.com site.

------------------
##Solution 1: This is the shortcut solution

*(It worked for me with Only S/PDIF profile, Sound from both headphone and speaker and not being able to switch profile)*

1. Add this ppa by the command

 `sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily`

2, Update packages list. by
 `sudo apt-get update`

3. Then install "alsa-hda-dkms" package:
 `sudo apt-get install alsa-hda-dkms`.

Reboot, And See the result!

------------------------------

## Solution 2: Compiling driver from source

1. Go to Realtek official site:
http://www.realtek.com/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

, accept the disclaimer, then download the audio driver for linux/unix. You need to select version 3 for Kernel 3 or later.

2. Setup necessary tools to compile this driver.

  `sudo apt-get install build-essential gcc make`

3. Extract the downloaded file, run `sudo ./install` file from a terminal after going to the extracted folder to compile the driver.

4. Read the `Readme.txt` file for more information.

5. Reboot your computer to only know that your problem is fixed!
------------------

http://www.realtek.com/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false
-----------------

I have given answer to the same question here: http://askubuntu.com/a/151944/61218

Simon Déziel (sdeziel) said : #4

@Mohammad, thanks for your reply but my problem isn't with the Intel HDA card.

@Simon, Your output suggests that, it is "Intel HDA card". Have you tried them?

Simon Déziel (sdeziel) said : #6

@Mohammad, you are right that the "pactl list cards" I initially gave is for an Intel HDA sound card. The problem isn't with the card itself but with the way to set a "default" profile for it. This question was answered in https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/972554/comments/13 :

"When you select a device it will then become default."

Now the linked bug is about a missing profile for the EMU-404 sound card. This seems to be a regression introduced when the Gnome "Sound" menu was simplified. To simplify the UI, they started removing some of the multiple profiles exposed by a card. Unfortunately the specific profile I needed was also removed from the list even if the driver supports it.

Thanks again