Suddenly Number pad does not work on Ubuntu 11.04 - tried replacing kb

Asked by pragathitech on 2010-12-29

The number pad was working since we installed Ubuntu 11.04 on a x86 machine about a month back.
Suddenly, today, the number pad did not work while using a search option in a Spread Sheet.

First i tried opening calculator - same problem
Restarted the computer - Same Problem
Replaced the Keyboard - Same problem.

Please suggest further trouble shooting or any software update or tweek.
with regards
Pragathi Technologies
Bangalore India.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-control-center Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2010-12-29
Last query:
2010-12-29
Last reply:
2010-12-29

Have you made sure that Number Lock is ON (on the keyboard)?

Is there any application in which the number pad *does* work? For example, does it work in a word processing document?

If you turn Number Lock OFF (on the keyboard), do the 4, 8, 6, and 2 keys in the number pad work properly as arrow keys? For example, in a word processing document, when the blinking cursor is in the middle of a word, pressing the 4 key on the number pad when Number Lock is set to OFF should cause the cursor to move left one character position.

Dear Mr. Eliah Kagan

I could understand that the number key pad has turned to controlling the
mouse cursor whether the num lock is on or off.

it acts like a control to move the mouse cursor 8 up / 2 down / 6 right / 4
left and 1, 3, 7, 9 act to move the mouse cursor diagonally up / down /
right / left.

It behaves the same when we open word processing / calculator or any appn.

How can we disable it to use it as a numerical pad?

Thank u for the speedy reply.

with regards
for Pragathi Technologies
Bangalore India.

On 29 December 2010 14:32, Eliah Kagan <<email address hidden>
> wrote:

> Your question #139458 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/139458
>
> Status: Open => Needs information
>
> Eliah Kagan requested for more information:
> Have you made sure that Number Lock is ON (on the keyboard)?
>
> Is there any application in which the number pad *does* work? For
> example, does it work in a word processing document?
>
> If you turn Number Lock OFF (on the keyboard), do the 4, 8, 6, and 2
> keys in the number pad work properly as arrow keys? For example, in a
> word processing document, when the blinking cursor is in the middle of a
> word, pressing the 4 key on the number pad when Number Lock is set to
> OFF should cause the cursor to move left one character position.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/139458
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Dear Sir,

 Thank you for your concern to take up a course from Pragathi Technologies.

 We offer realtime computer training on different flavours of UNIX like
Solaris, IBM-AIX, HP-UX, with Veritas Volume Manager and Veritas Cluster
Server. Besides, we offer courses in Oracle DBA, SQL/PLSQL, Redhat Linux,
Websphere, Weblogic and IBM Mainframe.

Visit www.pragathitech.com to view the course contents.

Also refer our website to your friends who are interested in taking up the
courses we offer.

with regards

Syed Faheem Jeelani

+91 9538734732

for Pragathi Technologies <email address hidden>

m: +91 9742095494

ll: +91 80 64528888, 42275509
w: www.pragathitech.com
e: <email address hidden>

a: No-7, Vysya Bank Colony, 100ft Road, BTM 2nd Stage, Bangalore-560076

lm: Diagonally Opp to Jayadeva / Opp to State Bank ATM

Just to make sure I understand you correctly: Are you saying that whether or not number lock is on, the number pad acts as though number lock is off? That is, even when number lock is on, pressing 2, 4 6, and 8 on the number pad is like pressing the corresponding arrow keys?

If that is the case, then I have another question: Does pressing the Number Lock key on the keyboard while in Ubuntu change the number lock light on the keyboard, or does it have no effect?

The Num Lock light toggles. but does not have any effect.

the numbers does not act like arrow keys. Rather, they move the mouse cursor
up / down / right / left. and No. 5 acts as if we click a right button mouse
click.

with regards

On 29 December 2010 16:28, Eliah Kagan <<email address hidden>
> wrote:

> Your question #139458 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/139458
>
> Status: Open => Needs information
>
> Eliah Kagan requested for more information:
> Just to make sure I understand you correctly: Are you saying that
> whether or not number lock is on, the number pad acts as though number
> lock is off? That is, even when number lock is on, pressing 2, 4 6, and
> 8 on the number pad is like pressing the corresponding arrow keys?
>
> If that is the case, then I have another question: Does pressing the
> Number Lock key on the keyboard while in Ubuntu change the number lock
> light on the keyboard, or does it have no effect?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/139458
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Ah, I see. It seems that Mouse Keys has been accidentally enabled on your system. Mouse Keys is an accessibility feature that allows people who have trouble using the mouse or other pointing device (or technical problems getting them to work) to move the mouse cursor around and click. It behaves exactly as you are describing.

To disable Mouse Keys and restore the normal function of the number pad, go to System > Preferences > Keyboard to bring up the Keyboard Preferences window. Click the Mouse Keys tab (in the tab bar at the top of the window). Uncheck the checkbox labeled "Pointer can be controlled using the keypad" and click Close.

If that does not solve the problem (or is otherwise unsatisfactory), please let me know.

Done..
Thank you very much

On 29 December 2010 17:17, Eliah Kagan <<email address hidden>
> wrote:

> Your question #139458 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/139458
>
> Status: Open => Answered
>
> Eliah Kagan proposed the following answer:
> Ah, I see. It seems that Mouse Keys has been accidentally enabled on
> your system. Mouse Keys is an accessibility feature that allows people
> who have trouble using the mouse or other pointing device (or technical
> problems getting them to work) to move the mouse cursor around and
> click. It behaves exactly as you are describing.
>
> To disable Mouse Keys and restore the normal function of the number pad,
> go to System > Preferences > Keyboard to bring up the Keyboard
> Preferences window. Click the Mouse Keys tab (in the tab bar at the top
> of the window). Uncheck the checkbox labeled "Pointer can be controlled
> using the keypad" and click Close.
>
> If that does not solve the problem (or is otherwise unsatisfactory),
> please let me know.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/139458/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/139458
>
> You received this question notification because you are a direct
> subscriber of the question.
>

No problem! [This reply is to change status from Open back to Answered.]

System -> Preferences -> Keyboard -> Mouse keys tab ->
unchecked the option - Pointer can be controlled using the Keypad

The problem is solved.. Thank you for your assistance.