How do I reinstall gnome-applets and gnome-applets-data.

Asked by Riverrun on 2007-12-05

My Trash can and Volume Control have disappeared from their respective panals today. I get the following error message: 'The panal encountered a problem when loading the Trash icon. Do you want to delete the settings?'

Googled it; it's a common problem. Reading round the subject and seemingly the answer is to reinstall gnome-applets and gnome-applets-data.

Tried: sudo apt-get install gnome-applets, didn't work.
Tried: sudo apt-get reinstall gnome-applets, resulting in an invalid operation message.

The trash can bit is ok 'cos after a bit of fiddling in Main Menu I found out how to place it on the desktop.

Guys, I need Vol. control.

How do I fix this problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-applets Edit question
Assignee:
No assignee Edit question
Solved by:
Ricardo Cropalato de Melo
Solved:
2007-12-05
Last query:
2007-12-05
Last reply:
2007-12-05

try "sudo aptitude reinstall gnome-applets"

Riverrun (buttimersean) said : #2

Did that and the applets did reinstall. Tried to add Trash, Vol. Control but I get the same error message.

try "sudo aptitude reinstall gnome-applets-data"

Riverrun (buttimersean) said : #4

No luck with: sudo aptitude reinstall gnome-applets-data

Still left with the error message.

try it.

create another user and try to include another applet.

Riverrun (buttimersean) said : #6

Ricardo Ty for the help. Got it! The answer was in Terminal all along but I'm still very new to Ubuntu and I didn't see it and coming from a windows background...well, need I say more!
 A vital package, namely gstreamer was missing. I'd uninstalled it last night in the course of configuring MPlayer to stream TV stations in Firefox.

Thanks again for the help.

The answer was right there for me to see. Still thinking in Windoze. Ubuntu is soooooo cool.

Riverrun (buttimersean) said : #7

Thanks Ricardo Cropalato de Melo, that solved my question.