gnome-volume-control-applet does not run at startup

Asked by Rocko

Binary package hint: gnome-applets

In my Lucid alpha 3 installation, gnome-volume-control-applet does not run when I log in. It runs fine from the command line, though.

I'm using my home directory from Karmic. Has the way to specify that gnome-volume-control-applet should run changed in Lucid, eg does it need to be added to the start up programs?

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 1bd8e90541d49b96c13cbfcc9baf103b
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Sun Feb 28 08:24:05 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
NonfreeKernelModules: nvidia
Package: gnome-applets 2.29.5-0ubuntu1
 PATH=(custom, user)
SourcePackage: gnome-applets
Uname: Linux 2.6.33-generic x86_64

Question information

English Edit question
Ubuntu gnome-applets Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Rocko (rockorequin) said :
Revision history for this message
Rocko (rockorequin) said :

It may be relevant that instead of the volume control applet I now get a keyboard indicator applet that I can't get rid of in the notification area. (I didn't notice it at first because it writes the keyboard layout in black text over black background.)

Revision history for this message
Rocko (rockorequin) said :

OK, it seems that the volume and bluetooth indicators in Lucid now appear in the indicator applet, not in the notification area applet. This is a pain because (a) the network etc indicators appear in the notification area, so now you need both the notification area and the indicator applet, and (b) I don't want the indicator applet to appear in any case. It has an indicator for Evolution mail that I don't want and can't figure out how to get rid of.

Is there a way to configure what appears in the notification area and indicator applets so I can select the notifications I want?

Revision history for this message
Anzenketh (anzenketh) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at if you are uncertain if they are bugs. For help on reporting bugs, see

Revision history for this message
Rocko (rockorequin) said :

I actually think this is a bug (regression), as it appears inconsistent to the user, unlike in previous versions of Ubuntu. It is messy needing to run two separate applets as notifications areas - especially since neither of them appear to be configurable.


* Why has Lucid's Gnome installation split the notification area into two separate applets?

* How do we fix this problem? Is it for instance possible to configure the individual applications (volume control, bluetooth, network manager, pidgin, skype, etc) to use one or the other?

Revision history for this message
Sam_ (and-sam) said :

Actually the intention is to improve user desktop experience, e.g. 'clean up' of notification area. Providing a menu doesn't take so much space off the panel.

All projects.

Other specs.


To make volume control appear in notification area, an entry in startup applications should help.
cmd is:

Revision history for this message
Rocko (rockorequin) said :

Thanks for the info. So now I have a few more questions...

Is the indicator-applet is supposed to replace the notification area applet altogether? Does this mean it will automatically intercept proprietary applications like Skype that are unlikely to change their code to comply, or will we always have to run two applets to get everything?

Can we configure the indicator-applet to filter out show certain applications? For instance, I don't want to see the "email" symbol that shows gwibber etc, as it takes up too much real estate.

Is there a way to make the indicator applet more compact? The same number of icons on it take up much more room than the notification area, as the spacing between them is higher. Again, this means it is taking up valuable real estate unnecessarily.

Will there be an option to choose either a menu (new style) or an icon (old style)? While it initially might seem a good idea to group together related apps (gwibber, pidgin, etc), it means it is slower for the user to access frequently-used applications.

I'd like to get the bluetooth applet appearing in the notification panel as well. Can I ask that here or should I ask another question?

Out of interest, is this mentioned in the alpha release notes and I just missed it? I think a substantial UI change like this should be mentioned, because this kind of change sure looks like a bug when you first see it.

Revision history for this message
Sam_ (and-sam) said :

Some answers can be found in the content of mentioned links; for further requests, feedback refer to ubuntu-desktop team.
Release notes mention new features refering to blueprint list.
Same procedure as for volume may work for bluetooth (supposed to be enabled already in startup applications).

Revision history for this message
Rocko (rockorequin) said :

Too many questions all at once? :) I did read some of those links but wasn't entirely sure what they propose and wanted to check it.

The bluetooth applet does indeed run at startup, and in Lucid it only sends its output to the indicator applet - they've split up the programs responsible for displaying the volume control (one for indicator applet, one for legacy notification area), but not the bluetooth applet. I'll ask it in another question.

How can I refer feedback to the ubuntu-desktop team?

Revision history for this message
Ben (ben-lemire) said :

Is anything going to happen with this? I miss my volume indicator icon in the notification area.

Revision history for this message
Oliver Joos (oliver-joos) said :

The notification area is subject to change at the moment (April 2010):

You can use the original volume applet in Lucid by adding the command "gnome-volume-control-applet" as startup application (Gnome menu "System - Preferences - Startup Applications").

After reading the linked article I understand and look forward to a new solution. What I really dislike is that the old solution is crippled before the new one is ready to be compared. Won't the new indicator applet be good enough to win a fair comparison, or what??
Canonical, please be more diplomatic with such obvious changes. If you "nuke the whole site from the orbit" (see linked article) then the collateral damage might be hard to predict.

Revision history for this message
Anthony Glenn (aglenn-pcug) said :

I am using Natty, but I dislike the "Unity" interface, so I changed to "Ubuntu Classic (no effects)" in the Login Screen. I keep my system fully updated. "Volume Control - Show desktop volume control" is right there in Startup Applications and it is checked to show that it should be running on startup.

Alas, no Volume Control icon shows up in the Notification area on startup. To get it there, I have put a launcher on the desktop to execute the command "gnome-volume-control-applet" when I click the launcher. Every time I want the Volume Control icon to show up after startup, I have to click the launcher to make it happen. This is plainly not acceptable to ordinary users.

By the way, the Printer applet, is also supposed to start, but does not. When I do the command manually, I get:

> system-config-printer-applet
No protocol specified
/usr/lib/pymodules/python2.7/gtk-2.0/gtk/ GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
system-config-printer-applet: failed to connect to session D-Bus

However, the Printer applet is not relevant here.

This problem with the Volume Control applet is definitely a bug. Please fix. Please classify correctly.

Come on Ubuntu. Your market share is currently sitting at under 1%. It is not going to get a lot higher if you have serious bugs, like this one, not fixed for over a year. It is a bad mistake, to be unresponsive to a bug report and reclassify it as a question (which did not get answered), as has happened here.

Can you help with this problem?

Provide an answer of your own, or ask Rocko for more information if necessary.

To post a message you must log in.